Sign in with
Sign up | Sign in
Your question

My games won't run properly

Tags:
  • PC gaming
  • Dell Studio Xps
  • Video Games
Last response: in Video Games
Share
Anonymous
February 16, 2012 6:32:22 AM

Hello guys,

I have an laptop Dell XPS : 6GB RAM(1066GHZ) ; Video Nvidia Geforge 555M and an i7 2.0Ghz (second generation).

The problem is that , when I run a game, in the menu all things are good. But when I enter in a mission, or start a campaign , it moves like a snail.

This happens ,since I have reinstalled my windows 7.

I have installed all drivers.(are all new)
I have installed directx.

More about : games run properly

February 16, 2012 7:18:14 AM

Its an interesting problem, try running the game in "administrator" mode (solved a lot of random problems for me).

Can you download a CPU monitor to see if your CPU or GPU even react to stress from a game?
February 16, 2012 1:08:34 PM

1. which game is this?
2. did you install optimus drivers and make sure to set the game to run on dedicated GPU vs intel HD?
Related resources
February 16, 2012 2:12:05 PM

some games are very heavy for notebook graphics, so first of all make sure you are using latests nvidia optimus drivers, second, if the game is lagging, go lowering the graphics up to a level where you can play it at acceptable framerates.

Some games may be lagged even at very low graphics, so you can lower the resolution or search online for performance fixes (lowering graphics in the game config file and other)

if you are saying that the game is running at good frames but the controls response is very slow, try removing vertical sync before lowering graphics.
February 16, 2012 3:00:46 PM

It sounds like you may be inadvertantly running off of the Intel HD graphics instead of your dedicated card if you do indeed have all of your drivers installed correctly after the reinstall of W7 you mentioned above.

Under your power options make sure you have selected High Performance and not Power Saving or some other setting that would switch you to integrated.
!