Sign in with
Sign up | Sign in
Your question
Closed

Skyrim FPS on my laptop is Horrible

Last response: in Video Games
Share
February 22, 2012 4:22:54 PM

Hello,

I just bought Skyrim for my new laptop and the fps is horrible. I tried tweaking in different ways but it doesn't seem to have any effect, what could be the problem? Or any tips to increase performance? It even rons choppy on the lowest settings possible. Updated my drivers, etc.


My specs are:
Asus X73S
OS: Windows 7 64bit
CPU: Intel Core I7-2630QM, 2.0GHz
RAM: 6GB
HDD: 640GB
Nvidia Geforce GT540M Cuda 1GB

Would really apreciate it if you could give me a push in the right direction.
a b D Laptop
February 22, 2012 4:48:17 PM

make sure the game is running on your dedicated card vs intel onboard.

what driver version have you updated to?

what resolution and settings are you playing the game on?

have you patched the game to 1.4 patch?
February 22, 2012 5:00:56 PM

Hi Antizig,

I updated my videocard driver to 295.73.

My Skyrim is currently v1.4

My settings are the following:
Resolution: 1600x900
Antialiasing: 8 Samples
Anisotropic: 8 Samples

Texture: High
Radial Blur: Medium
Shadow: High
Decal Qt: High

FXAA enabled


How do I make sure its running on the dediated card vs intelboard? (still learning the ropes)

Related resources
a b D Laptop
February 22, 2012 5:24:01 PM

dedicated vs onboard is in optimus options. I don't know if you can find it in control panel options or if it's part of nvidia control panel or intel hd control panel.

disable antialiasing (your 540 will not be able to do 8x AA at that resolution), only keep fxaa enabled (it does a great job as is). drop shadow quality to medium.
February 22, 2012 5:41:47 PM

It's a tad better now. But still very choppy. What about Anisotropic?

I still couldn't find out the Dedicated vs onboard. But this is just the one game giving me trouble. Should be alright then I assume?
a b D Laptop
February 22, 2012 5:54:49 PM

you can turn down anisotropic but it doesn't impose a significant load on the GPU (disable it and see if you can deal with that level of graphics, if not, notch it up)

according to this


Uploaded with ImageShack.us
you might want to turn down the resolution and try the medium preset
a c 249 D Laptop
February 22, 2012 6:01:08 PM

Hi :) 

The honest answer is that for high end gaming NO LAPTOP will even come close to a gaming PC....

All the best Brett :) 
a b D Laptop
February 22, 2012 7:59:39 PM

Brett928S2 said:
Hi :) 

The honest answer is that for high end gaming NO LAPTOP will even come close to a gaming PC....

All the best Brett :) 

Very helpful, thanks.
February 24, 2012 1:58:19 AM

Quote:
Brett928S2 wrote :

Hi :) 

The honest answer is that for high end gaming NO LAPTOP will even come close to a gaming PC....

All the best Brett :) 



This may be true, but it is entirely possible for Skyrim to run at decent graphical settings on the described hardware. My friend had a similar problem, in which the game would automatically run off of the onboard graphics, rather than the dedicated card on his laptop. Once we managed to get it to run on the dedicated card, it runs quite well at medium-high settings.
a b D Laptop
February 24, 2012 3:08:06 AM

use medium settings, try it. not very familiar with 540m but judging on the model number med-high(just some) is what you may need to set.

better yet, set everything to medium first, check the performance, if it's ok then try setting 1 or 2 to high and see how it goes.
a b D Laptop
February 24, 2012 1:10:02 PM

I cannot determine what controls the detection for which programs ought to run with onboard and which with dedicated. I'm suspecting it has to be with intel drivers since most likely the CPU makes the decision upon detecting any particular program, check if you can update the intel GPU drivers, that should add skyrim to the list of programs it autodetects and allow it to run with dedicated card.

otherwise you'll have to tweak it manually
February 24, 2012 5:17:24 PM

I believe the Nvidia graphics driver does the detection (Optimus)

Right mouse click on Desktop and chose Nvidia Control Panel
Select Manage 3D settings
Select Program Settings tab
Then find Skyrim in the drop down or use the add button
Then change the preferred graphics processor to High-performance Nvidia processor
Click apply

That should force the use of your Nvidia GPU for Skyrim
!