Sign in with
Sign up | Sign in
Your question

A quick question about Boot.ini

Last response: in Windows XP
Share
September 24, 2005 2:00:31 AM

Hey everyone,

I recently installed a trial of WinXP x64-bit edition. I would like to un-install it, which i don't know how to do without reformatting.

But, right now i <i>really</i> want to know how to keep that option from coming up in the startup screen. I've gone to the boot.ini, and edited it a little. The only entries i see now are Windows XP and my hard-disk partition. But, still i keep getting the option of "Windows (Default) as a startup option. How can i get rid of this option? MY boot.ini reads:
_____________________________________________________
[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn
_____________________________________________________

-Thanks.
September 24, 2005 2:35:07 AM

If the OS you want to NOT show up is the one in the "default" line then you need to change that line to the one you DO want which I'm guessing from your post is the other OS listed as XP Home.

If this is correct then your file should read as follows:
[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn

Then you can also change the Timeout to 0 and you shouldn't get any choices at all.

If you think I have misunderstood which operating system you want to load do not change anything. A little more clarity as to which one you want to keep for sure would be helpful.





....WW (5.1)
September 24, 2005 4:30:06 PM

Thanks =).

Yes, i do want to only have the WindowsXP Home edition as my OS. Whenever i edit the timeout to 0 it (by default)it starts up WindowsXP x64-bit edition (This is the "Default" OS listed in the boot.ini). I'll edit it like you suggested and see how it goes!
Related resources
September 24, 2005 4:42:14 PM

Hmmm... After editing it again (with what you suggested) It STILL has an option entitled Windows (Default) in the startup screen. And, it's the default option - so i can't disable the choice selection. The only difference is now Windows x64 won't start. Any ideas?

**EDIT**: I checked my Laptop's boot.ini (It only has one OS) and, it's almost identical to what my original boot.ini was <i>except</i> it lists "rdisk(0)" instead of (1) like my PC and under the "timeout" entry, it lists "patition(1).<P ID="edit"><FONT SIZE=-1><EM>Edited by Cody_7 on 09/24/05 05:49 AM.</EM></FONT></P>
September 24, 2005 5:12:23 PM

ARG!

I just COMPLETELY deleted the "Default" line in the boot.ini and it STILL gives me this option! *sigh*
September 25, 2005 12:31:21 PM

On which OS is your boot.ini file located?

....WW (5.1)
September 26, 2005 1:48:41 PM

Check your config.sys file... that's where the menu item is created, Boot.ini is something different.

Not sure, just tossing it out there though.
!