Sign in with
Sign up | Sign in
Your question

DVI->VGA adapter causing frame skipping?

Last response: in Video Games
Share
February 24, 2012 11:52:49 AM

Is it possible that a VGA->DVI adapter can cause frame skipping in games? I have a monitor with VGA input but my GPU only supports DVI. So that's why I have a VGA cable with a DVI->VGA adapter between my GPU and the VGA cable.

I read on another forum that this might cause frame skipping or micro stutter in games and I have also noticed this in majority of my games that I have random frame skippings.

Is this true? Would a better cable fix this problem?
February 24, 2012 1:51:16 PM

Yes, vga adapter gives you a lot of problems, vga also have a very low quality compared with DVI, see if your Monitor have HDMI input than you can use DVI to HDMI adapter without problems.

It is not recommended to use vga if you are working on high resolutions.

if your monitor really have only VGA you can try buying a cable VGA>DVI but you will be losing a lot of quality also, would be better upgrading your screen to a DVI/HDMI screen.
February 24, 2012 1:57:53 PM

I got this monitor when I still had my old PC which had a VGA input too.

Would a VGA->DVI cable get rid of the frame skipping?
Related resources
February 24, 2012 2:06:12 PM

i'm not sure but a cheap adapter cause various problem, a cable could "improve it".
February 24, 2012 2:35:33 PM

Ok, thanks for the help. Do you know why an adapter causes problem? Is it something to do with the information process from the GPU to the monitor?
February 24, 2012 3:04:10 PM

probably it is a problem when converting the Digital signal to Analogic maybe in this process some frames are lost what can cause low frames, interference, and sometimes even block higher resolution, but i really do not recommend doing this conversion if your graphics card is good... you will be wasting a lot of image quality just by using the vga cable or adapter, go for digital signal (hdmi/dvi that you will gain a lot).
February 24, 2012 3:07:58 PM

I don't want to really spend money on a new monitor again since this one isn't broken or anything.

Also, I'm gonna check what adapter I am using later on but I remembered that I received a DVI-A - VGA adapter with my new PC. I think the adapter I am currently using is DVI-D - VGA.

Would DVI-A - VGA adapter help to smooth the converting the image?
February 24, 2012 3:11:48 PM

there is a very small difference in image quality from vga to dvi. dvi allows colour info to be sent digitally while vga uses analog so the colour info is not as accurate. thats all...
i dunno where you see a huge drop in picture quality because i use both regularly and see very little difference between the 2. up to 2048 × 1400 i see a marginal difference. i still see lots of monitor builders offering vga input on the high dpi models. if there was a huge difference it would have died out long ago as a standard as bigger monitors became the norm..
also vga should have no impact on frame-rates if its working correctly. if your getting frame skipping its more likely a cpu-gpu issue.

http://en.wikipedia.org/wiki/List_of_display_interfaces dvi is basically bnc rgb with y-sync lead in 1 connector. bnc if you look at the list actually is part of the vga standard. sounds to me like sum1 has been listening to sales hype rather than reading up.

also there is no conversion of images all the dvi adapter does is correclty align the pins from a vga socket to the dvi socket... the gfx card doesnt say "oh hold on a mo i see a vga adapter i better convert to analog"... if your monitor has dvi and your gfx has vga then the moniotr accepts the vga signal just the same as it would if it was a vga monitor. the same goes for the gfx. the gfx sends both analog and digital colour signals if the monitor can use digital it will if it cant because of the lead it wont. it will just ignore it and carry on as if nothing changed.

seriously there is very very little difference...
http://en.wikipedia.org/wiki/Video_Graphics_Array
February 24, 2012 4:54:51 PM

So an adapter couldn't cause any frame skipping in games?
February 24, 2012 5:53:54 PM

nope. i used a dvi adapter on my old hanns-g monitor from my old 88gt and had no issues. the card is now in another system and still works off the dvi to vga on its current monitor which is 1920/1080...

most likely your issues is cpu-gpu related. either you have vsnc on and its allowing variable vsnc where the card syncs the frames on the fly meaning it doesnt lock the fps to 30 or 60 but waits for the next full frame. this can look like stuttering of skipping. or you have a slight bottleneck which is likely to be revealed if you can add a couple of hundred mhz to the cpu (dont oc on stock cooling and make sure you have enough power for overclocking b4 you try it))...
theres a simple trick you can try to see if you can solve the issue... use fraps and set it to 30fps... this will force your monitor and game to sync at 30 fps... (press f10 to record a video as this will start the limiting effect)... if it does work then try fraps at 60 fps (repeat the video recording trick) and see if your issue reappears. if it does look at the fps numbers. if you find there between 31 and 59 fps then drop your settings a little... turning off fsaa and soft shadows will normally give the biggest increase and 1s your at 60 fps minimum turn vsnc on and the issue should be gone.

1 other thing. go into your gfx control panel and reset everything to default... you may have inadvertently turned up a setting that has a heavy performance hit causing your issues.
February 24, 2012 8:01:27 PM

It's quite hard to control this issue with FRAPS because in most of the games, the frame skip happens at totally random intervals, ranging from 2 minutes to 10 minutes.

If this is true: "either you have vsnc on and its allowing variable vsnc where the card syncs the frames on the fly meaning it doesnt lock the fps to 30 or 60 but waits for the next full frame."

Then how do I fix this?

I also have ESET Antivirus running in the background, it isn't scanning my system while playing and it doesn't seem to hog a lot of resources but maybe ESET is the culprit for causing random spikes?
February 24, 2012 9:01:36 PM

well i cant really say as you havent mentioned your specs. its entirley possible that eset is scanning while your playing and causing a performance hit...
as for the vsnc issue just turn it off... it it doesnt go away then its not the issue.
but to be honest if you think that your av may have something to do with it, your system may not be the best... so like i say post your specs and we can start properly from there.
February 24, 2012 9:57:39 PM

My system:

Intel i3 2100 3.1Ghz
4GB RAM
MSI HD6850 1GB (factory OC)
February 25, 2012 6:25:22 AM

well that explains a lot... your running a dual core with a high end gfx card. without an overclock... not really a good combo...
most of the guys here that have that cpu but dont have your issue, run maxed with decent cooling. which isnt that hard to do or get. seems like its just a case of turning off all power saving and your done. this stops the cpu from dropping power states and causing the cpu to throttle just as it needs to be going full tilt.

turn off any power saving measures in bios. and start off by setting your c1 halt and any other C states to disabled turn off speed step save and quit go into windows and set the power performance profile to maximum performance.

hopefully this will stop the multiplyer from dropping and give you consistent maximum speed.

February 25, 2012 7:24:42 AM

I'm pretty sure that all power savings are disabled automatically when I run a game and even if I disable all power savings, even in BIOS, then it would just make my CPU work on full throttle even while idle. Or am I wrong?

I don't really want to argue with you but I think that the MSI HD6850 isn't that high end and the Intel i3 2100 outperforms the last generation intel i5's. It is dual core but then again, a lot of games don't utilize quad cores.
February 25, 2012 10:22:00 AM

thats the point the cpu needs to work full throttle but if the game isnt stressing the system or you have the wrong power config enabled the cpu may momentarily slip into a reduced power state causing the gpu to bottleneck. this is just a test to see if it re-leaves the problem...

you can always save a oc profile if bios allows it so you can skip between the basic profile and full throttle profile when gaming.(assuming it works)

February 25, 2012 11:19:02 AM

Ok, thanks for the help.
February 25, 2012 6:52:08 PM

I just read about this thing called "core parking" where Windows 7 disables cores to save power while idle. I checked the resource monitor and saw that CPU 1 and 3 were parked. I played 2 games (League of Legends and Team Fortress 2) and neither times did the parked cores get turned on.

I also changed my power saving to high performance and that didn't help either.

Could this be the issue for getting micro stutters?
February 25, 2012 7:06:36 PM

you gotta have 2 gfx cards to get micro stutter. what your getting is fps droop. where your fps drops to 0 for a split second then jumps back to normal from what i gathered from your other posts.
as for core parking it does sound like an issue as its a dual core that handles 4 threads. as far as i know you just disable c1 halt state in bios to turn core parking off but as i have a gen 1 i7 and not a gen 2 i3 i cant be sure. maybe its time you ask in the cpu section about core parking and get advice from the guys that actualy have i3 or i5 gen 2...
but b4 you go try this...

- Go to Regedit
- Select Edit > Find... and find this key: " 0cc5b647-c1df-4637-891a-dec35c318583 "
- Within this key, there is a value called: " ValueMax " This value represents the % number of cores the system will park
- Change the value of " ValueMax" to 0 so that, it matches " ValueMin "
- You will have to find the key a few times and repeat the process for each time it is found - the number of instances will depend on the number of power profiles in your system. To do this go back up to Edit > Find Next. (some have 3 instances of this key in there registry.)
- Do a full shutdown and power-off and cold-re-start.

credit to muffe @ultimatecomputers.net
February 25, 2012 7:22:28 PM

Yes, I just did this, now all cores are working. Going to check if the hiccups stop.
February 25, 2012 7:28:40 PM

supposedly that issue is only found on multi cpu systems... (server cards that have 2 or more actual cpu's... but it may not be exclusive so its worth a try... anyways im off for some beers... have a good night and good luck.
!