Sign in with
Sign up | Sign in
Your question

Directx issue with all games

Last response: in Video Games
Share
February 25, 2012 3:48:48 AM

ok i just got a new dell vostro and it will not run any games.
it has 4gb ram and 1.4ghz cpu quad core. intergrated graphics.

i have installed and reinstalled the drivers. i just recieved this laptop it has been restored.

the error i receive on cod WAW is. "DirectX encountered an unrecoverable error check the readme for possible solutions"

my AV is eset. i have tried registry cleaners. i have tried other games fallout 3 and fiesta(mmorpg). fallout 3 says that this computer does not support windowed mode and the mmorpg just closes itself on launch.

the mmo worked on all of my computers but no this one.


i also have updated direct X 11

i have done alot of research on this error and have had no luck.

is there a simple solution?

More about : directx issue games

February 25, 2012 4:03:18 AM

Are you installing the games from a disk? If so are you getting the error when installing or have they already been installed and are giving you the error when trying to launch? What version of windows are you running?
February 25, 2012 4:51:45 AM

im running windows 7 proffesional and its 64 bit. i have installed all of the games and they crash with the error that i mentioned. many people have gotten this error. but i think its more then that because a simple mmorpg(fiesta) crashes and it works on my other laptops that have only 2gbs of ram.
Related resources
February 25, 2012 6:48:49 AM

Can you tell us the exact model of the laptop?
February 25, 2012 7:03:34 AM

dell only has a service number

D1PMHR1
February 25, 2012 7:36:54 AM

Can I assume this is the Vostro 3555 AMD A6-3400M+HD6520 @ 1.4Ghz Turbo to 2.2Ghz.

I would first download the latest chipset and video drivers off AMD website and use memtest to chec the ram.

You say it has just be restored, if this is back to the factory image, it will have installed a lot of bloatware which can have unpredicatable results.
February 25, 2012 3:06:06 PM

Sounds like you have a process running that is keeping the games from opening. It's hard to say what process it is but antivirus software is many times the culprit. Also as as-stig said dells come with bloatware and that could be an issue. Try going to msconfig and selecting normal start up and then restart. If that doesn't work or if normal start up is selected you may try selective start up and kill any processes from 3rd party software. Also open task manager and then launch a game look for any processes that open and then shut down immediately. If all of this fails try to get ur hands on a Windows install disk and do a clean install. Make sure to backup the drivers from dell before you do so.
February 26, 2012 7:33:14 AM

well this computer only had the video drivers under programs when i first checked. then i install eset which is on my other laptop. i have tried to run in normal and diagnostic mode under msconfig. no help. i have installed the drivers/reinstalled. and i believe i meant the computer was formatted by this but im not 100% sure because the person said restore but had to reinstall drivers. i have tried this tutorial and all of the rest that i can find on google. NO RESULTS.
http://www.techpowerup.com/forums/showthread.php?p=2426...

i will be having the original owner take a look at it because he is more tech smart then i am and has windows disk if it needs to be fully reset again.
February 26, 2012 7:40:25 AM

on thing that i noticed tho is that directX has no features enabled and they say installing the drivers fix the problem but i have installed/reinstalled the drivers and they are still "not avaible". i dont think this is correct. is there something wrong with this computer. should i try to reformat the pc?
February 26, 2012 11:35:52 AM

If this was my machine, get the drivers for everything off the net, download the appropriate Windows 7 OEM image from Microsoft and install with that using your key and install the drivers, could be he is using a iffy disc. One thin gto note, when selecting the hdd/partition to install to, don't delete the factory restore partition.

Your best off looking for x64 Home Premium SP1 found under Windows 7 SP1 Media Refresh Digital River Direct Links (5/12/2011 new releases with SP1 included)

http://forums.mydigitallife.info/threads/28517-Windows-...
February 26, 2012 7:57:16 PM

1.download driver sweeper
2.uninstall AMD display drivers
3. Restart to safe mode
4.run driver sweeper
5.remove any display drivers
6. Restart
7.clean install latest AMD drivers

If this doesn't work then you can uninstall Directx and then reinstall it.
!