Sign in with
Sign up | Sign in
Your question

D-Link DI-624 Problem

Tags:
  • Routers
  • D-Link
  • Wireless Networking
Last response: in Wireless Networking
Share
September 1, 2005 4:47:29 PM

Archived from groups: alt.internet.wireless (More info?)

I have a D-Link DI-624 wireless router. I have upgraded the firmware to
Ver. 2.70, but my problem was the same with earlier versions of firmware.

When I start my laptop and connect via the WLAN to PokerStars.com, I get
many and frequent disconnects (every one or two minutes). If I go to
the D-Link setup wizard and go to any menu and just restart the router
(without making any changes in the setup), PokerStars works just fine -
no disconnects. It seems to work fine until I turn off the laptop, then
I have to go through the same process of restarting the router to get
PokerStars to stay connected. It is obviously a real bother to have to
restart the router everytime I want to use the laptop. Any thoughts on
why I have this problem? Would getting different router (LinkSys, or
something else) possibly solve this problem?

Thanks for any comments / suggestions.

More about : link 624 problem

Anonymous
September 1, 2005 8:24:22 PM

Archived from groups: alt.internet.wireless (More info?)

Contact DLink for the problem or / and email then for this issue


On Thu, 01 Sep 2005 12:47:29 GMT, Chuck <urg44@yahoo.com> wrote:

>I have a D-Link DI-624 wireless router. I have upgraded the firmware to
>Ver. 2.70, but my problem was the same with earlier versions of firmware.
>
>When I start my laptop and connect via the WLAN to PokerStars.com, I get
>many and frequent disconnects (every one or two minutes). If I go to
>the D-Link setup wizard and go to any menu and just restart the router
>(without making any changes in the setup), PokerStars works just fine -
>no disconnects. It seems to work fine until I turn off the laptop, then
>I have to go through the same process of restarting the router to get
>PokerStars to stay connected. It is obviously a real bother to have to
>restart the router everytime I want to use the laptop. Any thoughts on
>why I have this problem? Would getting different router (LinkSys, or
>something else) possibly solve this problem?
>
>Thanks for any comments / suggestions.
Anonymous
September 2, 2005 12:49:34 AM

Archived from groups: alt.internet.wireless (More info?)

On 1-Sep-2005, Midjet <midjet@vid.ath.cx> wrote:
<snipped>

> but my problem was the same with earlier versions of firmware.

<snipped>

I missed the above portion of your post when I replied earlier. Sorry.
--
Just Me, D
Related resources
September 2, 2005 12:49:50 AM

Archived from groups: alt.internet.wireless (More info?)

Aye, Aye, Captain Midjet. They said to reflash the firmware, uplug the
router, and walk around it three times, counter clockwise, plug it back
in, and try it again. This didn't help, so I came here. What is your
next suggestion?


Midjet wrote:
> Contact DLink for the problem or / and email then for this issue
>
>
> On Thu, 01 Sep 2005 12:47:29 GMT, Chuck <urg44@yahoo.com> wrote:
>
>
>>I have a D-Link DI-624 wireless router. I have upgraded the firmware to
>>Ver. 2.70, but my problem was the same with earlier versions of firmware.
>>
>>When I start my laptop and connect via the WLAN to PokerStars.com, I get
>>many and frequent disconnects (every one or two minutes). If I go to
>>the D-Link setup wizard and go to any menu and just restart the router
>>(without making any changes in the setup), PokerStars works just fine -
>>no disconnects. It seems to work fine until I turn off the laptop, then
>>I have to go through the same process of restarting the router to get
>>PokerStars to stay connected. It is obviously a real bother to have to
>>restart the router everytime I want to use the laptop. Any thoughts on
>>why I have this problem? Would getting different router (LinkSys, or
>>something else) possibly solve this problem?
>>
>>Thanks for any comments / suggestions.
>
>
September 2, 2005 3:31:08 AM

Archived from groups: alt.internet.wireless (More info?)

Doug - I got Ver. 2.70 from the website link in the setup menu for the
DI-624. It is apparently pretty new - I think it was dated 8/31/05.

One thing I didn't do is reset the router to the default settings
prior to installing the new firmwear. The installation instructions
state that "Upgrading the firmware will not change any of your system
settings", so I didn't think it would be necessary to reset to the
default settings before doing the firmwear update. I guess I could try
this, just for kicks. Do you think it would work if I saved the
settings, reflashed the firmware, and then reinstalled the settings (as
opposed to manually going through the whole setup procedure again)?

Chuck

Doug Jamal wrote:
Now to Chuck's dilemma: Chuck, did you
> experience your problem prior to updating the firmware to version 2.70?
> Speaking of version 2.70, where did you download it from? D-link's US site
> only has firmware up to version 2.53 (beta) for DI-624 Rev C, up to version
> 1.28 for Rev B and up to version 1.24 for Rev A. If you did not, reset the
> router to it's default settings then reload the firmware. Afterwards, reboot
> the router. That *should* take care of your problem. Take care.
September 2, 2005 5:49:42 AM

Archived from groups: alt.internet.wireless (More info?)

"Chuck" <urg44@yahoo.com> wrote...
>
> Doug - I got Ver. 2.70 from the website link in the setup menu for the
> DI-624. It is apparently pretty new - I think it was dated 8/31/05.

I agree. The new version is 2.70 straight from DLink's web site.

From your original posting, it seems that the problem occurs only with one
site, which looks from its name that it might be a gaming site. Is it
possible that when on Pokerstars.com that you need to be set as a server or
that running the game qualifies as a Special Application with the router
requiring some tinkering with the router setup? I'm just guessing as this is
way above my knowledge of routers and networking stuff but maybe the
following applies. The fact that you initially connect but have to reset
frequently seems to me to be that one end of your gaming application tries
to check to see that the other end is still there every now and then--and if
it can't get through, you disconnect.

From D-Link's Help files:

Special Applications
Some applications require multiple connections, such as Internet gaming,
video conferencing, Internet telephony and others. These applications have
difficulties working through NAT (Network Address Translation). If you need
to run applications that require multiple connections, specify the port
normally associated with an application in the "Trigger Port" field, select
the protocol type as TCP (Transmission Control Protocol) or UDP (User
Datagram Protocol), then enter the public ports associated with the trigger
port to open them for inbound traffic. At the bottom of the screen, there
are already defined well-known special applications. To use them, click on
the edit icon and enable the service.
Name - This is the name referencing the special application.
Trigger Port - This is the port used to trigger the application. It can be
either a single port or a range of ports.
Trigger Type - This is the protocol used to trigger the special application.
Public Port - This is the port number on the WAN side that will be used to
access the application. You may define a single port or a range of ports.
You can use a comma to add multiple ports or port ranges.
Public Type - This is the protocol used for the special application.

DMZ
If you have a computer that cannot run Internet applications properly from
behind the device, then you can allow the computer to have unrestricted
Internet access. Enter the IP address of that computer as a DMZ
(Demilitarized Zone) host with unrestricted Internet access. Adding a client
to the DMZ may expose that computer to a variety of security risks; so only
use this option as a last resort.

Virtual Server
The device can be configured as a virtual server so that remote users
accessing services such as Web or FTP services via the public (WAN) IP
address can be automatically redirected to local servers in the LAN network.
Depending on the requested service (TCP/UDP port number), the device
redirects the external service request to the appropriate server within the
LAN network. At the bottom of the screen, there are already defined
well-known virtual services. To use them, click on the edit icon. You will
only need to input the LAN IP address of the computer running the service
and enable it.
Name - The name referencing the virtual service.
Private IP - The server computer in the LAN network that will be providing
the virtual services.
Private Port - The port number of the service used by the Private IP
computer.
Protocol Type - The protocol used for the virtual service.
Public Port - The port number on the WAN side that will be used to access
the virtual service.
Schedule - The schedule of time when the virtual service will be enabled.
September 2, 2005 6:26:33 AM

Archived from groups: alt.internet.wireless (More info?)

I don't think this is the problem, because after I restart the router,
PokerStars stays connected for literally hours. Not that I play that
long at a time, but I've connected, played a few hours, gone away, come
back later, and played again, and stay connected as long as I don't turn
off the laptop. If I turn off the laptop, I have to restart the router
again to avoid the numerous disconnects. I also noticed that when I'm
connected to the internet through the router, I get a lot more missing
packets, both through the laptop and the desktop (which is connected to
a LAN port on the router) than I get with the cable modem connected
directly to the desktop. I don't know diddly about routers, etc., but
I'm thinking part of the problem is in the differences in error checking
when connected through the router compared to connecting directly to the
cable modem. But it doesn't make sense to me how restarting the router
corrects the problem. I'm thinking about just getting a LinkSys router
to try, and if it works better, take the D-Link back. If it doesn't work
better, I'll the D-Link and keep plugging away, or wait until I get
tired poker on PokerStars (or playing poker all together), and the
problem will resolve itself. By the way, other online poker sites don't
exhibit this problem - only PokerStars.

Craig wrote:
> "Chuck" <urg44@yahoo.com> wrote...
>
>>Doug - I got Ver. 2.70 from the website link in the setup menu for the
>>DI-624. It is apparently pretty new - I think it was dated 8/31/05.
>
>
> I agree. The new version is 2.70 straight from DLink's web site.
>
> From your original posting, it seems that the problem occurs only with one
> site, which looks from its name that it might be a gaming site. Is it
> possible that when on Pokerstars.com that you need to be set as a server or
> that running the game qualifies as a Special Application with the router
> requiring some tinkering with the router setup?
Anonymous
September 3, 2005 5:35:23 AM

Archived from groups: alt.internet.wireless (More info?)

On 1-Sep-2005, Chuck <urg44@yahoo.com> wrote:

> One thing I didn't do is reset the router to the default settings
> prior to installing the new firmwear. The installation instructions
> state that "Upgrading the firmware will not change any of your system
> settings", so I didn't think it would be necessary to reset to the
> default settings before doing the firmwear update. I guess I could try
> this, just for kicks. Do you think it would work if I saved the
> settings, reflashed the firmware, and then reinstalled the settings (as
> opposed to manually going through the whole setup procedure again)?
>
> Chuck

First, thanks for the tip regarding the new firmware. I entered the DI-624's
menu, saved my router's configuration to my hard drive, reset the router to
its default settings then updated the firmware. After the router rebooted, I
re-entered the router's menu, loaded the saved settings and voila! My DI-624
is performing as flawlessly as it did prior to me updating its firmware. AES
cipher is also supported with this update. Anyway, resetting devices to it
default settings prior to updating the firmware works best for me. And yes,
you can save your settings and reload them after updating the firmware. The
more I think about your situation, the more I'm convinced that it is not the
DI-624. You stated that you only experience your problem when you turn off
the laptop and turn it back on. Therefore it is my understanding that if you
never turned off your laptop, your wireless networking experience is
excellent. But as soon as you turn off your laptop and turn it back on, you
have to reboot the DI-624 in order to be able to network wirelessly without
any annoying intermittent reboots. My guess is with your laptop's wireless
card or the settings in your notebook. Are you using the D-Link DWL-G650
card? If so, it has a history of not connecting upon startup of Windows.
Mine is no different. However, my trusty Netgear WG511T will connect
flawlessly everytime. Do you have a spare notebook card to experiment with?
Can you use a friend's laptop to see if it acts in the same manner as yours
while connected to YOUR DI-624?

--
Just Me, D
September 3, 2005 10:53:01 PM

Archived from groups: alt.internet.wireless (More info?)

Doug Jamal wrote:
>
> First, thanks for the tip regarding the new firmware. I entered the DI-624's
> menu, saved my router's configuration to my hard drive, reset the router to
> its default settings then updated the firmware. After the router rebooted, I
> re-entered the router's menu, loaded the saved settings and voila! My DI-624
> is performing as flawlessly as it did prior to me updating its firmware.

Glad this worked for you, but here is a warning I found on the D-Link
support website about loading configuration files. This warning was
actually in bold red letters!

Note: If the firmware on your wireless router has been
upgraded/downgraded, do not load configuration files that were saved
using a different version of firmware then you currently have installed.
This will not work and could damage the unit.



> The more I think about your situation, the more I'm convinced that it is not the
> DI-624. You stated that you only experience your problem when you turn off
> the laptop and turn it back on. Therefore it is my understanding that if you
> never turned off your laptop, your wireless networking experience is
> excellent. But as soon as you turn off your laptop and turn it back on, you
> have to reboot the DI-624 in order to be able to network wirelessly without
> any annoying intermittent reboots. My guess is with your laptop's wireless
> card or the settings in your notebook. Are you using the D-Link DWL-G650
> card? If so, it has a history of not connecting upon startup of Windows.
> Mine is no different. However, my trusty Netgear WG511T will connect
> flawlessly everytime. Do you have a spare notebook card to experiment with?
> Can you use a friend's laptop to see if it acts in the same manner as yours
> while connected to YOUR DI-624?

You make a good point - at least for me, I almost never know when I am
trying to solve a software or hardware problem, and exactly which
software and hardware is causing the problem. The laptop is a new Dell
Inspiron 6000, with an IntelĀ® PRO/Wireless 2200 Internal Wireless
(802.11 b/g, 54Mbps) wireless adapter. I should add that when
connecting to the internet trough the router on the desktop, through the
LAN cable, I get similar disconnects. If I connect the cable modem
directly to the desktop, instead of the router, I don't get disconnects,
and significantly fewer lost packets. I do appreciate your thoughts.
Guess I just keep plugging away. I think I am going to try a
different router next, just to make sure it is a router problem. This
is fun for a while, but the fun is starting to where off quickly!

Chuck
Anonymous
September 4, 2005 1:59:10 AM

Archived from groups: alt.internet.wireless (More info?)

On 3-Sep-2005, Chuck <urg44@yahoo.com> wrote:

> You make a good point - at least for me, I almost never know when I am
> trying to solve a software or hardware problem, and exactly which
> software and hardware is causing the problem. The laptop is a new Dell
> Inspiron 6000, with an IntelĀ® PRO/Wireless 2200 Internal Wireless
> (802.11 b/g, 54Mbps) wireless adapter. I should add that when
> connecting to the internet trough the router on the desktop, through the
> LAN cable, I get similar disconnects. If I connect the cable modem
> directly to the desktop, instead of the router, I don't get disconnects,
> and significantly fewer lost packets. I do appreciate your thoughts.
> Guess I just keep plugging away. I think I am going to try a
> different router next, just to make sure it is a router problem. This
> is fun for a while, but the fun is starting to where off quickly!
>
> Chuck

Being that you are also experiencing the disconnects via ethernet cable,
reset the DI-624 to its default settings. If you have file & print sharing
on your notebook and other attached PCs, temporarily disable them PRIOR to
resetting to the router's default settings. Once you've reset the router to
its default settings, observe your connected PCs for lost connections. Do
this for about 15 minutes or so. What I'm specifically looking for is to see
whether or not you lose connections prior to a screensaver being activated
and/or after your computer(s) have gone into standby mode. If this is the
case and if your PC and notebook cards allow, go into the card's
configuration and disable power-saving mode. By the way, I was aware of the
dangers of loaded a previous firmware's config. data. Still, I'm a tinkerer
and love to push things to the limit. (smile) Besides, I've been blessed up
to this point. Anyway, let me know what happens. If you've had enough of the
troubleshooting and the challenge to overcome your dilemma has peaked then I
recommend the Linksys WRT54G or WRT54GS wireless router. Take care.

--
Just Me, D
September 4, 2005 6:32:45 AM

Archived from groups: alt.internet.wireless (More info?)

Doug, I really appreciate your persistence in trying to solve my D-Link
problem. Actually, I took your advice and got the Linksys WRT54G router
today. It took me about 1/2 hour to read through the documentation
and set it up (all my "experience" with the D-Link helped). It seems to
work perfectly, including the WPA security (which I never did get
working with the D-Link). It could be that the D-Link is defective, but
I guess I'll never know. I am going to leave the Linksys connected.
I'll probably try to return the D-Link to Office Max, but don't expect
much success, since I already removed the UPC code from the box and sent
in for the rebate.

It may be my imagination, but internet activities on the laptop, which
is on the wireless network, seem much faster with the Linksys than with
the D-Link, even though I never did have any of the advanced security
features configured on the D-Link. And PartyPoker has not disconnected
even once. Guess I've been converted to a Linksys fan, like Jorge
Padrone, the first responder to my post, is.

Again, thanks for you thoughts and comments.

Chuck

Doug Jamal wrote:
> On 3-Sep-2005, Chuck <urg44@yahoo.com> wrote:
>
>

Anyway, let me know what happens. If you've had enough of the
> troubleshooting and the challenge to overcome your dilemma has peaked then I
> recommend the Linksys WRT54G or WRT54GS wireless router. Take care.
>
Anonymous
September 4, 2005 6:43:11 AM

Archived from groups: alt.internet.wireless (More info?)

On 3-Sep-2005, Chuck <urg44@yahoo.com> wrote:
<snipped>
> Again, thanks for you thoughts and comments

No problem, Chuck. Take care and enjoy your new toy. ;) 

--
Just Me, D
Anonymous
December 1, 2008 9:46:01 PM

Hi Guys,
Here's one for you. I have the strangest problem with my DI-624.
It seems when ever the unit is switched off at the mains socket and later turned back on. For some strange reason it can takes hours to power back up.It is completely dead it talk all day today to come back on. At 1st I thought it was a heat problem but it isn't, I have tried everything. Any ideas? its driving me mad!
Anonymous
December 2, 2008 5:17:16 AM

If it has an extrenal Power Supply cube, try swapping it for one of (exactly ) the same voltage, same wattage/ampage or greater -- and same type (regulated supply, probably) . Obviously also check polarity of socket is matched.

!