Sign in with
Sign up | Sign in
Your question

Autochk program not found, but partition is unhidden?

Last response: in Windows 7
Share
October 8, 2010 11:18:26 PM

Greetings everyone, I need you to be my Obi-Wan because right now you are my only hope.

I have spent all day trying to fix this "autochk program not found - skipping autocheck" error on my PC. It makes an infinite reboot loop and I can't boot into windows. Most of the google hits end up telling me that it is because my partition is hidden. Well, I've tried using got Gparted to make sure the "hidden" box isn't checked. And I have used Test Disk to see that the partition value is indeed 07 so it really shouldn't be hidden. I have also tried using the windows 7 disk to do a repair but it has no effect. I have also done a chkdsk /r but to no avail.

And yet.... I still get this autochk error. I am frustrated to the brim of tears and I just don't know what to do now. Is it still somehow hidden and fooling the programs? Is there anything else I can do?

I appreciate anything you have that may help. Thank you.
October 9, 2010 1:04:20 AM

I had a feeling that would come up at some point. I haven't been able to try "unhiding" it that method.

I don't have a floppy drive so I've been trying to make a dos CD with ptedit on it but when I tried Bart's method I still couldn't start up ptedit. I'm going to try again, maybe look for a different mothod to make a dos CD.

edit: And again... I'm having serious trouble finding a method of making a bootable dos CD from which to run ptedit. If anyone has a method they know of feel free to share.
m
0
l
Related resources
a b $ Windows 7
October 9, 2010 6:04:11 AM

have tried a bootable USB FlashDrive.
m
0
l
October 9, 2010 1:29:37 PM

I don't have one handy. I'll either be buying a USB drive to try it. Or getting an internal floppy drive installed to use that method.

How can I tell if a usb drive will be recognized on start up?
m
0
l
a b $ Windows 7
October 9, 2010 8:53:22 PM

If your board supports it, enable usb boot device in bios.
m
0
l
October 10, 2010 4:12:23 PM

Alright... Got a usb drive. Got it booted to dos and opened PTEdit, as I expected the drive type was already set to 07 and it is set to bootable.

The only other option that I have found is trying to replace the mountmgr.sys file in the drivers folder of system32. But I'm not having a hard time trying to do that.

I took the file from another computer running windows 7 and put it on the usb root. When I get into DOS I see that the USB is taking up the drive letter C:, which is already the letter of one of my partitions, but not the one I am trying to copy to.

The command line I try is;

C:> mountmgr.sys (I have tried A:, E:, and D:) /windows/system32/drivers\ y

but in return I get a "Bad command or file name" message. Any ideas? I feel like the problem really lies in the mountmgr.sys file so i need to get it replaced.
m
0
l
!