Sign in with
Sign up | Sign in
Your question

Strange network card problem

Last response: in Components
Share
June 4, 2004 7:39:51 AM

Hi guys,

I hope you can help me as I'm going a little insane troubleshooting a strange networking issue for a friend. The problem is this:

My friend has a computer that will simply not work using any configuration hooked up to my network hub. He has two network cards (one integrated on an Epox mobo / one generic Realtek 10/100 PCI card) both of which are correctly installed, have the latest drivers etc and are reported as working fine under Windows XP Device manager. However the "network cable is unplugged" message always appears along with the systray unplugged icons regardless of which card we connect to. Now I know the typical things that will be suggested for this kind of problem so here is everything that I know and that has been ruled out as a potential problem:

1. I have tried multiple ports on the hub. None of them work with his computer, but all of them work fine with other computers
2. I Am definitely using a proper patch cable. I've tried a couple of diff cables to be on the safe side. The cables works fine connected to other PCs.
3. His RealTek network card works fine in another computer.
4. The network card lights on the back of the PC don't light up at any stage. Either when the computer is first turned on/booting or within Windows.

5. Now here's the weird part: We can get both of his network cards to work just fine when using a crossover cable connected directly to another PC! I.e. the lights light up straight away and the network card/s work absolutely fine for a direct PC connection to another computer, but just wont work when connected to a hub!

What on earth would cause this?! I cant think of a single thing that would allow a PC's network card to work fine with a direct connection to a single PC, but not work when using a patch cable connected to a hub!

Please help guys as this problem is driving me utterly insane!

Thanks a lot for your input.
June 7, 2004 11:07:07 PM

it will say network cable unplugged if only one card has a connection. the warning is for the specific card its not universal.

wpdclan.com counter-strike game server - 66.150.155.52:27015
now featuring valve security module!
Anonymous
August 26, 2009 1:57:29 PM

I had this problem with a winxp system with a realtek nic card, hardwired.

A temp solution was using a wireless g, which gave me 54mbs, instead of 100mbs over the cable.

This problem would occur just occasionally, but it annoyed me...I checked most of the ideas...the router, cable, ports, nic...etc.

i didn't want to have to replace the nic...as I just had a hunch that the problem was some "glitchy" software issue with either winxp or the realtek card software...

AND THE SOLUTION WAS:

I saw someone said to check the "bios" settings...you press like F2 on startup...to get into bios...

under the peripherals there were two references to my network card...one was lan setup WHICH WAS ENABLED...and one was "rom boot of network card" WHICH WAS DISABLED...SINCE I HAD NEVER TAMPERED WITH THESE SETTINGS...I assumed they were correct and that the "rom boot of the card" was some kind of manual overide...which you SHOULDN'T NORMALLY HAVE TO ENABLE.

...anyway I enabled the "rom boot of the card" also...restarted, disconnected the wireless and SURPRISE I HAD ACCESS TO THE NETWORK...one thing...I had to go into the "local network connection properties" and reckeck the box so the "network icon" would appear again on the taskbar"...that being done ALL WORKED, etc.

Now, I restarted went back in and "disabled" the "rom boot of the network card"...I did this because the boot process was stalled as a setup screen appeared querying you about the "rom setup" ...just hitting the "escape key" got you thru this setup program...but I didn't want to have to keep going thru this delay on startup...

...when I restarted the NETWORK CARD WAS STILL WORKING WITH THE ICON IN THE TASKBAR showing all was fine...

so, you should try this before buying a network card again...or spending time checking cables...do this first it just takes a few minutes...and then do the other stuff...

I think ultimately...something changes the "Normal network card setup" either xp or the card software...or both, or some other software impacting them...in any event...

if I have this problem again...I'll just go into the bios and ENABLE THE ROM BOOT OF THE CARD...get the network working...and go back in an disable the "rom manual network card forced setup."

hope that helps...and my thanks to the person who in one line suggested checking the "bios" which I probably never would have....

regards,

flashrob
!