Sign in with
Sign up | Sign in
Your question

peer to peer network on xp

Last response: in Components
Share
January 13, 2005 7:59:50 AM

Hi,
I hope someone can help me with this because im really stumped. Iv been trying to set up a network between my PC (that has no Internet) and my family's other PC (that has Internet) so my PC can use the Internet, play LAN games, etc.

I already had 1 ethernet network card so I whacked that into one of the machines then I went out and bought another network card and some RJ45 crossover cable (no router).

I had a few hitches whilst installing the network cards but now they seem to be ok. I connected everything up and ran the windows xp small network wizard on both machines. Now when they start up a login box appears asking for a user name and password. But once youve given it the user name and password (which are the same as the user names and passwords for the old windows xp login screen with the different pictures for each user that used to come up before I meddled with this networking stuff) if you try and access the network in 'My network places' it says the network cable is unplugged.

Is there something in the BIOS iv forgotten to do? or is the cable faulty?

Any help would be very greatly appreciated!

More about : peer peer network

January 13, 2005 5:04:40 PM

If it says network cable unplugged you are definatly having a problem with the cable. When you right click on my network places and go to properties does it show the network connection with a small red x in the corner? Do the lights on either of the network cards light up?
Have you checked in device manager to make sure the cards are installed correctly?
The windows xp network wizard really does more harm than good, I wouldn't ever use it :( 
The manual aproach to sharing internet between 2 computers isn't that hard at all. I'd be glad to explain it if you would like.

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
January 13, 2005 5:11:00 PM

I checked task manager and they seemed to be ok. There arnt any LEDs on the network cards I dont think. There is the little red x against the local area connectin. I would like to here the manual way.
Related resources
January 13, 2005 5:49:55 PM

The LEDs on the network cards arn't lit you have a cable problem. The only network cards that don't have LEDs on them are in Apple computers (one of many reasons a network tech like myself hates them). Any network cards for a PC that lack LEDs would likely be extremely old or rare. I have yet to see one.
Take a look at the wires in the heads on each end of the cable pin side up. One end should be from left to right: orange white, orage, green white, blue, blue white, green, brown white brown. The other end should be: green white, green, orange white, blue, blue white, orage, brown white, brown. Also see if all the wires are making contact with those little pins in the head. If something doesn't look right take that cable back and get it replaced. Or put new heads on in the correct config. If it appears to be correct at both ends you might have a faulty network card at one end. I'd replace the card you had first, if it was just laying around it might be bad.
How long is the cable? The theretical max lenght of Cat5e is 100 meters but I wouldn't go to much over 100ft. Thought I would bring that up just in case :) 

Internet connection sharing via crossover:
1) On the computer that has the internet connection enable internet connection sharing (ICS). Right click on my network places and go to properties. Right click on your internet connection (or the network adaptor which the broadband modem is connected if you have cable or similar) and go to properties. Go to the advanced tab and check the box "allow other network users to connect through this computer's internet connection" and choose the network connection from the list that is connecting your 2 computers together, hit ok. It will then give that network connection a static IP of 192.168.0.1 and make that internet connection avaliable. When you are connected to the internet on that machine bring up a command prompt (start, run type cmd, hit ok) and type in ipconfig /all. Look down the list until you find the DNS servers for your internet connection. Make note of them, you will need them later.
Then go to your computer. Right click on my network places and go to properties. Right click on your lan connection and go to properties. In the general tab find the "internet protocol (TCP/IP)" in the list and hit properties. Move the selection to "use the following IP address". Enter this:
IP: 192.168.0.2
subnet: 255.255.255.0
gateway: 192.168.0.1 (the computer sharing its internet connection)
Preferred DNS: (one of your ISPs dns servers)
Alternate DNS: (another of your ISPs dsn servers)

Hit ok and you should be good to go.

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
January 13, 2005 6:02:25 PM

Ok, the cable is only 10 metres so I dont think its that. Il keep hold of the rest of what you said and try it next time im at my dads (where the network is) starting with a closer look at those network cards! thanks for the help!
January 16, 2005 2:49:29 PM

I can't beleive it! Maplins sold me a straight through cable when the bag was specifically marked X-over cable! Luckly I still have the bag and the reciept, even though I bought it a few weeks ago im still going to go back and complain. Thanks for all the help, im sure i'll be posting again if I get stuck again!
!