Sign in with
Sign up | Sign in
Your question

Gigabyte GA-H55-USB3 and Win7 mark internal SATA drives as removable

Last response: in Windows 7
Share
October 9, 2010 12:49:47 AM

Similar to the problem posted at http://www.tomshardware.com/forum/3844-63-gigabyte-p55a... , my new Gigabite GA-H55-USB3 (Rev. 2) marks drives C: and D: (internal drives!) as removable. (Before anyone makes this rather useless yet distressingly common suggestion, YES, I have already set them to 'optimise for performance' as opposed to 'optimise for quick removal'. They still show up under "Safely Remove Hardware and Eject Media".)

I tried the suggestions as postead at http://www.tomshardware.com/forum/3844-63-gigabyte-p55a... ; however, they do not work. The registry path HKEY_LOCAL_MACHINE\System\
CurrentControlSet\Services\msahci\Controller0 (or Controller1, or Controller2, or controllerANYTHING) does not exist. In fact, the msahci has no subdirectories (subkeys?) whatsoever.

This is pretty stupid. Any suggestions?
a b $ Windows 7
October 9, 2010 2:12:36 AM

If you have AHCI enabled in your BIOS then SATA drives are hot swappable and will therefore be correctly identified by the operating system as removable. AHCI mode is better than IDE mode as it supports NCQ.
m
0
l
October 9, 2010 6:32:54 AM

I see. Thank you for that information. Is there no way to just tell it to pretend they aren't hot-swappable, though, since I am never going to remove either of those drives and do not want to see them on the list?
m
0
l
Related resources
a b $ Windows 7
October 9, 2010 7:57:02 AM

The only way I know is to reinstall Windows with the SATA interface set to IDE mode in the BIOS but this will disable NCQ which will slightly slow your hard disk. You may be able to fool Windows that the drives are not removable with a clever registry edit but I don’t know how.
m
0
l
October 9, 2010 9:57:49 AM

Bleurgh. Well, it's at least nice to know that this is actually normal. :)  Thank you!
m
0
l
!