Error installing USB Printer support

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

I keep getting an error when i try to install my Epson
C40UX printer.

I just did a fresh install of WinXP Home, i have downloaded
and installed all of the latest updates and patches.
Before the reinstall the printer was working perfectly, now
when windows tries to install the drivers it doesnt work.
The device manager shows a device called "USB Printer" with
the little exclamation mark that it has when things dont
work. If i try to reinstall the drivers for that device, it
comes up with an error saying: "There was a problem
installing this hardware, USB Printing Support. An error
occurred during the installation of the device, The data is
invalid"

It does this no matter how many times i try
uninstalling/rebooting and reinstalling the driver.

Ive had a quick look in the knowledge base but i couldnt
find anything of any use to me (which is not to say that it
isnt there, just that i couldnt find it if it is)

Any help would be greatly appreciated

phillm90
7 answers Last reply
More about error installing printer support
  1. Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

    Epson has many support documents
    http://tinyurl.com/3d6a9
    Resources for Troubleshooting Printing Problems in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308028&Product=winxp
    General USB Troubleshooting in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;310575&Product=winxp

    --
    Mary Sauer MS MVP
    http://office.microsoft.com/
    http://www.mvps.org/msauer/
    news://msnews.microsoft.com
    "Phill Macey" <phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in message
    news:1be8b01c42119$3565cea0$a101280a@phx.gbl...
    > I keep getting an error when i try to install my Epson
    > C40UX printer.
    >
    > I just did a fresh install of WinXP Home, i have downloaded
    > and installed all of the latest updates and patches.
    > Before the reinstall the printer was working perfectly, now
    > when windows tries to install the drivers it doesnt work.
    > The device manager shows a device called "USB Printer" with
    > the little exclamation mark that it has when things dont
    > work. If i try to reinstall the drivers for that device, it
    > comes up with an error saying: "There was a problem
    > installing this hardware, USB Printing Support. An error
    > occurred during the installation of the device, The data is
    > invalid"
    >
    > It does this no matter how many times i try
    > uninstalling/rebooting and reinstalling the driver.
    >
    > Ive had a quick look in the knowledge base but i couldnt
    > find anything of any use to me (which is not to say that it
    > isnt there, just that i couldnt find it if it is)
    >
    > Any help would be greatly appreciated
    >
    > phillm90
  2. Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

    thanks Mary, i have looked through all of the links you
    gave me and followed any relevant links that i found while
    looking but I didnt find anything that helped.

    I should have pointed out in my first post, there is
    definantly nothing wrong with the printer because 1) i can
    get it to print its own test page (not using the windows
    one, just using the combination of button presses on the
    printer - it doesnt even need to be connected to the computer)
    2) it was working just fine before i reinstalled windows.
    Im certain it is a driver problem. I dont think it is a
    problem with the epson drivers though. It is just the 'USB
    Printer Support' one that windows installs to allow the
    printer to be on a usb port.. I can get the epson drivers
    to install, but they can not access the printer because
    that other driver is not functioning (they can only access
    LPT ports, COM ports, and FILE)... Yes i uninstalled the
    printer drivers before i tried installing them again.

    USB works fine cause ive had other usb devices (storage
    devices) running without any problems. I have tried
    plugging it into different usb ports, and it still doesnt
    work no matter what port i put it in.

    I can tell that this is going to be a real pain in the
    bum.. it already has been

    phillm90

    >-----Original Message-----
    >Epson has many support documents
    >http://tinyurl.com/3d6a9
    >Resources for Troubleshooting Printing Problems in Windows XP
    >http://support.microsoft.com/default.aspx?scid=kb;en-us;308028&Product=winxp
    >General USB Troubleshooting in Windows XP
    >http://support.microsoft.com/default.aspx?scid=kb;en-us;310575&Product=winxp
    >
    >--
    >Mary Sauer MS MVP
    >http://office.microsoft.com/
    >http://www.mvps.org/msauer/
    >news://msnews.microsoft.com
    >"Phill Macey"
    <phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in message
    >news:1be8b01c42119$3565cea0$a101280a@phx.gbl...
    >> I keep getting an error when i try to install my Epson
    >> C40UX printer.
    >>
    >> I just did a fresh install of WinXP Home, i have downloaded
    >> and installed all of the latest updates and patches.
    >> Before the reinstall the printer was working perfectly, now
    >> when windows tries to install the drivers it doesnt work.
    >> The device manager shows a device called "USB Printer" with
    >> the little exclamation mark that it has when things dont
    >> work. If i try to reinstall the drivers for that device, it
    >> comes up with an error saying: "There was a problem
    >> installing this hardware, USB Printing Support. An error
    >> occurred during the installation of the device, The data is
    >> invalid"
    >>
    >> It does this no matter how many times i try
    >> uninstalling/rebooting and reinstalling the driver.
    >>
    >> Ive had a quick look in the knowledge base but i couldnt
    >> find anything of any use to me (which is not to say that it
    >> isnt there, just that i couldnt find it if it is)
    >>
    >> Any help would be greatly appreciated
    >>
    >> phillm90
    >
    >
    >.
    >
  3. Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

    Did you leave the printer disconnected from the computer when you
    reinstalled windows and printer drivers?


    "Phill Macey" <phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in
    message news:190c301c4215a$edb6f420$a601280a@phx.gbl...
    thanks Mary, i have looked through all of the links you
    gave me and followed any relevant links that i found while
    looking but I didnt find anything that helped.

    I should have pointed out in my first post, there is
    definantly nothing wrong with the printer because 1) i can
    get it to print its own test page (not using the windows
    one, just using the combination of button presses on the
    printer - it doesnt even need to be connected to the computer)
    2) it was working just fine before i reinstalled windows.
    Im certain it is a driver problem. I dont think it is a
    problem with the epson drivers though. It is just the 'USB
    Printer Support' one that windows installs to allow the
    printer to be on a usb port.. I can get the epson drivers
    to install, but they can not access the printer because
    that other driver is not functioning (they can only access
    LPT ports, COM ports, and FILE)... Yes i uninstalled the
    printer drivers before i tried installing them again.

    USB works fine cause ive had other usb devices (storage
    devices) running without any problems. I have tried
    plugging it into different usb ports, and it still doesnt
    work no matter what port i put it in.

    I can tell that this is going to be a real pain in the
    bum.. it already has been

    phillm90

    >-----Original Message-----
    >Epson has many support documents
    >http://tinyurl.com/3d6a9
    >Resources for Troubleshooting Printing Problems in Windows XP
    >http://support.microsoft.com/default.aspx?scid=kb;en-us;308028&Product=winx
    p
    >General USB Troubleshooting in Windows XP
    >http://support.microsoft.com/default.aspx?scid=kb;en-us;310575&Product=winx
    p
    >
    >--
    >Mary Sauer MS MVP
    >http://office.microsoft.com/
    >http://www.mvps.org/msauer/
    >news://msnews.microsoft.com
    >"Phill Macey"
    <phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in message
    >news:1be8b01c42119$3565cea0$a101280a@phx.gbl...
    >> I keep getting an error when i try to install my Epson
    >> C40UX printer.
    >>
    >> I just did a fresh install of WinXP Home, i have downloaded
    >> and installed all of the latest updates and patches.
    >> Before the reinstall the printer was working perfectly, now
    >> when windows tries to install the drivers it doesnt work.
    >> The device manager shows a device called "USB Printer" with
    >> the little exclamation mark that it has when things dont
    >> work. If i try to reinstall the drivers for that device, it
    >> comes up with an error saying: "There was a problem
    >> installing this hardware, USB Printing Support. An error
    >> occurred during the installation of the device, The data is
    >> invalid"
    >>
    >> It does this no matter how many times i try
    >> uninstalling/rebooting and reinstalling the driver.
    >>
    >> Ive had a quick look in the knowledge base but i couldnt
    >> find anything of any use to me (which is not to say that it
    >> isnt there, just that i couldnt find it if it is)
    >>
    >> Any help would be greatly appreciated
    >>
    >> phillm90
    >
    >
    >.
    >
  4. Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

    What driver version are you installing? v5.2aAs is the
    newest.

    try uninstalling the "USB Printing Support" from device
    manager

    uninstall the printer device driver

    reboot the computer, without the printer connected
    install the printer driver

    turn computer off
    reboot, connect the printer, turn printer power "ON"


    >-----Original Message-----
    >I keep getting an error when i try to install my Epson
    >C40UX printer.
    >
    >I just did a fresh install of WinXP Home, i have
    downloaded
    >and installed all of the latest updates and patches.
    >Before the reinstall the printer was working perfectly,
    now
    >when windows tries to install the drivers it doesnt work.
    >The device manager shows a device called "USB Printer"
    with
    >the little exclamation mark that it has when things dont
    >work. If i try to reinstall the drivers for that device,
    it
    >comes up with an error saying: "There was a problem
    >installing this hardware, USB Printing Support. An error
    >occurred during the installation of the device, The data
    is
    >invalid"
    >
    >It does this no matter how many times i try
    >uninstalling/rebooting and reinstalling the driver.
    >
    >Ive had a quick look in the knowledge base but i couldnt
    >find anything of any use to me (which is not to say that
    it
    >isnt there, just that i couldnt find it if it is)
    >
    >Any help would be greatly appreciated
    >
    >phillm90
    >.
    >
  5. Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

    yeah, i forgot that it was turned off when i did the
    Windows Install.. I noticed a couple of days later, when i
    wanted to use the printer..

    >-----Original Message-----
    >Did you leave the printer disconnected from the computer
    when you
    >reinstalled windows and printer drivers?
    >
    >
    >"Phill Macey"
    <phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in
    >message news:190c301c4215a$edb6f420$a601280a@phx.gbl...
    >thanks Mary, i have looked through all of the links you
    >gave me and followed any relevant links that i found while
    >looking but I didnt find anything that helped.
    >
    > I should have pointed out in my first post, there is
    >definantly nothing wrong with the printer because 1) i can
    >get it to print its own test page (not using the windows
    >one, just using the combination of button presses on the
    >printer - it doesnt even need to be connected to the computer)
    >2) it was working just fine before i reinstalled windows.
    >Im certain it is a driver problem. I dont think it is a
    >problem with the epson drivers though. It is just the 'USB
    >Printer Support' one that windows installs to allow the
    >printer to be on a usb port.. I can get the epson drivers
    >to install, but they can not access the printer because
    >that other driver is not functioning (they can only access
    >LPT ports, COM ports, and FILE)... Yes i uninstalled the
    >printer drivers before i tried installing them again.
    >
    >USB works fine cause ive had other usb devices (storage
    >devices) running without any problems. I have tried
    >plugging it into different usb ports, and it still doesnt
    >work no matter what port i put it in.
    >
    >I can tell that this is going to be a real pain in the
    >bum.. it already has been
    >
    >phillm90
    >
    >>-----Original Message-----
    >>Epson has many support documents
    >>http://tinyurl.com/3d6a9
    >>Resources for Troubleshooting Printing Problems in Windows XP
    >>http://support.microsoft.com/default.aspx?scid=kb;en-us;308028&Product=winx
    >p
    >>General USB Troubleshooting in Windows XP
    >>http://support.microsoft.com/default.aspx?scid=kb;en-us;310575&Product=winx
    >p
    >>
    >>--
    >>Mary Sauer MS MVP
    >>http://office.microsoft.com/
    >>http://www.mvps.org/msauer/
    >>news://msnews.microsoft.com
    >>"Phill Macey"
    ><phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in
    message
    >>news:1be8b01c42119$3565cea0$a101280a@phx.gbl...
    >>> I keep getting an error when i try to install my Epson
    >>> C40UX printer.
    >>>
    >>> I just did a fresh install of WinXP Home, i have downloaded
    >>> and installed all of the latest updates and patches.
    >>> Before the reinstall the printer was working perfectly, now
    >>> when windows tries to install the drivers it doesnt work.
    >>> The device manager shows a device called "USB Printer" with
    >>> the little exclamation mark that it has when things dont
    >>> work. If i try to reinstall the drivers for that device, it
    >>> comes up with an error saying: "There was a problem
    >>> installing this hardware, USB Printing Support. An error
    >>> occurred during the installation of the device, The data is
    >>> invalid"
    >>>
    >>> It does this no matter how many times i try
    >>> uninstalling/rebooting and reinstalling the driver.
    >>>
    >>> Ive had a quick look in the knowledge base but i couldnt
    >>> find anything of any use to me (which is not to say that it
    >>> isnt there, just that i couldnt find it if it is)
    >>>
    >>> Any help would be greatly appreciated
    >>>
    >>> phillm90
    >>
    >>
    >>.
    >>
    >
    >
    >.
    >
  6. Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

    See inline comments


    >-----Original Message-----
    >What driver version are you installing? v5.2aAs is the
    >newest.
    Yeah, ive got the latest ones off the epson site. but they
    are useless to me unless i can install USB printing support
    because without it, they will only let me install the
    printer on either: LPT ports, COM ports or FILE


    >
    >try uninstalling the "USB Printing Support" from device
    >manager
    >
    >uninstall the printer device driver
    >
    >reboot the computer, without the printer connected
    >install the printer driver

    Same problem as above.. I dont know how to manually install
    USB Printer Support..until i get that working I cant tell
    the drivers that there is a printer on a USB port.


    >
    >turn computer off
    >reboot, connect the printer, turn printer power "ON"
    >
    >
    >
    >
    >
    >
    >
    >>-----Original Message-----
    >>I keep getting an error when i try to install my Epson
    >>C40UX printer.
    >>
    >>I just did a fresh install of WinXP Home, i have
    >downloaded
    >>and installed all of the latest updates and patches.
    >>Before the reinstall the printer was working perfectly,
    >now
    >>when windows tries to install the drivers it doesnt work.
    >>The device manager shows a device called "USB Printer"
    >with
    >>the little exclamation mark that it has when things dont
    >>work. If i try to reinstall the drivers for that device,
    >it
    >>comes up with an error saying: "There was a problem
    >>installing this hardware, USB Printing Support. An error
    >>occurred during the installation of the device, The data
    >is
    >>invalid"
    >>
    >>It does this no matter how many times i try
    >>uninstalling/rebooting and reinstalling the driver.
    >>
    >>Ive had a quick look in the knowledge base but i couldnt
    >>find anything of any use to me (which is not to say that
    >it
    >>isnt there, just that i couldnt find it if it is)
    >>
    >>Any help would be greatly appreciated
    >>
    >>phillm90
    >>.
    >>
    >.
    >
  7. Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

    oops, forgot to enter my details for that post... too late now.

    phillm90

    >-----Original Message-----
    >yeah, i forgot that it was turned off when i did the
    >Windows Install.. I noticed a couple of days later, when i
    >wanted to use the printer..
    >
    >>-----Original Message-----
    >>Did you leave the printer disconnected from the computer
    >when you
    >>reinstalled windows and printer drivers?
    >>
    >>
    >>"Phill Macey"
    ><phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in
    >>message news:190c301c4215a$edb6f420$a601280a@phx.gbl...
    >>thanks Mary, i have looked through all of the links you
    >>gave me and followed any relevant links that i found while
    >>looking but I didnt find anything that helped.
    >>
    >> I should have pointed out in my first post, there is
    >>definantly nothing wrong with the printer because 1) i can
    >>get it to print its own test page (not using the windows
    >>one, just using the combination of button presses on the
    >>printer - it doesnt even need to be connected to the
    computer)
    >>2) it was working just fine before i reinstalled windows.
    >>Im certain it is a driver problem. I dont think it is a
    >>problem with the epson drivers though. It is just the 'USB
    >>Printer Support' one that windows installs to allow the
    >>printer to be on a usb port.. I can get the epson drivers
    >>to install, but they can not access the printer because
    >>that other driver is not functioning (they can only access
    >>LPT ports, COM ports, and FILE)... Yes i uninstalled the
    >>printer drivers before i tried installing them again.
    >>
    >>USB works fine cause ive had other usb devices (storage
    >>devices) running without any problems. I have tried
    >>plugging it into different usb ports, and it still doesnt
    >>work no matter what port i put it in.
    >>
    >>I can tell that this is going to be a real pain in the
    >>bum.. it already has been
    >>
    >>phillm90
    >>
    >>>-----Original Message-----
    >>>Epson has many support documents
    >>>http://tinyurl.com/3d6a9
    >>>Resources for Troubleshooting Printing Problems in
    Windows XP
    >>>http://support.microsoft.com/default.aspx?scid=kb;en-us;308028&Product=winx
    >>p
    >>>General USB Troubleshooting in Windows XP
    >>>http://support.microsoft.com/default.aspx?scid=kb;en-us;310575&Product=winx
    >>p
    >>>
    >>>--
    >>>Mary Sauer MS MVP
    >>>http://office.microsoft.com/
    >>>http://www.mvps.org/msauer/
    >>>news://msnews.microsoft.com
    >>>"Phill Macey"
    >><phillmNinetyREPLACEITWITHNUMBERS@hotmail.com> wrote in
    >message
    >>>news:1be8b01c42119$3565cea0$a101280a@phx.gbl...
    >>>> I keep getting an error when i try to install my Epson
    >>>> C40UX printer.
    >>>>
    >>>> I just did a fresh install of WinXP Home, i have
    downloaded
    >>>> and installed all of the latest updates and patches.
    >>>> Before the reinstall the printer was working
    perfectly, now
    >>>> when windows tries to install the drivers it doesnt work.
    >>>> The device manager shows a device called "USB Printer"
    with
    >>>> the little exclamation mark that it has when things dont
    >>>> work. If i try to reinstall the drivers for that
    device, it
    >>>> comes up with an error saying: "There was a problem
    >>>> installing this hardware, USB Printing Support. An error
    >>>> occurred during the installation of the device, The
    data is
    >>>> invalid"
    >>>>
    >>>> It does this no matter how many times i try
    >>>> uninstalling/rebooting and reinstalling the driver.
    >>>>
    >>>> Ive had a quick look in the knowledge base but i couldnt
    >>>> find anything of any use to me (which is not to say
    that it
    >>>> isnt there, just that i couldnt find it if it is)
    >>>>
    >>>> Any help would be greatly appreciated
    >>>>
    >>>> phillm90
    >>>
    >>>
    >>>.
    >>>
    >>
    >>
    >>.
    >>
    >.
    >
Ask a new question

Read More

USB Devices Printers Windows XP