Sign in with
Sign up | Sign in
Your question

World at War crashes to desktop when it goes online

Last response: in Video Games
Share
March 29, 2012 9:48:05 PM


It seems that whenever the game tries to go online it just crashes with no error messages. Doesn't matter if it's single- or multiplayer. My Anti-Virus was preventing from going online for some reason, so I could play single-player, but when I disabled my anti-virus the game wouldn't even reach main menu before it crashed to desktop.
I tried reinstalling it without punkbuster and when I logged my account back in, same thing happened.

The game worked a few days ago. Once. And then it didn't work again.
I even reinstalled Windows to see if it would help, but it didn't.

I have tried every suggestion I found online. Sound card settings, uninstalling modems etc.
I also opened the required ports on my router.

I sent an email to Activion, but I didn't get a reply yet.

I recently bought a new machine, maybe that has something to do with it. Maybe CD aunthentication or something?

I have Windows 7 64 bit, AMD Phenom II X4 processor, ASUS M5A97 Pro Motherboard, 4gb kingston RAM, and Radeon HD 6870 graphics card.
March 29, 2012 9:49:17 PM

I would also like to add that Call of Duty 4 works just fine, but I prefer World at War.
March 30, 2012 9:52:09 AM

Update:
I can loan a CD key from my friend, so that I can try if the issue is with that.
Does anyone know if you can use the CD key on multiple machines? Because I got just got a new machine, and the game used to work with my old one.

I saw a thread about this problem here, but it was closed and the solution didn't work for me (Uninsall pb and reinstall game without it)

PS. How long is the edit option allowed for messages, because I don't like adding a new reply every time.
Related resources
March 30, 2012 12:13:27 PM

I got it working finally. I donät know what I did different from last time but this is what I did:
Uninstalled game
Reinstalled WITHOUT punkbuster
installed all the patches up to 1.7
installed punkbuster

You can close this thread.
April 1, 2012 6:14:43 PM

FFS, It's back.
Help anyone?
April 2, 2012 5:47:27 PM

Lol It fixed itself. I didn't do anything. Maybe the problem is at activions end.
April 2, 2012 7:25:37 PM

Seems like its not a problem that is there all the time?
Hmm. I don't see why this problem should be there, after my tech skills your pc looks very good and it shouldn't have any problems when playing an old game like World At War.
But PB does many times have something to do with crashes and that's why I always prefer not to install PB unless necessary (which it are to play on most servers in games which want you to install PB)
But of course we can't always blame PB, but I need to be sure. When you got it fixed, was it from installing it with your friends CD or your own?
April 3, 2012 12:48:31 PM

bloodandbon3s said:
Seems like its not a problem that is there all the time?
Hmm. I don't see why this problem should be there, after my tech skills your pc looks very good and it shouldn't have any problems when playing an old game like World At War.
But PB does many times have something to do with crashes and that's why I always prefer not to install PB unless necessary (which it are to play on most servers in games which want you to install PB)
But of course we can't always blame PB, but I need to be sure. When you got it fixed, was it from installing it with your friends CD or your own?


No. I did't even have to reinstall. I was going to input my friends CD key in the main menu, but my profile got online before I could try that.

But I just tied to play the game again just now, as I'm writing this, THE PROBLEM IS BACK!?
I'm going to try out to put the CD key in the menu.

I'll come back with results
April 3, 2012 3:37:21 PM

I played one match in black ops and GTA IV for a while and WaW still works.
Problem might be fixed.

Maybe I'll find out tomorrow.

Do you happen to know if WAW has some DRM or something like that, what prevents from istalling on many machines.
My copy of waw was installed for at least three machines/versions of windows

April 6, 2012 10:38:57 AM

The problem came back. I disabled my internet and put in my friends CD key back in and it worked again.

I'm starting to think more and more that the problem is with the servers.
!