Sign in with
Sign up | Sign in
Your question

Game stutter

Tags:
  • PC gaming
  • Games
  • Video Games
Last response: in Video Games
Share
April 1, 2012 1:55:10 PM

Wasn't getting much help in the systems forum, decided to post here instead. In almost every game I play I experience massive stutters and retarded fps spikes. In Skyrim, fps is generally in the 30's to 40's but I have constant stutters (they generally stop when my character is not moving). What I find odd is when recording with fraps, all my problems seem to disapear... In valve games, the stuttering only appears after long periods of playing (temps are fine). In LoL, my fps is jittery, it goes from 30 to 60 continuously. My cpu temps never exceeds 50-60C and same with the GPU.

Specs:

i7 920 stock
EVGA x58 sli le
6GB mushkin 1066
Sapphire 5570 1gb (oc'd to the max)---using ati 11.12 drivers, 12.x ones suck
Auzentech studio 5.1 sound card
Stays cool in a cooler master scout case.

I'd really appreciate some help.

More about : game stutter

April 2, 2012 12:49:58 AM

you have a good basic system thats being hobbled by a crap gfx card.
you will be lucky to clear 30 fps on low settings for a game like bf3
the chances are your settings are just way past what your card can handle so turn everything down to minimum apart from the screen rez. turn off fxaa and any other advanced features...
seriously m8 get 150 together and get a decent gfx card and your system will love you for it...

as you can see i have a 920 also but where your system will be lucky to hit 10000 on 3dmark06 mine hits over 18000 at stock and 22000 (cpu)oc'd... this is pretty much down to the gfx i have but if you can get your hands on a gtx 560 ti, or a 6850/6870 you would get roughly the same as me...
m
0
l
April 2, 2012 11:40:08 AM

Okay, but I'll think I'll wait until the full 6xx series is released, I could probably snatch a deal on a gtx460 or 470. One thing I don't understand is why running traps in the background stopped the stutters.
m
0
l
Related resources
April 2, 2012 12:43:07 PM

cause fraps probably was set to run at 30fps or 60fps which is exactly half or matches your screens refresh rate so its basically forcing a vertical synchronization with the screen and this will reduce or even get rid of stutters...
to repeat this in game turn vsnc on and hope its as effective as fraps... the difference being is that the game is likely to have a variable fps where as fraps locked it at 30 or 60 even though it could give more...
m
0
l
April 4, 2012 2:13:55 AM

If you are getting improved performance by recording with fraps, you could always try underclocking your CPU, seeing as how that is the only impact fraps has on your system when recording (drains CPU resources).

Joke.

Aside from upgrading your GPU, there are a few things you can try.

You can try installing a fps limiter. Try capping your frame rate at around 30fps (which is what the console version runs at, so it's definitely more than playable).

You can try updating your graphics drivers (that's pretty much a given, though), seeing as how when Skyrim came out, new drivers had to be released for performance reasons.

Lastly (and perhaps your best chance), you could try downloading and installing this (it's free)...

http://www.iobit.com/gamebooster.html

I use it myself and it helps...A lot.

Seeing as how fraps seems to help, I would think that this would solve your problem. It's hard to explain why, but fraps effects the CPU (but for the worse), while Game Booster effects the CPU and RAM (but for the better). It will free up resources to allocate towards your gaming. After installing, just right click on the shortcut of what ever game you want to play, and select, "Run with Game Booster".

I use it and get a good 2-3 fps boost. But seeing as how my system is already quite powerful, you may actually get a bigger boost than that.
m
0
l
April 4, 2012 4:17:29 AM

maxidodies said:
Okay, but I'll think I'll wait until the full 6xx series is released, I could probably snatch a deal on a gtx460 or 470. One thing I don't understand is why running traps in the background stopped the stutters.

I got a gtx 680 and love it. Ive only had a few problems like some horizontal lines in crysis, crysis 2 and sometimes in bf3 and crysis is grainy for some reason :p  i think its a driver issue...but yeah i would wait for the rest of the 600 series the 660 or 660ti should be a good buy and should handle anything currently out quite well. Also you can cap the frame rate at whatever you want with evga's new precision x I find that 40 fps is the sweet spot if your trying to geta smooth frame rate. I mean 30 is good but 40 seems a step up smoother. also just mess with the settings that are the most performance heavy like turning anti aliasing down or just off does wonders. I ran skyrim at ultra for the most part on my gts 450 with that off shadow detail turned down and object detail at like 3 or something. Hope this helps
m
0
l
April 4, 2012 9:32:39 PM

PCgamer81 said:
If you are getting improved performance by recording with fraps, you could always try underclocking your CPU, seeing as how that is the only impact fraps has on your system when recording (drains CPU resources).

Joke.

Aside from upgrading your GPU, there are a few things you can try.

You can try installing a fps limiter. Try capping your frame rate at around 30fps (which is what the console version runs at, so it's definitely more than playable).

You can try updating your graphics drivers (that's pretty much a given, though), seeing as how when Skyrim came out, new drivers had to be released for performance reasons.

Lastly (and perhaps your best chance), you could try downloading and installing this (it's free)...

http://www.iobit.com/gamebooster.html

I use it myself and it helps...A lot.

Seeing as how fraps seems to help, I would think that this would solve your problem. It's hard to explain why, but fraps effects the CPU (but for the worse), while Game Booster effects the CPU and RAM (but for the better). It will free up resources to allocate towards your gaming. After installing, just right click on the shortcut of what ever game you want to play, and select, "Run with Game Booster".

I use it and get a good 2-3 fps boost. But seeing as how my system is already quite powerful, you may actually get a bigger boost than that.



Thanks, this really helped. I installed game booster and enb series patch in conjuction with an fps limiter and now everything is smooth and my fps stays at 31.
m
0
l
April 6, 2012 6:51:48 AM

maxidodies said:
Thanks, this really helped. I installed game booster and enb series patch in conjuction with an fps limiter and now everything is smooth and my fps stays at 31.

No problem, glad to be of some help.
m
0
l
!