Sign in with
Sign up | Sign in
Your question

AoE2, gameranger issues.

Last response: in Video Games
Share
April 3, 2012 8:28:41 PM

Bah, this is driving me insane. I'm usually pretty good at solving my own problems but this is nail biting. Basically, I'm trying to play AoE with gameranger with my friends. I've done this before on my old laptop.

Now I've updated to a better PC, it simply doesn't work. Initially, I took note of the changes - It no longer operates on wireless, and I'm now using W7 instead of vista.

I can't try it with wireless, and don't really want to mess around with the OS as I feel there must be a fix somewhere before that point. Heed my words when I say this: I've tried everything :kaola: 

From router settings, DMZ, messing with IPs, Hamachi, other software, unblocking every port relating to any program it uses messing with the PC. I even tried to bodge up IPX for W7!

After days of messing around, I've came nowhere, all I get told now is "You need a static IP" and I do have a static IP. I fail to understand the issue, I host many things, such as a webserver from this machine.

The result is the same "Unable to join game". For the love of all sanity, someone, please help me.

Any contributions are really appreciated, I'm hoping this is me being clumsy and it's a nice easy fix.

More about : aoe2 gameranger issues

April 3, 2012 9:27:25 PM

Hello, and sorry as I'm not familiar with this gameranger, could you explain what exactly it's supposed to do for you?
April 4, 2012 12:58:10 AM

itsa basically like steam and origin. or even xfire... where you log in and you can connect to friends to play private or public matches. mostly its used by pirates to host games that would otherwise not let them play multiplayer online but its also used by a small but loyal legit group of users... the good news is that you dont actually need it.

you can host the game and invite your friends to join you by giving them your ip and a port numbers...
TCP Ports
2300-2400,47624
UDP Ports
2300-2400

they enter your ip into there game click join and they will appear in your game...

sadly aoe2 nolonger has any online support...
April 4, 2012 5:57:56 PM

Thanks for the replies, unfortunately, HEXiT, the ports you mentioned are already unblocked in my router, and any Windows firewall (I've even disabled the Windows firewall to ensure this).

I have tried the method you stated as well, by direct connection without gameranger - That too did not work. As I said in the OP, this did previously work on my laptop with the same router settings.

My initial hypothesis was that the older version of windows supported aoes old protocol, and newer versions of windows do not. This was shot down when a friend of mine informed me he can play without issue on windows 7.
August 16, 2012 4:09:37 PM

I know what you mean, I too upgraded my machine to a fully decked out gaming computer and I am now unable to play aoe2 on gameranger. I have tried everything you have listed and then some. I will let you know if I find anything but if anyone has had these problems and fixed them, please let me know. By the way do you get stuck on the "setting up multiplayer" match screen?
January 30, 2013 1:41:33 AM

OMG... at least I know I am not alone. I was able to fix the color issue, but I can host, and no one else can join, or I cant join. Again played for years. Old tower dead, new one has windows 7. tried removing flash player. That didit work. tried inputting my own IP on the setup. that didint work. I keep thinking its some kind of fire wall thing. But honestly no idea
June 7, 2013 2:07:00 AM

hi, see i had this problem where im stuck in the page where it say "setting up multiplayer game". Where i was unable to join games. so what i did was i turned off my firewall. And then i tried to join a game and i successfully joined the game :D  . try it out good luck
!