Sign in with
Sign up | Sign in
Your question

Darkness 2 Help Needed

Last response: in Video Games
Share
April 8, 2012 11:45:58 PM

Hello Tom's Hardware community, I am in need of desperate help.
Here are my specs-
Processor (AMD FX-8150 CPU (8x 3.60GHz/8MB L2 Cache)))
Motherboard (Gigabyte GA-970A-D3 -- AMD 970))
RAM- 16GB
Graphics Card- AMD Radeon 7770 Crossfire mode

Okay so here is my problem,
When I attempt to launch The Darkness 2, Saints Row 3, and Deus ex: Human Revolution, My entire computer crashes giving me a blue screen. I have researched this issue and people are saying it's a graphic card issue.

This is weird for me considering I can run Crysis 2 and Skyrim on full blast around 60 FPS with no problem. Can someone please help me?

Thanks
- liamthetank11

More about : darkness needed

April 9, 2012 6:01:57 AM

Did you try disabling CF and using either one of those HD 7770s?
Which drivers are you using?
m
0
l
April 9, 2012 1:03:18 PM

drivers and most likely seeing how these are new cards you got there, there's bound to be some compatibility issues that AMD should fix eventually
m
0
l
Related resources
April 9, 2012 4:42:10 PM

Gman450 said:
Did you try disabling CF and using either one of those HD 7770s?
Which drivers are you using?


How would I disable crossfire, i've tried a few times and I couldn't figure it out.
m
0
l
April 9, 2012 4:51:22 PM

Gman450 said:
Did you try disabling CF and using either one of those HD 7770s?
Which drivers are you using?


And im using AMD drivers, it says its all up to date.
m
0
l
April 9, 2012 4:54:06 PM

liamthetank11 said:
How would I disable crossfire, i've tried a few times and I couldn't figure it out.

It should be in CCC. Although I've never owned a AMD/ATi card.
Right click on the AMD/ATi icon, highlight the first card, CrossFireX settings, disable crossfire.
m
0
l
April 9, 2012 5:06:24 PM

Gman450 said:
It should be in CCC. Although I've never owned a AMD/ATi card.
Right click on the AMD/ATi icon, highlight the first card, CrossFireX settings, disable crossfire.


I've tryed doing that before there is no possible way to turn off crossfire though CCC
m
0
l
a b À AMD
April 10, 2012 3:54:34 PM

you dissable crossfire via the ccc panel (In the bottom right, right click the ATI icon. Then highlight the first card > CrossfireX settings > disable crossfire.) if theres no option to disable crossfire it means your system doesnt have crossfire or its not being detected...
if this is the case then open the pc and check the leads... the crossfire bridge, the power connectors and make sure its firmly seated in the gfx slot...

go into bios load optimized defaults and set hpet mode to match your.o.s bit rate.
set up your raid if you have 1 and your drive order... save and quit..
run windows and se if you can force a crash and note down the 0x000000 number... and its error text... you can also use bluescreen view to read the dmp files that bsods create.
m
0
l
April 10, 2012 5:52:41 PM

HEXiT said:
you dissable crossfire via the ccc panel (In the bottom right, right click the ATI icon. Then highlight the first card > CrossfireX settings > disable crossfire.) if theres no option to disable crossfire it means your system doesnt have crossfire or its not being detected...
if this is the case then open the pc and check the leads... the crossfire bridge, the power connectors and make sure its firmly seated in the gfx slot...

go into bios load optimized defaults and set hpet mode to match your.o.s bit rate.
set up your raid if you have 1 and your drive order... save and quit..
run windows and se if you can force a crash and note down the 0x000000 number... and its error text... you can also use bluescreen view to read the dmp files that bsods create.


Where is the ATI icon in the bottom right? I have the new update of CCC caled AMD Vison Engine Control Center, ill continue to look but for now i dont see it.
m
0
l
a b À AMD
April 10, 2012 6:05:44 PM

tray icon in the bottom right corner of your desktop
m
0
l
April 10, 2012 6:13:49 PM

HEXiT said:
tray icon in the bottom right corner of your desktop


Okay it shows my card 5 times and crossfirex settings isnt there
m
0
l
a b À AMD
April 10, 2012 6:57:54 PM

5 times? it should show maybe 3 depending on how many monitors you have...
as you cant find the off button then you can just disconnect the power on 1 card while you run your tests, just pull the leads on the bottom most card. then try your game and see if theres any stability problems or improvements.

but dont forget the bsod error codes as they are what will point me to your solution much faster than you trying and posting the results...

m
0
l
a b À AMD
April 12, 2012 1:50:24 AM

the last time i had 65 monitors show up is when the install of the ccc went wrong. i ened up having to format my primary partition as ccc just would not detect my hardware correctly...
also forget the 12.3 drivers use the 12.2 beta/performance drivers. they seem more stable and have little extras that have been left out of 12.3 for stability reasons.
m
0
l
!