Sign in with
Sign up | Sign in
Your question

Strange Mass Effect 3 framerate lag

Last response: in Video Games
Share
April 16, 2012 11:55:58 PM

Hi there. I just started playing Mass Effect 3 the other night and I'm having some incredibly strange framerate issues. When I first started up the game my FPS was chugging at 10-15 (which is incredibly low for my PC) so I checked and found that my video card drivers were out of date. I updated them, restarted and the game ran perfectly at 60+ FPS. The next day I played a little and it worked fine. I then did some work for about 3-4 hours and upon return the framerate issue had returned. At this point I attempted every fix I could find. I checked to make sure all possible drivers were up to date. I checked Directx, checked all my Nvidia settings and nothing would fix it. I tried disabling vsync as I read online that it was causing problems. This did not fix the issue. Out of frustration I tried playing the game in windowed mode and the FPS issue disappeared. I then tried on borderless windowed mode and the FPS dropped to 10-15 once again.

I finally decided to just reinstall the drivers in case they had been corrupted somehow. I reinstalled my video card drivers, rebooted and found the fullscreen FPS issue to be fixed again. Today I started up the game and the fullscreen FPS issue has returned. It still runs fine in windowed. Anyone have any idea what is going on here?

Specs:
3.20 GHz i7 960 CPU
12 GB RAM
x2 Nvidia GTX 460M (1GHz each, SLI'd)
64 bit Windows 7
April 17, 2012 12:59:07 AM

sounds like your sli may be the issue... if your driver stops working and restarts it may not restart with sli enabled.
April 17, 2012 1:48:27 AM

HEXiT said:
sounds like your sli may be the issue... if your driver stops working and restarts it may not restart with sli enabled.


I thought so as well. Same problem even with SLI disabled.
Related resources
May 5, 2012 4:45:44 AM

Go to Users\[username]\My Documents\BioWare\Mass Effect 3\BIOGame\Config directory. Once in there you need to add the following to the bottom of the [SystemSettings] section

SmoothFrameRate=False
UseVSync=False

Then save this file.

This will override the 60 fps limit that Bioware put on this game for some strange reason. You cannot do this ingame settings. Hope this helps.
May 5, 2012 7:27:41 AM

after re-reading this and looking at the symptoms im convinced its a background process causing the issue... it went away after your reinstall but you also restarted the machine which would also get rid of any unused services/processes.
if this persists. then instead of re-instlling the drivers. try rebooting. and see if the problem vanishes... if so then take not of the active background tasks and when it happens again check em to see what has been added or is using a lot of cpu...

May 8, 2012 5:34:29 PM

There are two things that are most common with this issue - first is turning off Origin in game (Frame Rate EATER) - Go to settings and turn it off. Another thing that helped me was to set my video card setting for the game at the card level, not game. For NVIDIA you right click on the desktop and then got to the NVIDIA control panet and change the settings for ME3 there.
!