Sign in with
Sign up | Sign in
Your question
Closed

Batman Arkham City

Last response: in Video Games
Share
April 17, 2012 8:27:20 AM


Oh Dear :)  a week ago i build a gaming machine spec: MOBO- Asus crosshair v formula, CPU - Amd FX-8150 BE, Ram- Hynix 4 + 4Gb ddr3 dual channel 1333 Mhz, Monitor - LG LED 3D 23" 1920 x 1080 p, Logitech Wireless KB & Mouse, Cooler Master gaming cabinet & CM 850 Watt PCU, Graphic Card, Sapphire HD 6970 2Gb Single
So i installed gently all hardware & components to its destiny, Now i installed win 7 64 bit ultimate, update all s/w components including bios, GPU catalyst latest version, Motherboard chip set drivers & its utilities, Now i installed 2 games Batman Arkham City & Assassins Creed Revelation(it runs awesome till now), When i start Batman AC with All High setting, 8x AA, Direct x 11 function Off, Res. 1920 x 1080, it starts smoothly i see a benchmark tools so i go with it first, giving FPS Max 65, Avg 55, min 41, every thing is good i enjoy the game a lot, but today it's some thing went wrong, i again i test the batman inbuilt game benchmark it shows Max 42, Avg-35, Min 18, OMG what terrible happens seriously i hurt a lot, So please help me some body here the most hi-tech community.. Help needed :( 

Regards
Abhishek

More about : batman arkham city

April 19, 2012 9:11:16 PM

Did anything change with your system between the time period where it ran well and then didn't run as well? Any driver updates? Do you have any conflicting applications running the background. If something such as an anti-virus program was auto-updating in the background, you would lose performance. Sometimes it inexplicably happens from time-to-time on my system as well, and if I am positive I made no changes to my system that would lead to lost performance, I'll just reboot my computer to make sure something isn't conflicting in the background. This works in most cases.

You could try dropping your AA to get some of that back in the mean time. The benefit vs. performance lost going from 2x to 8x AA is really not worth it.
Score
0
April 19, 2012 9:48:37 PM

temperatures?
Score
0
Related resources
April 23, 2012 7:50:34 AM

1st of all thanks for your precious reply, ya the only thing i change during that time is i just update graphic card catalyst ver 11.9 to 12.3, also installed AMD over drive and about antivirus program before game play i just switch it to gaming profile, only background application that i opened is amd overdrive, and catalyst s/w to watch the status of GPU, CPU & Mother boards. So, please from this conclusion what i have done, is some thing wrong from me, Hey today it is more worst than before again i test the benchmarks from Batman arkham city results are Max- 40, Min 32, Min 12 :( , That's all the performance is going to be worst day by day.. Any idea please help me.

Again Thanks for your reply...
Score
0
April 23, 2012 7:55:44 AM

Thanks a lot for reply, Ya during game play Batman Arkham City i monitored the temp GPU = 70 C, CPU = 65 C, Motherboard = 50 C, I exactly reset my system to default no changes to their standard settings, please from above temp status tell me that's an ideal temp or not.. ? please help needed..
Score
0
April 23, 2012 7:58:36 AM

Have you installed Catalyst Application Profiles v12.3?
Score
0
April 23, 2012 8:15:01 AM

Sorry i only update catalyst to v 12.3, not installed Profiles..
Thanks for reply...
Score
0
April 23, 2012 8:22:14 AM

Just hazarded a guess.I too had problems with CAP v12.3 and couldn't run nfs shift without problems.However,I uninstalled the app profiles and suddenly it started to work.That's why I thought maybe uninstalling CAP would help.Check if you have accidentally enabled DX11 ? :) 
Score
0
April 23, 2012 1:48:06 PM

Those temperatures, are they the maximums or averages?

Also, the AMD overdrive, just not something I'd play with unless you know exactly what you're trying to achieve with it. Check that your GPU and CPU are running at proper clock when under load.

As others suggested, try 12.2 performance drivers and make sure you still have dx11 turned off and windows power options to full performance.

If still nothing I'd uninstall the overdrive and try then.

Let us know what you find
Score
0
April 23, 2012 2:13:52 PM

Couple of other questions - how much of your vram is in use during gameplay? What is your GPU utilization during gameplay? Did you do any overclocking?

Also, if it worked well before you updated drivers, and after the update it didn't work well, try rolling your drivers back and see if you get your performance back.

Score
0
April 24, 2012 6:31:49 AM

http://www.evga.com/forums/tm.aspx?m=1509605&mpage=1 go here and follow the fix. it really does work... no need to do the last part where you turn off frame smoothing as it doesnt really do anything at least not on ati cards...

credit to absxiith who asked me to try it out for him yesterday....
i did and feel i can post his link as i earned the right to ...
Score
0
April 24, 2012 6:37:32 AM

:)  Sure,no probs. :)  But credit actually goes to the EVGA forums... :) 
Score
0
April 24, 2012 8:17:14 AM

Thanks a lot absxiith, Hexit, heids24 & antizig, :)  Thanks for your great support buddy ya i have done lot of thing to max gaming performance, after installing dot net 4 and AMD fusion s/w including catalyst profile i get some new results are as Max -62, Avg-58, Min 42 :)  with directx 11 off, wow!! now the bad days really gone at a time, I don't know what suited better, but your precious guidelines help me a lot,
First of all i went to the BIOS of MOBO set performance to extreme. now i proceed with above s/w installation i.e. amd fusion, catalyst profile(i never touch this app till now) than i go with a single restart. during game play batman AC, i used FPS s/w Frap & also test inbuilt benchmark. i got better FPS now, also updated Batman AC new patches.
Directx 11 have another issue, when i switched on directx 11 FPS Max -32 Avg-24, Min 12, really i unable to play after switching directx 11 on, lots of lag.
One thing i want to ask you that as per my above PC Config what will be the max fps using direct x 11 any suggestion or idea.. :( 

Again thanks for solving without directx 11 solve my issue on Batman AC game play is its best now. :) 
Still lots to do including my system temp is good or not, may i have to set bios to extreme, or just let my systems(including graphic card) to their standard setting(default) i have to test many times. all tweaking i wanna do to maintain the max gaming performance.

Thanks & best Regards,
Abhishek
Score
0
April 24, 2012 4:02:46 PM

HEXiT said:
http://www.evga.com/forums/tm.aspx?m=1509605&mpage=1 go here and follow the fix. it really does work... no need to do the last part where you turn off frame smoothing as it doesnt really do anything at least not on ati cards...

credit to absxiith who asked me to try it out for him yesterday....
i did and feel i can post his link as i earned the right to ...


HEXiT and absxiith - thanks for that link! I'm gonna have to try this when I get home. I was pretty disappointed that my rig with GTX 580s in SLI (resolution of 2560 x 1600) couldn't handle the game in DX11 smoothly.
Score
0
April 24, 2012 4:34:05 PM

Do post your results here. :) 
Score
0
April 25, 2012 6:50:03 AM

Thanks HexiT and abxiith for your links i tried those steps carefully, still no donuts for me, getting Max - 45, Avg - 26, Min-3.
Score
0
April 25, 2012 6:53:48 AM

Update the game,then try again. :)  Also,try lowering some settings. :) 
Score
0
April 25, 2012 2:54:28 PM

ya i got it soon i will be updated the game by installing latest patches & updates, i will follow your above instruction strictly, also lowering AA 8x to 4x might be helpful, let us see what happens next.
Thank you absxiith :) 
Score
0
April 25, 2012 2:59:34 PM

As instructed by HEXiT,don't try the frame smoothing thing. :) 
Score
0
April 25, 2012 3:26:05 PM

also if you dont have a physx based gpu (ie not nvidia cuda) then leave it off or the game will be gimped by it.
Score
0
April 25, 2012 3:27:05 PM

sorry !! unfortunately i have tested the HEXiT trick, but not found any better FPS. So, i am just completed now only updating with new patches. Hope finally it may works. :) 
Score
0

Best solution

April 25, 2012 3:34:02 PM

Try the fix AFTER updating the game. :)  Let us know your results. :) 
Share
April 25, 2012 5:30:07 PM

Wow !! now feels like thousands bugs free, great relief man, Thanks a lot absxiith now your suggestion helps me the best and defeated my problem with lower FPS finally :) , now i dominate directx 11 with Highest FPS in 1920 x 1200 with all setting to high 8x AA Directx 11 function on and directx 11 tessellation- high + ccc to high setting and gaming performance to optimal quality, getting FPS Max-50 Avg-40 Min-27 :)  :) 
After updating, i just restarted my pc. Hey i got my lollipop. Thank you very much to all of you buddies for your great works :) 
You Helped me a lot now enjoying gaming batman AC
Thanks & Best Regards
Abhishek :) 
Score
0
April 25, 2012 6:22:00 PM

please pick absxiith as best answer then the mods can close this thread as solved.
Score
0
April 26, 2012 4:02:49 AM

Best answer selected by Abhishek Sahu.
Score
0
April 26, 2012 5:23:18 AM

Thank you,Abhishek!Glad I could help! :)  And HEXiT,a big thanks to you for testing it! :) 
Score
0
December 20, 2012 6:34:00 AM

[im playi batman arkham city im stuck with a problem near the museum when i the enter the door the game crashes by giving a message Qa_approved_january2011 any solutions for this ?????

Score
0
December 20, 2012 8:05:11 AM

Try re-installing DirectX and enable steam cloud on steam (found this on the steam forums).:) Hope this helps and please start a new thread from next time.:) 
Score
0
December 20, 2012 9:02:04 AM

DirectX11 or DX9
Score
0
December 20, 2012 9:13:09 AM

could you send me the link of the DirectX ???
Score
0
December 20, 2012 9:58:49 AM

XP3 is my os .....sorry im new to this :( 

Score
0
December 20, 2012 10:17:58 AM

Windows XP SP3 does not support DirectX11.Play Batman Arkham City in DX9 setting only. :)  And please start a new thread if you face any further problems.Right now,when you launch the game,configure it to use DirectX 9(the default version of your system) in the settings window.Hope this helps.:) 
Score
0
!