Sign in with
Sign up | Sign in
Your question

Internet shortcut opens in MS Word, not Firefox. Why?

Last response: in Windows 7
Share
October 12, 2010 6:52:34 AM

Hi all.

I don't know if this is the right place for this thread, but I've just upgraded from XP to W7, and the problem I'm experiencing never occurred in XP, so I'm wondering if it's a W7 thing...

Basically, when I used to work in XP, I'd drag an address (or more specifically the wee logo in the nav bar) from the navigation bar in Firefox into a folder on my desktop, which I could then check out at a later date. I had MS Word installed at that point too, and whenever i clicked on the internet shortcut, it would open up the relevant page in Firefox. (MS Word never made an appearance).

But now, things have changed. I'm using W7 (although I've no idea if that's got anything to do with this problem...) When I drag the wee logo (internet shortcut) from the nav bar into my folder for perusal at a later date, and then click on it, expecting it to open up in Firefox, it opens in MS Word! Excuse my language but WTF? It's really doing my head in. I've right clicked and checked the properties to see if I could get another program to open it (ie - Firefox), but there's no such option.

What do I have to do to get back to how it was when I was working in XP?

(Again, I don't know if it's an OS thing or something else, but it really annoying me and slowing down my work flow)

So what needs to be done so that when I click and open an internet shortcut (that I've dragged onto my desktop for example), it opens an internet page, be it Firefox, which is what I use, or any other browser (it doesn't matter what browser), and NOT B****Y MS Word? Pardon my language, but I'm at my wit's end. I've bin googlin for many hours and can't find the right answer.

Any help most appreciated.

Toby

ps. - there isn't an emoticon that can adequately describe how i feel right now. I might go and design one that would, to blow off a little steam...

Cheers guys and girls x

October 12, 2010 1:12:08 PM

Control Panel>Programs>Default Programs
good luck
m
0
l
October 12, 2010 2:17:56 PM

arkadi said:
Control Panel>Programs>Default Programs
good luck



My friend, thank you very very much. After lots of fiddling, poking and more than a little prodding, the problem is no longer a problem.

I now feel emotionally able to use one of the emoticons that are so flamboyantly trying to attract my attention from the right hand of the screen.

:bounce: 

a big hug to u from me x

m
0
l
Related resources
October 12, 2010 2:21:25 PM

It's always great learning something new too. Thanks again matey, you've really helped me out.

Toby
m
0
l
October 12, 2010 2:58:24 PM

You welcome mate!
Now you know what to do next time when you encounter a problem.
This is one of the best forums you can find. :) 
m
0
l
October 13, 2010 10:53:15 PM

You go that right buddy. I will spread the good word :) 
m
0
l
!