Sign in with
Sign up | Sign in
Your question
Solved

Random lag spikes in-game

Last response: in Video Games
Share
April 22, 2012 2:18:04 AM

Okay so I've had this computer since October. It's custom built and shouldn't have any problems at all. I've actually got two problems, but let's start with the one the thread title speaks of. When I'm in-game (on any game) I get these horribly annoying lag spikes. In some games I'm running at 300+ FPS and it usually never drops below 100 with these lag spikes, but it still causes a millisecond pause with the drop in frame rate.

My second problem is most likely something with my GPU, but I'm not completely sure. It tend's to happen when I start a game, but has happened right during start up. I noticed it happening right after I updated my drivers for my GPU (atleast I believe so). I'll post a link to a picture of what it looks like.

System Specs:

Intel i5 2500k @3.3GHz
8GB Dual Channel Memory
GIGABYTE NVIDIA GeForce GTX 560Ti 1GB
Western Digital Caviar Black 500GB 7200RPM

GPU Problem picture:

If that doesn't work: http://i1095.photobucket.com/albums/i476/john14073/Phot...

More about : random lag spikes game

Best solution

April 22, 2012 4:34:51 AM
Share

that looks like a memory overflow error. where the gpu is displaying memory to the screen. normally it happens when you have a driver that is incopatable with the gfx in some way.
as for the lag spikes. what your seeing is the game stuttering when it gets a sudden increase in demand. the best thing to do is limit the amount of frames your displaying.
if you limit the upper frame limit then the lower frame limit should come up and even out the stutter...
you can do this 2 ways. either adjusting an in game cvar or vsync... adjusting via the game isnt always possible.

April 22, 2012 1:43:18 PM

See, the thing is is that I'm playing such simple games that it shouldn't be stuttering like this. IE: Minecraft and Combat Arms. Which have never maxed out my GPU or CPU, even on max settings. Also, now that I think of it, I believe my vsync is turned off in Combat Arms. Minecraft doesn't have this option.

As for this memory overflow error, how would I fix it?

I'll do some more testing with other games to see if I'm experiencing the same problem there.

Thanks much for the reply!
Related resources
April 29, 2012 4:21:54 AM

Best answer selected by john14073.
April 29, 2012 4:46:01 PM

best just try new drivers. the screen corruption i got when i first got my card went away as the drivers matured ...
!