Sign in with
Sign up | Sign in
Your question

Crysis locked at 24fps on fullscreen?

Last response: in Video Games
Share
April 26, 2012 6:42:46 AM

For some reason the original Crysis is stuck at 24fps on fullscreen. When placed in windowed mode it goes up to 60fps. PC has no problems. i5 2500k @ 4.3 / GTX 680.

I had a similar problem on Crysis 2. The solution i found is disable vsync and fullscreen and then turn each one on seperately and the framerate would go up to 60fps. No luck on the original Crysis yet. I read somewhere there have been some problems with the automatic refresh rate sensor in the games software.

btw playing on 3d HDTV that has options of 60Hz or 24Hz. I guess the games software is sensing the lower Hz option. Anyone have a fix?
April 26, 2012 9:58:32 AM

force the desktop to 60hz and set the tv to 60hz also via the tvs own menu.
then detect the display. hopefully this will set the gfx driver to recognise the tv properly.
it may also be that the tv will only do 1080p at 24hz but will allow 720p upscaled to 1080@60hz

so try setting the games screen rez to 1280/720 to see if thedisplay runs at 60hz. then without changing anything other than the screen rez set the display to 1920/1080 if it drops to 24hz then you have your answer. its the tv and not your system... again you may be able to force it somewhat, by either the tvs menu or the desktop prefs.

if you can get a cheap 1080p monitor. some nice LED backlit cost a little over £100/$150
m
0
l
April 26, 2012 11:25:43 AM

Thanks for response Hexit. Im gaming on a high-end Panasonic plasma VT30. 1080p @ 60Hz is the default settings for the HDTV. Setiings on GPU are set at 60Hz also. I play tons of new AAA games and Crysis 1&2 are the only games that trys to lock at this low framerate, So im hoping there is some auto Hz settings i can change in the config files.
m
0
l
!