Sign in with
Sign up | Sign in
Your question
Closed

GTA IV High CPU usage on Dual Core [Bottleneck]

Last response: in Video Games
Share
April 27, 2012 11:52:52 PM

My PC Specs:

AMD Athlon II X2 245 2.9ghz @ 3.25ghz
Sapphire HD 6670 GDDR5 (Driver 12.4)
4GB DDR2 800mhz @ 1000mhz
PSU Generic 500w
Windows 7 Pro 64-Bit
320GB WD HDD

Game Settings:
All High except Textures
Sliders: 21,31,21
Resolution: 1440x900
Vsync Off
Patch 1.0.7.0.

I'm getting 95-100% CPU Usage.

Framerate around 20-30. Average 25 Fps but i get stutters and textures loads slow. I've already tried lowering resolution and other settings but i get same FPS.

Is there a way to fix it or it's my PC ?
April 28, 2012 2:18:31 AM

How old is your rig? Are you monitoring your temps? When was the last time you did spring cleaning on the inside of your case? Get back to us
Score
0

Best solution

April 28, 2012 2:25:43 AM

CPU and DDR2 800mhz are way too old. I don't think you can do anything to improve frames other than set everything to low.
Share
Related resources
April 28, 2012 3:49:56 AM

Ok thanks guys, yeah my rig OLD, but i fixed it now. Temps are fine.


anyway, i have downgraded to 1.0.4.0. and installed iCEnhancer 2.0n

however, i had lower FPS but it feels a lot smoother than Vanilla.

Benchmark - settings untouched.

Average FPS: 18.07
Duration: 37.51 sec
CPU Usage: 56%
System memory usage: 54%
Video memory usage: 35%



after tuning settings (disabled AA), FPS goes up is around 20-30. not bad for an old Low End PC.

It ain't CPU intensive anymore. now it needs GPU power :) 

____________

Also my CPU and GPU temps became lower than before.
Score
0
April 28, 2012 3:52:37 AM

Best answer selected by Regor245.
Score
0
November 9, 2012 7:03:32 PM

I understand now Devs keep rising the min req to force us up oour Specs..NO REASON execpt money..and we're getting performance upgrades with the baby spoon

HIS pc is under 50% used but he's getting low fps..how's that??
Score
0
!