Sign in with
Sign up | Sign in
Your question

Source Engine games + Guild Wars 1+2 Crash System, No BSOD, No Dump

Last response: in Video Games
Share
April 30, 2012 12:46:31 PM

Hey guys,

this is my first post here and I hope you could give me a hand because, frankly, no one else can. Having hit a complete dead end, I really greatly appreciate any help. Here's my problem:

I own a 10-month-old Sony VAIO VPC-F13E8E laptop (DXDIAG: http://pastebin.com/GPkYCt7t ). Some month ago, I've noticed that it would crash when trying to play Nuclear Dawn, a source engine game. The game would run fine, then without any previous frame drops or artefacts, the sound would loop for roughly a second after which the system would shut down (as in: turn off completely). Pressing the power key immediately afterwards would power it on again without any delay. No dump files are created, nothing in the /Windows/MiniDump/, nada. The same problem would occur with Alien Swarm, also a Source Engine game, and the original Guild Wars. Interestingly enough, nothing of the kind happens when I play Team Fortress 2.

The crashes usually occur between 5 and 15 minutes after game launch, but can happen as late as 45 minutes into the game. After the crash, the area where the CPU is seated feels somewhat warm, but not nearly as hot as on some of my previous machines. The fan never operates on max and the temperatures of the CPU never rise above 70C. The GPU remains on constant 60C. Even if I limit the amount of CPU the game has access to to as low as 35% via power management, these crashes still occur.

Now the important bit is that this does not happen this regularly with any other game. It has happened once or twice, literally, when running League of Legends and that's about it. I can run every other demanding game without any problems.

I have also run some stress tests on the machine to see if it would crash. Letting the CPU run at maximum cycles for half-an-hour caused the fan to become significantly louder then during any time I was gaming, but no crash occurred. Running GPU stress tests had the same effect. As this doesn't affect any other programs, I exclude memory or hard drive faults as a cause.

Technically, the machine is still under warranty. I could return it. The problem is that the service techs will simply run another set of stress tests and tell me that the machine is fine. I live in Germany where I have the right to get a full refund after three repairs, so you can imagine that the store can get a little sceptical about a machine that "apparently doesn't work". I had it before when they couldn't detect a problem with the laptop's power supply. I could ask them to play Alien Swarm for a bit, but, yeah, I think you get my point.

Any ideas? I really don't know what to do or where to ask any more. :( 

PS: I also reinstalled the OS to factory default, so it shouldn't be malware.

PPS: All my drivers were up to date. No new versions of BIOS were released by the manufacturer since purchase.
April 30, 2012 3:22:59 PM

Alright, aside from this being a software issue, two main things that come into my head are:

1. motherboard BIOS
2. PSU not able to meet the capacity

#1 you probably won't be able to verify since you say there's no other BIOS available to try. (Have you checked the actual mobo manufacturer website? I'm fairly sure Sony doesn't make their own mobos)

#2 this you will have to find a benchmark that stresses both CPU and GPU at the same time. The bench marks that stress each one separately verify that CPU and GPU are working properly. To check that your PSU is enough for your hardware you need to load both CPU and GPU at the same time and see if the PSU trips out. That being said, if capacity wasn't enough or faulty PSU the laptop should have continued to run with battery.

Check your event viewer for possible clues. I know I've had similar issues with my laptop where it would just shut down on the spot for no reason, but I've narrowed those down to BIOS issues with Hibernation/Sleep mode, because it will only have a chance to shutdown if I've used hibernation/standby. If it's properly re/started from being shut off I've never had the problem of laptop shut down.

I'm not sure if this is the same issue as you're having or not, because my laptop is from sager, but it's possible the motherboards share some components. Perhaps intel chipset has problems with windows power state cycling. Not sure.
April 30, 2012 11:49:59 PM

Hey,

thanks for your reply.

There's nothing in the event viewer, except an entry made on boot about Windows not being shut down properly. I checked every category and there's really nothing there.

As for software, it could be and there's really no way for me to rule out this possibility. I'm on OEM Win 7 that came with the system, i.e. it's full of useless crap like trial versions of Photoshop Elements, Norton Backup and the usual ilk. I've uninstalled most of it, but aside from buying a new Windows licence there's really no way for me to check if it's some misbehaving service causing trouble. I tried turning off pretty much everything from MSCONFIG to the point where games can still run, but unfortunately to no avail.

I'm not entirely sure about the BIOS. Sony itself offer no newer versions and it seems that the board is actually manufactured by them. I'd also hate to flash anything that doesn't have Sony's stamp of approval due to warranty issues.

Good thinking on #2. Unfortunately that's also a dead end. I ran Prime 95 together with a burn-in GPU tester for about an hour. It got hotter than I've ever seen it, around 80C on the CPU and around 70C for the GPU, but unlike the comparatively undemanding games that keep crashing the system it kept on working until I finally stopped the workers.

It's also not the sleep. I've repeatedly restarted the system after crashes and it still kept crashing.

I really have no idea how to tackle this now. It's a very limited number of programs that even cause this effect, notably Source Engine games, the Guild Wars titles and, something I forgot before, GRID 3.

Again, thanks for your input.
Related resources
Can't find your answer ? Ask !
May 1, 2012 2:49:21 PM

Hmm, very strange. I would say this has something to do with source engine, but seeing how TF2 runs fine compared to others, the only thing I can think of is multi-core processor support or directx compatibility. (try running under win xp compatibiility)

If it were hardware issue, say defective memory or cpu, then it would blue screen and reboot. The fact that it simiply powers down is puzzling. Is there any audio driver updates that sony has for your board?

try running games without the laptop battery

Out of the games that you say you don't have this problem with, can you name a few of them? Maybe we can figure out what's different between them.

also, for the source games, check that they are detecting your dedicated card properly.
May 1, 2012 10:47:09 PM

Okay:

I tried running GW2 under XP Service Pack 3 compatibility, same result. Not sure how to deal with the DirectX issues. I guess I could try uninstalling DX11 and leaving only DX9c on the machine, if that's even possible.

About the drivers: it looks like the system comes with regular Realtek HD audio drivers. Sony's driver download website is two years behind on that. I'll check if the new audio drivers and running without battery (and perhaps only of battery) helps once I get a chance (it takes a bit to redownload the library after the Windows reinstall :p ). Dirt 3 and, I think, Alien Swarm are pretty good at causing these crashes pretty fast (unfortunately GW2 beta weekend is over, so that's out of the question).

A few games that do not crash of the top of my head would be TF2, Tribes:Ascend, League of Legends (this one did crash, but only once or twice in over six month), Dungeon Siege 3 and Deus Ex: Human Revolution + Missing Link.

>also, for the source games, check that they are detecting your dedicated card properly.

How would I check that?

Again thanks, I'm really grateful for your help.
May 1, 2012 11:22:06 PM

if you're missing particular dx9 files, you need run installs for those particular versions of directx (check maybe they are on the game CD). All you got to do is install it, it will get added to the dll folder and the game will be able to use it. If that's the issue...

try disabling windows aero theme while running the game (you can enable this option i compatibility settings)
May 1, 2012 11:24:34 PM

Those I have installed. Steam installs them automatically for each game.

I also tried turning off Aero. Same effect.
May 20, 2012 9:54:46 PM

So I tried installing a new audio driver, I tried playing with battery and AC, with battery but no AC, without battery, I tested both the memory and the HDD. It still crashes, just as it did before.

Does anyone have any ideas anymore? :( 
!