Sign in with
Sign up | Sign in
Your question

Printers unavailable until "net start spooler" is performed

Last response: in Windows XP
Share
Anonymous
June 2, 2004 9:30:55 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

How do I get the printer to work after boot-up without going through the
command process???
I've really been going through the ringer with this thing, any suggestions
would help, I've removed all of the printer drivers, edited the registry to
get the entries out, I need some help! Thanks Jeff
Anonymous
June 2, 2004 9:30:56 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Control Panel, Administrative Tools, Services.... Ensure the Print Spooler
is set to Automatic.
--
Cari
MS-MVP Windows Technologies - Printing/Imaging/Hardware
www.coribright.com

"Jeff F" <bdfd1220@hotmail.com> wrote in message
news:uVYzTCPSEHA.3016@tk2msftngp13.phx.gbl...
> How do I get the printer to work after boot-up without going through the
> command process???
> I've really been going through the ringer with this thing, any
> suggestions
> would help, I've removed all of the printer drivers, edited the registry
> to
> get the entries out, I need some help! Thanks Jeff
>
>
Anonymous
June 2, 2004 11:41:34 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

How do I install the Print Spooler in Services? There is not one in the
services window.....
"Cari (MS-MVP)" <Newsgroups1@coribright.com> wrote in message
news:ur8EDRPSEHA.2936@TK2MSFTNGP10.phx.gbl...
> Control Panel, Administrative Tools, Services.... Ensure the Print Spooler
> is set to Automatic.
> --
> Cari
> MS-MVP Windows Technologies - Printing/Imaging/Hardware
> www.coribright.com
>
> "Jeff F" <bdfd1220@hotmail.com> wrote in message
> news:uVYzTCPSEHA.3016@tk2msftngp13.phx.gbl...
> > How do I get the printer to work after boot-up without going through the
> > command process???
> > I've really been going through the ringer with this thing, any
> > suggestions
> > would help, I've removed all of the printer drivers, edited the registry
> > to
> > get the entries out, I need some help! Thanks Jeff
> >
> >
>
>
Related resources
Anonymous
June 3, 2004 2:27:55 AM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Oh dear.... I see a Repair Installation of XP in your very near future.
Fortunately it's very rare it gets deleted, in all the years I've been
posting here, you're only the second person I've come across who has managed
to lose their spooler.
http://www.michaelstevenstech.com/XPrepairinstall.htm
--
Cari (MS-MVP Windows Client - Printing, Imaging & Hardware)
www.coribright.com



"Jeff F" <bdfd1220@hotmail.com> wrote in message
news:uCUBWLQSEHA.3056@TK2MSFTNGP11.phx.gbl...
> How do I install the Print Spooler in Services? There is not one in the
> services window.....
> "Cari (MS-MVP)" <Newsgroups1@coribright.com> wrote in message
> news:ur8EDRPSEHA.2936@TK2MSFTNGP10.phx.gbl...
> > Control Panel, Administrative Tools, Services.... Ensure the Print
Spooler
> > is set to Automatic.
> > --
> > Cari
> > MS-MVP Windows Technologies - Printing/Imaging/Hardware
> > www.coribright.com
> >
> > "Jeff F" <bdfd1220@hotmail.com> wrote in message
> > news:uVYzTCPSEHA.3016@tk2msftngp13.phx.gbl...
> > > How do I get the printer to work after boot-up without going through
the
> > > command process???
> > > I've really been going through the ringer with this thing, any
> > > suggestions
> > > would help, I've removed all of the printer drivers, edited the
registry
> > > to
> > > get the entries out, I need some help! Thanks Jeff
> > >
> > >
> >
> >
>
>
Anonymous
June 3, 2004 1:55:59 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Cari, my mistake, I wasn't looking in the correct services area.... my
setting IS on automatic, but it does not start when you attempt to install a
printer.

*I followed the instructions for removing printer drivers from Bruce
Sanderson's site after I started the service the printer installed normally,
however the printer service does not run after a reboot.
One of the dependencies of the service is the RPCSS, is this causeing it not
to start?

How can I get this to start after booting? Or is there something else that
I am missing?

"Cari (MS MVP)" <Newsgroups1@coribright.com> wrote in message
news:eXIfJuSSEHA.504@TK2MSFTNGP11.phx.gbl...
> Oh dear.... I see a Repair Installation of XP in your very near future.
> Fortunately it's very rare it gets deleted, in all the years I've been
> posting here, you're only the second person I've come across who has
managed
> to lose their spooler.
> http://www.michaelstevenstech.com/XPrepairinstall.htm
> --
> Cari (MS-MVP Windows Client - Printing, Imaging & Hardware)
> www.coribright.com
>
>
>
> "Jeff F" <bdfd1220@hotmail.com> wrote in message
> news:uCUBWLQSEHA.3056@TK2MSFTNGP11.phx.gbl...
> > How do I install the Print Spooler in Services? There is not one in
the
> > services window.....
> > "Cari (MS-MVP)" <Newsgroups1@coribright.com> wrote in message
> > news:ur8EDRPSEHA.2936@TK2MSFTNGP10.phx.gbl...
> > > Control Panel, Administrative Tools, Services.... Ensure the Print
> Spooler
> > > is set to Automatic.
> > > --
> > > Cari
> > > MS-MVP Windows Technologies - Printing/Imaging/Hardware
> > > www.coribright.com
> > >
> > > "Jeff F" <bdfd1220@hotmail.com> wrote in message
> > > news:uVYzTCPSEHA.3016@tk2msftngp13.phx.gbl...
> > > > How do I get the printer to work after boot-up without going through
> the
> > > > command process???
> > > > I've really been going through the ringer with this thing, any
> > > > suggestions
> > > > would help, I've removed all of the printer drivers, edited the
> registry
> > > > to
> > > > get the entries out, I need some help! Thanks Jeff
> > > >
> > > >
> > >
> > >
> >
> >
>
>
Anonymous
June 3, 2004 3:14:39 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Once more into the Services screen..... is the Remote Procedure Call (RPC)
also started - it should also be set to automatic. (This is the first
entry, not the one for Locator)
--
Cari
MS-MVP Windows Technologies - Printing/Imaging/Hardware
www.coribright.com

"Jeff F" <bdfd1220U@hotmail.com> wrote in message
news:ulw1roXSEHA.1472@TK2MSFTNGP09.phx.gbl...
> Cari, my mistake, I wasn't looking in the correct services area.... my
> setting IS on automatic, but it does not start when you attempt to install
> a
> printer.
>
> *I followed the instructions for removing printer drivers from Bruce
> Sanderson's site after I started the service the printer installed
> normally,
> however the printer service does not run after a reboot.
> One of the dependencies of the service is the RPCSS, is this causeing it
> not
> to start?
>
> How can I get this to start after booting? Or is there something else
> that
> I am missing?
>
> "Cari (MS MVP)" <Newsgroups1@coribright.com> wrote in message
> news:eXIfJuSSEHA.504@TK2MSFTNGP11.phx.gbl...
>> Oh dear.... I see a Repair Installation of XP in your very near future.
>> Fortunately it's very rare it gets deleted, in all the years I've been
>> posting here, you're only the second person I've come across who has
> managed
>> to lose their spooler.
>> http://www.michaelstevenstech.com/XPrepairinstall.htm
>> --
>> Cari (MS-MVP Windows Client - Printing, Imaging & Hardware)
>> www.coribright.com
>>
>>
>>
>> "Jeff F" <bdfd1220@hotmail.com> wrote in message
>> news:uCUBWLQSEHA.3056@TK2MSFTNGP11.phx.gbl...
>> > How do I install the Print Spooler in Services? There is not one in
> the
>> > services window.....
>> > "Cari (MS-MVP)" <Newsgroups1@coribright.com> wrote in message
>> > news:ur8EDRPSEHA.2936@TK2MSFTNGP10.phx.gbl...
>> > > Control Panel, Administrative Tools, Services.... Ensure the Print
>> Spooler
>> > > is set to Automatic.
>> > > --
>> > > Cari
>> > > MS-MVP Windows Technologies - Printing/Imaging/Hardware
>> > > www.coribright.com
>> > >
>> > > "Jeff F" <bdfd1220@hotmail.com> wrote in message
>> > > news:uVYzTCPSEHA.3016@tk2msftngp13.phx.gbl...
>> > > > How do I get the printer to work after boot-up without going
>> > > > through
>> the
>> > > > command process???
>> > > > I've really been going through the ringer with this thing, any
>> > > > suggestions
>> > > > would help, I've removed all of the printer drivers, edited the
>> registry
>> > > > to
>> > > > get the entries out, I need some help! Thanks Jeff
>> > > >
>> > > >
>> > >
>> > >
>> >
>> >
>>
>>
>
>
Anonymous
June 5, 2004 10:41:02 AM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

I having exactly the same problem with a Lexmark Z53 printer. Everytime I try and install the drivers it tells me that the required section was not found in the INF. So I have deleted all the drivers and entries for the printer in the registry, and now it's telling me that the print spooler is not started.

It is set to auto under services, but I cannot start it and nor can the driver installation program. I get the same message as Jeff, that in cannot start because of a dependency (RPC is the only one) is missing (it isn't, and is set to auto and is running) or has been marked for deletion:

Error 1075: The dependency service does not exist or has been marked for deletion.
Anonymous
June 5, 2004 12:55:01 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Steps 14 thru 16 at
http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
--
Cari (MS-MVP Windows Client - Printing, Imaging & Hardware)
www.coribright.com

"Karcsi" <anonymous@discussions.microsoft.com> wrote in message
news:CFDDF1BC-7044-4FFB-8C2B-7719DE795BFA@microsoft.com...
> I having exactly the same problem with a Lexmark Z53 printer. Everytime I
try and install the drivers it tells me that the required section was not
found in the INF. So I have deleted all the drivers and entries for the
printer in the registry, and now it's telling me that the print spooler is
not started.
>
> It is set to auto under services, but I cannot start it and nor can the
driver installation program. I get the same message as Jeff, that in cannot
start because of a dependency (RPC is the only one) is missing (it isn't,
and is set to auto and is running) or has been marked for deletion:
>
> Error 1075: The dependency service does not exist or has been marked for
deletion.
>
Anonymous
June 8, 2004 4:15:46 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Cari, I have checked the RPCS setting and the Print Spooler setting, they
are both set to "automatic". Any way that therecould be a dependency that
has changed causing this? Again, to reiterate, the printer service runs fine
after I start the service manually. I really do not want to do a repair
install.......
"Cari (MS MVP)" <Newsgroups1@coribright.com> wrote in message
news:%23Hqg5VxSEHA.2408@tk2msftngp13.phx.gbl...
> Steps 14 thru 16 at
> http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
> --
> Cari (MS-MVP Windows Client - Printing, Imaging & Hardware)
> www.coribright.com
>
> "Karcsi" <anonymous@discussions.microsoft.com> wrote in message
> news:CFDDF1BC-7044-4FFB-8C2B-7719DE795BFA@microsoft.com...
> > I having exactly the same problem with a Lexmark Z53 printer. Everytime
I
> try and install the drivers it tells me that the required section was not
> found in the INF. So I have deleted all the drivers and entries for the
> printer in the registry, and now it's telling me that the print spooler is
> not started.
> >
> > It is set to auto under services, but I cannot start it and nor can the
> driver installation program. I get the same message as Jeff, that in
cannot
> start because of a dependency (RPC is the only one) is missing (it isn't,
> and is set to auto and is running) or has been marked for deletion:
> >
> > Error 1075: The dependency service does not exist or has been marked for
> deletion.
> >
>
>
Anonymous
June 8, 2004 4:15:47 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Follow Bruce Sanderson's instructions..... you do not have to do a Repair
Installation, just reinstall the printer correctly.
--
Cari
MS-MVP Windows Technologies - Printing/Imaging/Hardware
www.coribright.com

"Jeff F" <bdfd1220U@hotmail.com> wrote in message
news:eM3uztXTEHA.3596@tk2msftngp13.phx.gbl...
> Cari, I have checked the RPCS setting and the Print Spooler setting, they
> are both set to "automatic". Any way that therecould be a dependency
> that
> has changed causing this? Again, to reiterate, the printer service runs
> fine
> after I start the service manually. I really do not want to do a repair
> install.......
> "Cari (MS MVP)" <Newsgroups1@coribright.com> wrote in message
> news:%23Hqg5VxSEHA.2408@tk2msftngp13.phx.gbl...
>> Steps 14 thru 16 at
>> http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
>> --
>> Cari (MS-MVP Windows Client - Printing, Imaging & Hardware)
>> www.coribright.com
>>
>> "Karcsi" <anonymous@discussions.microsoft.com> wrote in message
>> news:CFDDF1BC-7044-4FFB-8C2B-7719DE795BFA@microsoft.com...
>> > I having exactly the same problem with a Lexmark Z53 printer. Everytime
> I
>> try and install the drivers it tells me that the required section was not
>> found in the INF. So I have deleted all the drivers and entries for the
>> printer in the registry, and now it's telling me that the print spooler
>> is
>> not started.
>> >
>> > It is set to auto under services, but I cannot start it and nor can the
>> driver installation program. I get the same message as Jeff, that in
> cannot
>> start because of a dependency (RPC is the only one) is missing (it isn't,
>> and is set to auto and is running) or has been marked for deletion:
>> >
>> > Error 1075: The dependency service does not exist or has been marked
>> > for
>> deletion.
>> >
>>
>>
>
>
Anonymous
June 8, 2004 8:26:25 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Well I've done this three times now and it still does the same thing. what
else could it be?
"Cari (MS-MVP)" <Newsgroups1@coribright.com> wrote in message
news:o 7Id73XTEHA.1472@TK2MSFTNGP12.phx.gbl...
> Follow Bruce Sanderson's instructions..... you do not have to do a Repair
> Installation, just reinstall the printer correctly.
> --
> Cari
> MS-MVP Windows Technologies - Printing/Imaging/Hardware
> www.coribright.com
>
> "Jeff F" <bdfd1220U@hotmail.com> wrote in message
> news:eM3uztXTEHA.3596@tk2msftngp13.phx.gbl...
> > Cari, I have checked the RPCS setting and the Print Spooler setting,
they
> > are both set to "automatic". Any way that therecould be a dependency
> > that
> > has changed causing this? Again, to reiterate, the printer service runs
> > fine
> > after I start the service manually. I really do not want to do a
repair
> > install.......
> > "Cari (MS MVP)" <Newsgroups1@coribright.com> wrote in message
> > news:%23Hqg5VxSEHA.2408@tk2msftngp13.phx.gbl...
> >> Steps 14 thru 16 at
> >> http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
> >> --
> >> Cari (MS-MVP Windows Client - Printing, Imaging & Hardware)
> >> www.coribright.com
> >>
> >> "Karcsi" <anonymous@discussions.microsoft.com> wrote in message
> >> news:CFDDF1BC-7044-4FFB-8C2B-7719DE795BFA@microsoft.com...
> >> > I having exactly the same problem with a Lexmark Z53 printer.
Everytime
> > I
> >> try and install the drivers it tells me that the required section was
not
> >> found in the INF. So I have deleted all the drivers and entries for the
> >> printer in the registry, and now it's telling me that the print spooler
> >> is
> >> not started.
> >> >
> >> > It is set to auto under services, but I cannot start it and nor can
the
> >> driver installation program. I get the same message as Jeff, that in
> > cannot
> >> start because of a dependency (RPC is the only one) is missing (it
isn't,
> >> and is set to auto and is running) or has been marked for deletion:
> >> >
> >> > Error 1075: The dependency service does not exist or has been marked
> >> > for
> >> deletion.
> >> >
> >>
> >>
> >
> >
>
>
June 9, 2004 10:22:01 AM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Try this:

Go to the folder c:\windows\system32\spool\printers. If there are recent files, cut them to an other location. Then restart Windows XP.
I had this problem and this solved it.

Good luck

"Jeff F" wrote:

> How do I get the printer to work after boot-up without going through the
> command process???
> I've really been going through the ringer with this thing, any suggestions
> would help, I've removed all of the printer drivers, edited the registry to
> get the entries out, I need some help! Thanks Jeff
>
>
>
Anonymous
June 9, 2004 5:02:05 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Good idea Hans, But, I've done this about 3 times making sure that all files
are not hidden and all......
"Hans" <Hans@discussions.microsoft.com> wrote in message
news:C4B2CEA6-9DA3-47F2-9A4A-86126D13661F@microsoft.com...
> Try this:
>
> Go to the folder c:\windows\system32\spool\printers. If there are recent
files, cut them to an other location. Then restart Windows XP.
> I had this problem and this solved it.
>
> Good luck
>
> "Jeff F" wrote:
>
> > How do I get the printer to work after boot-up without going through the
> > command process???
> > I've really been going through the ringer with this thing, any
suggestions
> > would help, I've removed all of the printer drivers, edited the registry
to
> > get the entries out, I need some help! Thanks Jeff
> >
> >
> >
!