Sign in with
Sign up | Sign in
Your question

Game stutters or freezes for a moment when sounds occur.

Last response: in Video Games
Share
May 4, 2012 12:47:58 AM

Windows 7 Home Premium x64
Intel Core i7 2630QM @ 2.00GHz
AMD Radeon HD 6770M
6GB DDR3

Under system information and device manager these are the two listed...

IDT High Definition Audio CODEC
Intel(R) Display Audio



For example, in Minecraft, Planetside 1, and Blacklight. When a gun is shot, door opening, player falling, etc the game may stutter quickly or freeze for a second or three. I disabled both sound devices in device manager and when a sound would happen the game runs smoothly. Though there are still what seems like random quick stutters every 10 to 20 seconds or so. As far as my knowledge goes all of the drivers are up to date but it is possible that something may not be.
May 4, 2012 2:13:46 AM

try this... go into ctrl pannel/sound and double click on the active device. you should get a box with a tab saying enhancements. click that and select the disable all enhancements. ok the quit it. this will reduce the amount of cpu usage that the audio uses by a big margin... normally it will use up to 15% when disabled that drops down to 1%
m
0
l
May 4, 2012 1:44:35 PM

HEXiT said:
try this... go into ctrl pannel/sound and double click on the active device. you should get a box with a tab saying enhancements. click that and select the disable all enhancements. ok the quit it. this will reduce the amount of cpu usage that the audio uses by a big margin... normally it will use up to 15% when disabled that drops down to 1%


Tried it, hasn't made a difference. The boxes were already unchecked (status=disabled by default). But i still clicked the "disable all enhancements" option. Still has made no difference.

http://imgur.com/a/YxKPG

Images from minecraft diagnostic view. Note this sound problem never occured when playing Skyrim.

Edit: This also occured during the Diablo 3 beta, the spikes/lag made the game completely unplayable. Didn't have enough time to attempt some kind of minor diagnosis because the beta ended.
m
0
l
Related resources
May 8, 2012 4:31:31 PM

And Here is a curious event... when running frap recording at 60fps, during the recording time the game runs perfectly lagless, stutterless, and absolutely smooth.
m
0
l
May 8, 2012 7:08:28 PM

then turn on vsnc... the lag is probably being cause by fps droop where your dropping from 200fps to 50 this will cause a stutter jump , but if you lock the fps at 60 with vsnc the came wont produce excessive amounts of framse so cant droop which will/should solve your problem.
also the fps droop can be cause by other players on the server having high pings.. it then causes every 1 else's ping to bounce causing fps lag.
m
0
l
May 9, 2012 12:52:52 AM

Well that definitely helped out. But it is still consistent that when there is any action, the stutter every second occurs, and if I activate fraps the stuttering stops absolutely.
m
0
l
May 14, 2012 6:55:41 PM

Windows 7 Home Premium x64
Intel Core i7 2630QM @ 2.00GHz
AMD Radeon HD 6770M
6GB DDR3

Under device manager this is listed for sound...

High Definition Audio Device

For example, in Minecraft SP, Planetside 1 MP, and Portal SP. When a gun is shot, door opening, player falling and hitting ground, NPC talking, etc the game may stutter quickly or freeze for a second or three. I disabled both sound devices in device manager and when a sound would happen the game runs smoothly. Though there are still
what seems like random quick stutters every 10 to 20 seconds or so. As far as my knowledge goes all of the drivers are up to date but it is possible that something may not be.

http://imgur.com/a/YxKPG

Images from minecraft diagnostic view. These types of events also occur in planetside and portal. This also occured during the Diablo 3 beta, the spikes/lag made the game completely unplayable. Didn't have enough time to attempt some kind of minor diagnosis because the beta ended.

Exported Data from System Information

http://pastebin.com/rwv5g0C
http://pastebin.com/cgG8Jk58


Tried:
Disabling All Sound Enhancements in Control Panel-->Sound
Disabling allowing exclusive control of device in Control Panel-->Sound
Tried enabling verticle refresh
Tried reformatting
m
0
l
!