Sign in with
Sign up | Sign in
Your question

Skyrim Does Not Detect Dedicated GPU

Last response: in Video Games
Share
May 10, 2012 1:33:01 AM

On the Skyrim launcher, under the 'graphics adapter' section of the options menu, only my integrated graphics show up (NVIDIA Geforce 8800 GS). I have a GT 555m on my computer with the most recent drivers, and it does not appear as a usable alternative in the drop down menu. The game runs at about 5 FPS on low settings with native res, and after investigating issue with MSI afterburner, the GPU usage will remain at 0% when Skyrim is running. As a control, I ran BF3, and the usage jumped up to around 90%-100%, showing that the GPU actually works.
After looking around for a fix, the two solutions I've found (and they haven't helped, in my case):
1. In the NVIDIA control panel, set TESV.exe to use the GPU, as opposed to what the program specifies - resulted in no change.
2. Right click the executable file, and select 'run with graphics processor -> High performance NVIDIA GPU'
I'm running an alienware 14x laptop.
Any and all help is greatly appreciated.
May 10, 2012 3:16:23 PM

check your BIOS and see if you can disable the integrated GPU
May 10, 2012 8:42:11 PM

Power management is set to "High Performance".
Kind of wary of disabling the integrated graphics, but if nothing else works I guess I'll be forced to try it.
No, my computer is not using Nvidia Optimus.
Related resources
May 10, 2012 11:09:23 PM

An 8800 GS is not even a laptop card something is weird. What are the full specs?
May 10, 2012 11:14:12 PM

Alienware 14x - model
Windows 7 64 bit - OS
750 GB HDD
8 GB RAM
Intel HD 3000 Graphics - onboard
NVIDIA 555m GPU - dedicated
Intel core i7 Processor
May 11, 2012 9:57:35 AM

I tried to post that link yesterday but it said forum not available try those settings and see if it works.
May 11, 2012 2:11:38 PM

hmm, I'm very confused by why your computer thinks that you have 8800 GS then.

do you have the latest BIOS for your motherboard and latest nvidia drivers? and also check the intel IGP drivers as well
May 17, 2012 9:49:22 PM

BIOS is up to date, I have Alienware AO8, from December 2011.
!