Batman Arkham Asylum FPS Drops

Hey

My specs are

Powercolor Radeon HD 6850
AMD Athlon x2 250 Processor
Coolermaster eXtreme Power 500W PSU
4GB RAM DDR3
500 GB Hard Drive

Ive started up Batman Arkham Asylum on my computer and the game plays at a constant 60 fps and then around every 30 secs it will suddenly drop to 30-40 and it will stutter like mad and then go back to normal a few seconds later. I should be able to run this game maxed out no problem.

I have:

Uninstalled my drivers used driver sweeper and reinstalled them nothing changed.

I have tryed playing it on the lowest settings possible and i still get the same problem.

Games like Mass Effect 3 and Darkness 2 or Dirt 3 run perfectly on max settings so i really cant see what the problem is.

Thanks
11 answers Last reply
More about batman arkham asylum drops
  1. monitor you system resorces as you play. hooking up another monitor would be a good idea so that you can see what happens when it stutters. most of the time something like this is the hard drive. maybe try a reinstall.
  2. Images of resource montiro:



    http://postimage.org/image/mw0c2dbnb/165455f9/

    Changes sometimes
  3. Ignore that last message i checked my HDD with Hd Tune pro and Seagate tools and both game back green my hard drive is fine
  4. Do you have AA Cranked up? I think I lowered some settings with my gtx 580 and i7 3820. The Scarecrow scenes are especially taxing. Since then I've upgraded to 680s in SLI (compusa nice enough to let me return 580 as 680 came out a few weeks later). I haven't played Arkham Asylum on my current rig but I know the gtx 295 was the card to buy, which I did, after AA came out and I couldn't max the game. Let me put it to you this way; with 2 gtx 680s in sli and a 3820, Arkham City benchmarks like crap. The point I'm getting to, Mass Effect 3 really isn't a benchmark game, I know nothing about Darkness 1 or 2, and Dirt 3 isn't extremely taxxing either. Arkham Asylum SHOULDN'T be taxing and niether should Arkham City but both were console ports and very poorly ported at that. You have to figure, Arkham Asylum came out in Q3 2009 and the GTX 580 came out last year... A flagship card released 2 years after the game's release still couldn't completely max the game.
  5. jfizzle4321 said:
    Do you have AA Cranked up? I think I lowered some settings with my gtx 580 and i7 3820. The Scarecrow scenes are especially taxing. Since then I've upgraded to 680s in SLI (compusa nice enough to let me return 580 as 680 came out a few weeks later). I haven't played Arkham Asylum on my current rig but I know the gtx 295 was the card to buy, which I did, after AA came out and I couldn't max the game. Let me put it to you this way; with 2 gtx 680s in sli and a 3820, Arkham City benchmarks like crap. The point I'm getting to, Mass Effect 3 really isn't a benchmark game, I know nothing about Darkness 1 or 2, and Dirt 3 isn't extremely taxxing either. Arkham Asylum SHOULDN'T be taxing and niether should Arkham City but both were console ports and very poorly ported at that. You have to figure, Arkham Asylum came out in Q3 2009 and the GTX 580 came out last year... A flagship card released 2 years after the game's release still couldn't completely max the game.


    In the long run i think it could be my cpu bottlenecking my system im upgrading my cpu in a week or two to a pentium II x4 so ill have to see if that fixes it.
  6. zecele said:
    In the long run i think it could be my cpu bottlenecking my system im upgrading my cpu in a week or two to a pentium II x4 so ill have to see if that fixes it.


    That's possible.
  7. Go into C:\Users\...\Documents\WB Games\\Batman Arkham City\BmGame\config then delete bmengine, bmgame and userengin. Start the game with launcher and reconfigure your settings. I have everything maxed except I am using 4x multi at 1920/1080.


    try this it worked for me...
  8. HEXiT said:
    Go into C:\Users\...\Documents\WB Games\\Batman Arkham City\BmGame\config then delete bmengine, bmgame and userengin. Start the game with launcher and reconfigure your settings. I have everything maxed except I am using 4x multi at 1920/1080.


    try this it worked for me...


    Its arham asylum not arkham city

    Arkham city runs fine for me already
  9. HEXiT said:
    Go into C:\Users\...\Documents\WB Games\\Batman Arkham City\BmGame\config then delete bmengine, bmgame and userengin. Start the game with launcher and reconfigure your settings. I have everything maxed except I am using 4x multi at 1920/1080.


    try this it worked for me...


    Interesting. I haven't played the game in a long time but I just did that. Haven't started the game yet but once I'm interested in beating it hopefully it improves. I got Arkham Asylum in 2009 and just beat it a month ago lol.
  10. if you have an ati gfx card make sure physx is off as it cripples gameplay.
  11. HEXiT said:
    if you have an ati gfx card make sure physx is off as it cripples gameplay.


    No ATI here brother, just 2 680s in SLI. Regardless, I have never noticed the benefit of employing physx but I have noticed the detriment; hence I always turn physx off.
Ask a new question

Read More

PC gaming Video Games