My Computer is Running worse.

Hello,

To make things brief for all of us,

My computer has been running really crappy when trying to play most moddern games, but what gets me is that I just UPGRADED my pc.

I went from a 5750 AMD gfx card to 2 6850s. I also upgraded my mobo so the pci express outputs were at x16 and x8 which is enough to power the two cards. I also had to upgrade my power supply from a 500 to a 850 watt.

The problem I'm running into is that before, I could play games like Portal 2, on max settings with 30-40 fps on my old build with just one 5750, but now when I go back to play games like portal 2, my fps is 20 on max settings. I'm simply baffled at this and I know something has to be wrong.

Note* This happens in more games than portal two.


The only thing that I can think of is my CPU could of messed something up. I went from an Anthlon II quad to the new FX series quad core, http://www.newegg.com/Product/Product.aspx?Item=N82E16819103996 this link is to the one I purchased.

If you have any suggestions on how I may fix my computer that would be great, its really annoying that I spent all this money on upgrading my PC just to have it run even worse than before.

Thanks!
6 answers Last reply
More about computer running worse
  1. Did you change your mobo with your new processor? If no please state the mobo you are using.
  2. collinator said:
    Hello,

    To make things brief for all of us,

    My computer has been running really crappy when trying to play most moddern games, but what gets me is that I just UPGRADED my pc.

    I went from a 5750 AMD gfx card to 2 6850s. I also upgraded my mobo so the pci express outputs were at x16 and x8 which is enough to power the two cards. I also had to upgrade my power supply from a 500 to a 850 watt.

    The problem I'm running into is that before, I could play games like Portal 2, on max settings with 30-40 fps on my old build with just one 5750, but now when I go back to play games like portal 2, my fps is 20 on max settings. I'm simply baffled at this and I know something has to be wrong.

    Note* This happens in more games than portal two.


    The only thing that I can think of is my CPU could of messed something up. I went from an Anthlon II quad to the new FX series quad core, http://www.newegg.com/Product/Product.aspx?Item=N82E16819103996 this link is to the one I purchased.

    If you have any suggestions on how I may fix my computer that would be great, its really annoying that I spent all this money on upgrading my PC just to have it run even worse than before.

    Thanks!



    May I suggest you install and run the PSI software from http://secunia.com/vulnerability_scanning/personal/
    to ensure all your software is up todate in case something is mising, causing your recurring problem.

    Cheers
  3. Tibbs01 said:
    Did you change your mobo with your new processor? If no please state the mobo you are using.



    http://www.newegg.com/Product/Product.aspx?Item=N82E16813128510

    This is the mobo I bought.

    I had my old CPU in it for a few months before switching to my new CPU.
  4. temperatures? have you confirmed that CF is actually working properly? Have you tried running with only 1 card?

    What resolution and in-game settings are you running at? Anything overclocked?
  5. Have you made sure all software was updated and any old software/drivers not needed were removed? Did you do a clean install of the OS for the new hardware?
  6. best get a 960t for the crossfire setup you have. the fx wont cut it as its a poor performer even compared to older athlons and phenoms.
Ask a new question

Read More

PC gaming Computers Games Video Games Product