Sign in with
Sign up | Sign in
Your question

Dead Space 1 using an Intel HD 4000 (stuck on 60 FPS)

Last response: in Video Games
Share
May 26, 2012 12:43:34 AM

I just recently finished my first real gaming PC, but I'm holding out on getting a discrete graphics card. I'd like to get a GTX 670 and I figure it's best to wait for them to work out all the bugs first. I got myself an i5-3570K, which has Intel HD 4000 graphics. I know it's not good for super high end gaming, but I figured it would do me for a while. I've actually run Starcraft 2 on it and it looks quite nice (much better than on my last computer).

But I installed Dead Space (the first one, never played it and I've been wanting to try it for ages) last week, and so far as I can figure I can't change the frame rate. Normally, from what I know about games, when you set the graphics too high for the hardware to handle it dials down the FPS. On SC2 it would drop as low as 20 FPS in some battles, and I didn't notice all that much of a difference... to be honest. To me it still looks fine. With DS1 though it can't go down. I seem to be able to handle even the high graphics, but the mouse's movements are very slow. Sluggish would be the best word. I dialed it down to low, but the mouse still feels a little laggy. I'm sure it would help if I dialed down the FPS to at least 30, but I can't figure out how.

I know it can be done, I've seen people post gaming videos of DS1, supposedly at 30 FPS, on YouTube. So, am I missing something very obvious here? On a related note, does anyone know how to safely overclock the graphics portion of an Ivy Bridge chip?
May 26, 2012 2:47:14 AM

Dead Space has some problems on PC. The mouse controls are indeed quite slow, turn your sensitivity up to maximum, and turn off Vsync. Even then mouse control is quite sluggish, the mouse support is quite bad, so you may be better off trying to play with a controller or gamepad, if you have one. The developers never bothered fixing the mouse issues with this game, though they did greatly improve mouse control in Dead Space 2.

Dead Space's Vsync option is also broken. In addition to making the mouse problems worse, it caps the game at 30FPS. If you want to have Vsync in Dead Space I suggest you use D3DOverrider, it's part of the Rivatuner package, it will force Vsync to the refresh rate of your display.
m
0
l
May 26, 2012 1:25:47 PM

Hmmm... so do you know of a controller that is known to be particularly compatible with Steam? Or just one that is known not to bug out at the drop of a hat on the PC?

I figure the simplest solution will be to circumnavigate the mouse entirely, but I've never tried to play steam games with a controller.
m
0
l
Related resources
May 26, 2012 2:00:31 PM

You've kind of got the wrong idea, you don't 'dial down' fps, fps happens to be whatever fps happens to be at as a result of all of the other settings.
m
0
l
May 26, 2012 2:34:26 PM

Well, the FPS seem to stay fixed at 60 in the visual options.

I just imagined that would be the cause, since I'm able to play SC2 (which was made in 2010) almost at highest graphics. Yet I'm having troubles even on medium with a game from 2008. Is there a way to check the FPS in-game, at the moment while playing?
m
0
l
May 26, 2012 2:37:19 PM

in the options, you may be declaring what you want the FPS to be.

First Person Shooters, tend to be more graphically taxing than strategic games like SCII.

Using FRAPS you can get an indicator in the corner of the screen as to the FPS you are seeing
m
0
l
!