Sign in with
Sign up | Sign in
Your question

Cutscenes in games slow down

Tags:
  • PC gaming
  • Video
  • Games
  • Diablo
  • Video Games
Last response: in Video Games
Share
May 29, 2012 12:25:24 PM

Hello,

I have noticed this problem two times now. First time was when I watched "the first sign" cutscene in Diablo 3 (the intro video). I noticed that in some places, it felt like the framerate of the video itself was lower than it should have been. It didn't skip or stutter, it's like from the usual 24FPS that videos run, the video dropped to like 15FPS. Another game where I noticed this, was Deus Ex: Human Revolution. And it only happened during cinematics, not in in-game scenes.

My CPU was around 15-20% when watching the video. I also tried to watch the same video of Diablo 3 in Youtube, in 1080p but it seemed to run smoothly.

My specs:

Windows 7 Pro 64bit
Intel i3 2100 3.1Ghz
4gb of ram
MSI HD6850 1GB

More about : cutscenes games slow

May 29, 2012 12:42:30 PM

flash player uses GPU acceleration (youtube) might these games uses the cpu cause it uses different codec imo, try to low the resolution in game and try out the cinematics again


EDIT: i just tested D3 on my lap which it got amd dual core (3.0Ghz) and ati 5450, tested a random cinematic with maxed resolution and no stuttering at all, i am on 12.3 driver.
May 29, 2012 1:15:59 PM

Ok, I will try that. do these cinematics still use an external codec, Divx or something? And my CPU was only at 15-20% during the cinematic in Diablo 3.

Also, can you check the first cinematic "the first sign", the slow down is most noticable when Leah starts approaching her uncle.
Related resources
May 29, 2012 1:44:05 PM

Quote:
do these cinematics still use an external codec, Divx or something?

i think blizzard using their own codec in FMV formats, which i dont really know.

Quote:
Also, can you check the first cinematic "the first sign", the slow down is most noticable when Leah starts approaching her uncle.


i already chked it with 1366 x 768 resolution, no stutters no lags no slow downs at all.
May 29, 2012 2:10:32 PM

That is so weird, I have never experienced this problem before. I doubt that my eyes are playing tricks on me lol.
May 29, 2012 2:21:31 PM

lol
am telling you that might be a cpu problem, try to OC it :p  or drivers related
May 29, 2012 3:25:28 PM

I don't think OC-ing my CPU would fix anything if the CPU usage was only 10-20%.

EDIT: My max monitor resolution is 1366x768. I turned the resolution down to 1024x768 (letterbox mode) and it seemed that the slow downs were gone. Quite a weird probem. I'm going to update my drivers from 12.3 to 12.4 and see if that helps.
May 29, 2012 3:49:58 PM

its just an option, these 10-20% takes from the max clocks and the 2cores, i remember having these stutters with Dirt 1 opening cutscene, the problem was my dual core cpu.

and also might be a drivers problem, do you have the latest updates installed?
May 29, 2012 4:16:07 PM

Well, my GPU driver is 12.3, newest is 12.4. There's no drivers for my processor, I have not upgraded my BIOS because from the release notes, they do not seem to fix anything related to this problem.

Also, I just watched the video on my VLC player, in 1080p. I also made sure that the video was only being processed by my CPU. It ran flawlessly.

UPDATE! OK, I found out how to get rid of the stutters! Thing is, I run the game in fullscreen mode with Vsync ON.

One option to get rid of the stuttering is to disable Vsync, which will make the video render smoothly but with some screen tearing.

The other option is to keep Vsync ON but run the game in borderless windowed mode. No screen tearing and smooth playback.

So I'm guessing this is an issue with my GPU or GPU driver. I'm just wondering what could cause this issue...
May 29, 2012 4:36:57 PM

Thank you for the link, I've seen it before but I don't really have any of these 1-2 sec delays in-game. The game itself runs pretty well on my PC. I'm going to try to update my drivers and see if I can run the video smoothly with fullscreen on and vsync on.
May 29, 2012 4:51:18 PM

Quote:
UPDATE! OK, I found out how to get rid of the stutters! Thing is, I run the game in fullscreen mode with Vsync ON.

One option to get rid of the stuttering is to disable Vsync, which will make the video render smoothly but with some screen tearing.

The other option is to keep Vsync ON but run the game in borderless windowed mode. No screen tearing and smooth playback.

So I'm guessing this is an issue with my GPU or GPU driver. I'm just wondering what could cause this issue...


this is weird! i just tested with Vsync on and max resolution and no stutter at all not even one single micro stutter :S
May 29, 2012 5:11:47 PM

Don't know what's the issue is. I e-mailed AMD Support for help, maybe they can share some light on this.

EDIT: Heh, I noticed the micro-stuttering in game too. It goes away if I run the game in windowed mode. Looks like a lot of AMD users have this issue with Vsync turned on: http://eu.battle.net/d3/en/forum/topic/4078548184?page=...
!