Sign in with
Sign up | Sign in
Your question
Closed

Skyrim Low FPS Issue on high end pc

Last response: in Video Games
Share
June 1, 2012 11:57:59 PM

Hey guys I am having some issues with frame rate in Skyrim. I believe my system should be able to run this game with no problems.

GPU: TWO XFX HD 6970s CrossFireX
CPU: Intel Core i7 3770 Ivy
MoBo: ASUS P8Z77-V
RAM: 16GB 1600MHz
PSU: 1100w
OS: Windows 7 64-bit

I am getting avg fps of high 20s to high 30s low 40s on ultra with fxaa enabled. HD textures from Beth installed. No other really graphics intensive mods.

Catalyst Drivers are updated completely to 12.4. When I first installed this game it ran a consistent high 50-60 fps im not sure what is going wrong.


Side Note: I run Battlefield 3 on Ultra except msaa at a consistent 120+ FPS which is significantly more intensive game than Skyrim. And yes I realize Skyrims max is 60 but nonetheless I think thats what it should be running at, not 30.
June 2, 2012 2:29:33 AM

I don't know much about Skyrim but if you have to use Steam to play the game you might try checking the verify integrity of game cache. If you don't know how to do that I or someone on here will show you. Good luck.

Best solution

June 2, 2012 3:51:17 AM
Share

change the drivers to 12.3 as they seem to be the best current 1s. bf3 crumples on 12.4 for instance...
as for skyrim it doesnt like crossfire at all. it works but doesnt scale very well at all and in some configs will scale negatively... which is what looks like is happening to you...
check the skyrim nexus for there community mod as that does fix some issues that the devs havent touched. (if its still available),
verifying the game integity, you just click on library, right click on the game, select properties then local content. then verify
Related resources
June 3, 2012 4:59:58 AM

Thank you for the input, I tried all of the above and various other things to no avail (including disable v-sync, installing ccaps, and reinstalling current drivers).

What finally ended up working was a combination of the following;
-In CCC I set the CrossFire mode (i think thats what its called) to Optimize 1x1, not exactly sure what it is but it always seems to increase fps.
-And I believe on accident I set the cell buffer in Skyrim.ini to 11 when even 7 or 9 is ridiculously unstable. Reset it back to the default 5

Now works great! Ive been playing for two hours and fps has not dropped below 59 once and gpu load on my second hd6970 hasnt gone over 55%!
June 5, 2012 12:42:05 AM

That is good new to hear. Pat your self on the back for a job well done. Hat's off to you for finding your own fix. Good luck to you.
June 5, 2012 4:22:53 AM

ITS ALWAYS NICE when some 1 sorts there own issues out... btw 12.3 isnt that good for skyrim in crossfire... i made a mistake it should have read 12.2 beta...
but nice to see you managed anyway...
June 16, 2012 6:00:50 AM

Best answer selected by iyzik.
!