Sign in with
Sign up | Sign in
Your question

Another GTA 4 fps issue I've looked everywhere. Help if you have time.

Last response: in Video Games
Share
June 4, 2012 7:45:54 AM

Now this might seem like I am knit picking here but I am benchmarking with the built in benchmark with everything maxed out on 1080 65 fps. BUT in game fraps benchmark over 5 minutes nets me 45 fps 19fps min-58fps max. When I lower all settings to bare minimum EXCEPT resolution I only see an increase of 3-6 frames. I feel something is bottlenecking somewhere but idk what it would be. PC Specs Below:

i5-2500k small OC 3.5ghz
Vengeance 1600mhz 8gb
Asrock Extreme3 Gen3
GTX 670 FTW +50core/+500Mem

my cpu doesn't go past 60%.

I know that 45 fps is pretty decent for this game on pc and I know its a bad port BUT with my specs I should be able to run 60+. I get better FPS on ultra skyrim than this game =[
June 4, 2012 8:05:21 AM

It's because it averages your benchmark. Maybe, it has something to do with the game and running this particular benchmark. It also uses a little bit of CPU. The fraps website also mentions a little bit of overhead if you display your FPS during benchmarking, but it's turned off to provide accurate results. I wouldn't stress over it. If your game is playing smoothly then it's okay. Otherwise, if you see choppiness then a problem. Your specs are strong.
m
0
l
June 4, 2012 8:10:26 AM

Ya my Cpu and GPU never go above 60c even when fraps is on. Its just irritating me that I have this rig that can't max 60+ fps on a 4 yr old game.
m
0
l
Related resources
June 4, 2012 8:12:44 AM

Well, maybe the game wasn't optimized well for the PC.
m
0
l
June 4, 2012 9:33:30 AM

your rite you should get more than that... if you have em installed remove the games profile from the nvidia pannel. make sure its running at default settings.
patch the game to 1.4 minimum. you should then be able to get max settings on all apart from draw distance (this is more dependent on the amount of ram you have than the gpu type) reduce the draw distance to 30 or less if you have a 1 gig model 50-60 for 1.5 gigs and max it out if you have a 2gig model
turn off blur and enable aa as sometimes the 2 conflict causing 1 to stop working but hammering fps in the process.
if you still have issues than you may want to ask over at 1 of the gta 4 mod sites... they may have a community patch that gives newer hardware better compatibility.
m
0
l
June 4, 2012 2:35:26 PM

HEXiT said:
your rite you should get more than that... if you have em installed remove the games profile from the nvidia pannel. make sure its running at default settings.
patch the game to 1.4 minimum. you should then be able to get max settings on all apart from draw distance (this is more dependent on the amount of ram you have than the gpu type) reduce the draw distance to 30 or less if you have a 1 gig model 50-60 for 1.5 gigs and max it out if you have a 2gig model
turn off blur and enable aa as sometimes the 2 conflict causing 1 to stop working but hammering fps in the process.
if you still have issues than you may want to ask over at 1 of the gta 4 mod sites... they may have a community patch that gives newer hardware better compatibility.


Alright thank you. Will try this.
m
0
l
!