Sign in with
Sign up | Sign in
Your question
Solved

Assassin's Creed freezing during startup?

Last response: in Video Games
Share
June 8, 2012 9:46:07 PM

I'm sorry if this isn't the right place to ask this, but I guess Ubisoft customer support won't be of much help with this.

I just got my Alienware m14x r2 laptop and I'm trying to install Assassin's Creed (the first one) from Amazon's game downloads. I've downloaded the game and tried installing it, but when I go to play, it freezes during the opening (right after it reaches 100%, with the bluish gray haze with molecules flying about). I've tried it multiple times and it freezes every time but not always in the same part of the animation. I think my video and motherboard drivers are fully up-to-date. I'm pretty sure it meets the minimum requirements; I think there's actually a youtube video of a guy showing Assassin's Creed running on full graphics on his m14x. Still, since laptops aren't supported, Ubisoft only suggested to play it on a different machine.

I am curious if I made a mistake during the install. The Amazon downloader appeared to have downloaded the initial package to my Desktop. When I went to install the game, the default location was C:\Program Files (x86)\Ubisoft\Assassin's Creed. This is the first time I haven't done a CD install of a game, so I am not sure if this is a problem (I'm sorry if this is a really stupid question). I have gone into the Ubisoft Assassin's Creed folder and tried each of the .exe files there, but either the game freezes or crashes. Any thoughts, or am I just out of luck on this?
June 9, 2012 2:34:06 AM

I'd ask Ubisoft tech support about the issue. I am pretty sure they would help you regarding this problem especially on an Alienware laptop.

Best solution

September 1, 2012 1:05:56 AM
Share

I'd exactly this problem. (sorry if my english not correct, I'm French ^^)
The solution is very simple, but I've any explication ...
You have too disconnect internet ...
!