Sign in with
Sign up | Sign in
Your question
Solved

Problem Ejecting USB Mass Storage Device

Last response: in Windows 7
Share
October 17, 2010 3:13:11 AM

So basically I need to unplug my external harddrive but when I choose the "safely remove button" I get this message "Problem Ejecting USB Mass Storage Device" Windows can't stop your 'generic volume'.

Here is what I did so far and I still cant get it to work, need help!!

The help on microsoft told me to use "unlocker (v1.8) to locate the process and kill it. It found the process searchindexer.exe and I "unlocked it". When I safely removed again I got the same error message above. I found the process, disabled and stopped it, went back to unlocker which told me no locking handle was found. I then tried a third time and still, I get the same message above. What do you think I should do next? could it be a virus?
a b G Storage
a b $ Windows 7
October 18, 2010 2:19:06 AM

If you have windows explorer open to the device, or if another program is using it, you cannot safely eject it. Close windows explorer, and any other program that is using it, then choose safely eject.
m
0
l

Best solution

a b $ Windows 7
October 18, 2010 8:14:56 PM

Hello xco;

It might be Windows Drive indexing that's using the external drive.


You can try turning it off in it's Drive Properties. It will show down any searches you perform on that disk though.

Or you can always disconnect it safely after you've shut down the system and all system processes have stopped.
Share
Related resources
October 20, 2010 1:17:25 AM

thanks for the replies

that seems to have been the problem as every time I ended the searchindexer.exe task it would run itself again, much thanks!
m
0
l
October 20, 2010 1:17:47 AM

Best answer selected by xco.
m
0
l
May 23, 2013 11:40:02 AM

1. go to start, control panel, administrative tools, services. or alternatively,
[start, programs, administrative tools, services]

then 2. find "distributed link tracking client" in list and click on "stop" service.
then 3. find "windows media player network sharing service" and click on "stop" service.

note: keep your services window open b/c you will start these services back up again once your external hard drive has been ejected.

then you should be able to use "safely eject media" to eject your usb hard drive (or at least, it has always worked for me).

then 4. restart "distributed link tracking client" service and 5. restart "windows media player network sharing service" and you should be all set.

hopefully it will work for you like it has for me. it's not the best solution, but it gets the job done.

also, you can put a shortcut to the services tool on your desktop for quick access if you need/want to.

=)

m
0
l
!