Sign in with
Sign up | Sign in
Your question

Mouse Lag in Multiple Different Games

Last response: in Video Games
Share
June 13, 2012 11:02:56 PM

Hello everybody. I am experiencing an odd mouse lag in several different games. I cant tell if this is new or not, as before now i haven't tried to play these games on my system. The specs are as follows:

Coolmax 500W 120mm Fan Modular PSU w/ PCI-E
ASUS M5A78L-M LX PLUS 760G Socket AM3+ Motherboard
AMD Phenom II X4 965 Black Edition AM3 CPU
Kingston XMP HyperX Blu 8GB DDR3 1600MHz CL9 Kit
Diamond Radeon HD 6770 1GB GDDR5 PCIe 2.1
40 gig intel ssd for windows only
250 gig 7200 rpm sata drive for programs

I know the PSU is bad, but that wouldn't cause the mouse lag.

Games that have mouse lag for sure:

Tribes Ascend
Left for Dead 2
Arma 2

Games with No Mouse Lag

Counter Strike Source
League of Legends
World of Tanks
World of Warcraft
Tera Online

What I have done to try and correct the problem:

-Reformatted my box, (win 7 pro x64)
-Tried Different graphics card drivers (catalyst 12.4 as well as 12.2, no change)
-Tried different mice, my main gaming mouse is a Naga Hex, same issue persist with my absyisus, as well as acer wired usb mouse (all mice are wired)
-Forced Vsync and Triple buffering on and off (noticeable improvement with it off, but still bad mouse lag)
-For the individual games completed any ini tweaks ect...
-fiddled with almost every setting in the catalyst control panel
-used application D3DOverrider to ensure that VSYNC and Triplebuff were in fact on or off (no change with D3DOverrider)


It is also worth noting that when i turn the games graphics down to all min i do get better response form the mouse (still noticeable lag tho)

My machine has no overclocking done on it.

It is also worth noting that my main drive is SSD with just windows, and my games are on a separate drive, would that potentially cause this issue? (just dont wanna try formatting again if i dont have to)

Any help would be really appreciated, im grasping at straws trying to figure this out.

Thanks

-Fedhell

***EDIT***
I also wanted to mention that I have gone into control panel and disabled mouse acceleration :-) no change either way, aside from mouse not accelerating.

***EDIT2***
So it looks like lowering desktop AND game resolution from 1680x1050 down to 1440x900 has resolved it completely 100% for LFD2 and Tribes, but arma 2 is just as bad. I wonder if the monitor is going bad? Will be testing a 32inch 1080p tv and see what it does. (no real other monitors around) Please any ideas are helpful, ill re back soon about the TV.
June 13, 2012 11:05:38 PM

Does your mouse need new batteries?
m
0
l
June 13, 2012 11:12:04 PM

Have you considered that the game is lagging not the mouse...

As you should have noticed your mouse only lags in heavy games..

try running games in lower settings should be fine

m
0
l
Related resources
June 13, 2012 11:16:38 PM

Quote:
Have you considered that the game is lagging not the mouse...

As you should have noticed your mouse only lags in heavy games..

try running games in lower settings should be fine


Ive tried all min settings on my games, as i said it does help but there is still a noticeable delay, i just may have found a fix, ill re back in a min.

-Fedhell
m
0
l
June 13, 2012 11:21:04 PM

fedhell said:
Quote:
Have you considered that the game is lagging not the mouse...

As you should have noticed your mouse only lags in heavy games..

try running games in lower settings should be fine


Ive tried all min settings on my games, as i said it does help but there is still a noticeable delay, i just may have found a fix, ill re back in a min.

-Fedhell


Sry not gonna change my response, this is mainly due to graphic, There is not enough graphic memory causing the game engine to render slower.(making it look like mouse lag)
would suggest to get another HD 6550 for around $60-65.

hey up-to you though GD luck with the fix ???
m
0
l
June 13, 2012 11:25:08 PM

So it looks like lowering desktop AND game resolution from 1680x1050 down to 1440x900 has resolved it completely 100% for LFD2 and Tribes, but arma 2 is just as bad. I wonder if the monitor is going bad? Will be testing a 32inch 1080p tv and see what it does. (no real other monitors around) Please any ideas are helpful, ill re back soon about the TV.
m
0
l
June 13, 2012 11:26:44 PM

Quote:
another HD 6550 for around $60-65.


im running a 6770 tho? and my board isint sli ready tho, thats alot of money, considering the games are running at 100+ fps?

-Fedhell
m
0
l
June 13, 2012 11:34:41 PM

100+ fps in game like arma are you sure..

can you also conform your ping/latency during games

can you conform for me which mouse you are using???
m
0
l
June 13, 2012 11:41:51 PM

At the moment im using my Naga Hex, may have exaturated100 fps, but my point was, with the system listed in my original post, and theses games on all min settings, fps is high enough not to be factor. If we believe FPS to be an issue i can grab fraps and find out what the actual values are.

Same behavior on the 32 inch tv as the 21 inch monitor. Higher res = more mouse lag. Nothing however affected arma 2, it mouse lagged regardless.
m
0
l
June 13, 2012 11:45:23 PM

Quote:
can you also conform your ping/latency during games


for sure, arma 2 im actually just playing single player :-) Tribes im pinging 85
m
0
l
June 13, 2012 11:55:11 PM

Thanx

Rade your first post properly this time time.. Doesn't look like much problem with graphic.. some other problem in setup but still should run without problem..

Try this for a temporary fix.
On Task manager select the Processes
than Arma 2 and set the priority to real-time..

Try the game without the "Software suite" for the Mouse if you have one installed..

Oh and you can run 6770 and 6550 on crossfire without problem..(if you wanted to know)


If this still doesn't work give me a shout at b1bekgyawali@yahoo.com. i will personally look at your PC in details but tomorrow though.
m
0
l
June 14, 2012 12:04:48 AM

Quote:
Rade your first post properly this time time.. Doesn't look like much problem with graphic.. some other problem in setup but still should run without problem..

Try this for a temporary fix.
On Task manager select the Processes
than Arma 2 and set the priority to real-time..

Try the game without the "Software suite" for the Mouse if you have one installed..

Oh and you can run 6770 and 6550 on crossfire without problem..(if you wanted to know)


If this still doesn't work give me a shout at i will personally look at your PC in details but tomorrow though.


Wow many thanks for that offer, i get off work at 6pm eastern, ill emial you round then, my skype name is Fedhellz. Regarding real time for arma 2, i believe there was an improvement. Its getting close to playable, but defiantly still mouse input lag. I also went back into Tribes and set the res back to 1680x1050 then set real time, still mouse lag. Remember, when i lowered the rez to 1440x900 it did fix tribes and lfd2. But it defiantly would be nice to play at my full rez.

Thanks for all your ideas and help today, ill keep working on it untill we talk again tommorow :-)

-Fedhell



***EDIT***
Forgot to mention i did try another mouse as well as disabling software suite, no change.
m
0
l
June 14, 2012 9:58:53 AM

clean out the usb root hub of unneeded drivers and hardware...
also reduce the render ahead limit in the games config files... if its set to 3 or higher then set it to a minimum of 2 it should actually be 2 anyway.
lastly reduce the draw distance in arma the checnces are your using all your memory for draw distance leving none for actual gfx processing causing a bottlenck thats slowing the rest of the system...
lastly make sure your mouse is running at the correct priority in the taskmanager.. 2 high and it will for stall ie it will move b4 the game knows it has and will only register on the next passing cycle giving the effect of mouse lag. and set to low and you will get mouse lag... click set priority and set it to normal.
m
0
l
July 29, 2012 1:51:54 PM

Is your problem solved?
I got the EXACT same problem :o  also with the same games!

Please, let me know :)  Im strugling with this problem for a long time already
m
0
l
July 30, 2012 12:59:07 AM

sorry not really fixed yet, still getting some input lag issues, The only thing ive been able to do to reduce the input lag is lower the graphical settings to minimum.
m
0
l
Anonymous
November 6, 2012 5:55:14 PM

I'm having the same kind of problem! I have around 100fps and the mouse lag is horrible (in singleplayer), the research i have made so far hasn't told me anything. I hope there will be a proper solution to this soon.

i'm gonna try defragging next myself.
m
0
l
November 30, 2012 2:00:54 AM

I think I found a way to fix this, as Ive been having the same problems with L4D2, TribesAscend, Monday Night Combat.

Here is what I did for Tribes. (I haven't tried it for other games - they're not installed :/ )
I disabled VSync
Go to
C:\Users\[computer name]\Documents\My Games\Tribes Ascend\TribesGame\Config
open tribes.ini (text file that will probably just show as "tribes")

find: UseVsync=True, change it to UseVsync=False

Hope that helps!
m
0
l
!