Sign in with
Sign up | Sign in
Your question

Shogun 2 graphical glitches (7850)

Last response: in Video Games
Share
June 15, 2012 7:49:55 AM

hello everyone. I am running shogun 2 on a new pc 3570K @4.0 GHZ, 8 gb ram, and a 7850 @ 1200. playing at 1600x900. these glitches occur far more often w/ lower settings.

problems are
opening cut scene is choppy until i get to the more graphically intense portion then its fine.
the first screen to load into the game take abut 60 sec
graphics in menus often overlap or disappear altogether leaving only the text.
txt is sometimes jumbled and widely spaced
icons disappear but still clickable
choppy clan cinematic while ninja cinematic are fine


I have tried uninstalling and re installing but all that happened was that it got worse at first as these problems occur more often at lower settings. all my drivers and windows are up to date. also my system is stable with all other games that i play like SCII (even with big battles) DIII and LOL. I have also tried taking my VC to normal clock but same issues persist.

edit: I also have 0 mods. first image is clan selection and second image is what the options tab looks like for me :( 

any and all help would be appreciated.

Thank you.



June 16, 2012 2:36:52 AM

If it's from Steam, has the update been downloaded? Also, verify integrity of cache for your game.

If it's not from Steam, meaning you bought it from somewhere else, have you applied the latest patch for it?

Also, you may want to try downclocking your card at stock settings and see if you have any graphical errors.
June 16, 2012 3:30:51 AM

This game is my favorit and you have to do what fantastik250 has stated. I had a lot of problems with the game last year. I could only go about ten turns or as soon as the realms devide if would freeze or crash to desktop (CTD).

Other problems I had were after about 3 turns it would freeze on certian towns or if I was trying to create an army in these towns it would only let me make two armies.

But when I click on some towns it would freeze for about 1 to 2 min. I played with everything in cluding settings. Then I got this crazy idea to set my cards at a lower level plus they did a patch at the time.

Plus I OC'd my CPU a little and now it is fixed. No more problems but this might not be the fix for you. You don't and cannot patch or un patch the game because it goes through Steam.

In case you don't know how to verify integrity of game cache I will put a not at the bottom and all you have to do is follow it. Run the verify game cache about 4 to five times to insure that all files successively down loaded.

If you OC's or card undo it. Now I have two of the worst gaming GPU's that nVidia ever put out and I can now run Shogun II on ultra settings with everything truned on and up with out any problems.

If you still have problesm after that you can go to the Shogun's web site and get on there forums and put the questions to them as well. I will link you to it. Good luck to you.

http://forums.totalwar.com/forumdisplay.php/96-Total-Wa...

Note: When in Steam, left click on Games. Then left click on view Games Library. Right click on the Game. Then left click on properties. Then left click on local files. Then left click on Verify Integrity of Game Cache.
!