Sign in with
Sign up | Sign in
Your question

GZDoom Resolution Problem

Last response: in Video Games
Share
June 15, 2012 8:55:36 AM

Hey guys ive been trying to fix this problem since i got my new TV.I know this isnt exactly the best forum to use for this problem but the GZDOOM forums are dead. I'am a Avid doom fan and still love to occasionally play some co op with my mates using the GZdoom source port which adds an OpenGL engine and many other options such as full mouse support etc. Well anyways the problem is the following. On my previous screen, a Samsung BX2450 LED Full HD i could run GZdoom at 1920x1080x32 and was shown and select able in the display menu but ever since i got my Sony Bravia CX52 32inch FULL HD tv, 1920x1080 is not shown in the list anymore, now the highest Res i can go is 1366x768. ive browsed through all the options like forced aspect ratios and 1920x1080 is not shown at all. Its obviously something wrong with gzdoom but what? All my other games i can run at 1920x1080 with no problems. Even the Steam Version of Quake 1 with the Ultimate Quake Patch installed using the Darkside Engine i can select 1920x1080 with not issues. Its only GZdoom that has this problem.

Any help or input would be appreciated
June 15, 2012 12:05:45 PM

It's hard to know exactly without knowing the model # of your Sony TV, but I'll take a shot at an explanation of your issue.
I am willing to bet that the actual resolution of your TV is 1366x768. If you look at your TV manual on the spec page you should see it. Actual resolution is simply how many pixels your flat panel has in it. The supported resolutions are scaled by your TV's internal software. Even though your TV may support 1080i, it is scaled by the TV to fit the actual resolution of 1366x768.
GZDoom for some reason is seeing your actual resolution instead of the supported resolutions.
m
0
l
June 15, 2012 12:37:50 PM

this is my TV http://www.sony-asia.com/product/kdl-32cx520 if it helps any. I run all my other games at 1920x1080 with no issues its only GZdoom which has this problem. like i said above even Quake 1 with the darkworlds patch i can run at 1920x1080 with no issues. also all my games run at 1920x1080 1080P @ 60hz
m
0
l
June 15, 2012 5:13:04 PM

soz for double post i able to resolve the problem by going into the GZdoom INI file and manually settings the resolution and it works now playing Doom at 1920x1080 @ 60hz refresh rate 1080P :p 
m
0
l
!