Sign in with
Sign up | Sign in
Your question

Printer only works with Administrator Account

Tags:
  • Hewlett Packard
  • Printers
  • Windows XP
Last response: in Windows XP
Share
August 29, 2004 12:43:49 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

I'm using Win XP Pro, with a Pentium 4 processor and 1 GB
RAM.

I have 2 printers connected to my computer, HP LaserJet
2100 connected to LPT1 and a HP DeskJet 1220C connected
to a USB port.

I have an 80 GB hard drive partioned into
C: drive at 31.45 GB, with 19.78 GB free,
D: drive at 48.57 GB, with 42.11 GB free

There are 4 user accounts on my computer. I am the
Administrator and have no problem printing to either
printer.

The other three user accounts are 'limited accounts'.
They can print to the LaserJet printer without any
problem, however, whenever they change the default
printer to the DeskJet printer, they get the print
preview screen, but when they select 'print' a window
pops up titled "Spool Directory Selection". The message
is: "Insufficient disk space in the current directory to
spool the print file. Please select another directory".
It shows the current directly as: D:\spf15109.TMP and
another box listing a lot of folder names enclosed in
brackets. The Options are 'Click OK to continue, Skip to
ignore'. No matter what I do, the document doesn't
print. If I try to print another subsequent document,
absolutely nothing happens. I don't understand why it
shows the currently directory as "D:\"? I would think it
would be "C:\". Any advice or help would be appreciated.

Thanks,

More about : printer works administrator account

Anonymous
a b α HP
August 30, 2004 2:03:35 PM

Archived from groups: microsoft.public.windowsxp.print_fax (More info?)

Is the HP DeskJet 1220C driver the one shipped with XP or did you get this
from HP?

If from the CD with the device or HP.com please install the driver on the XP
CD. Printer Properties, Advanced, New Driver.
Pick the 1220C from the manufacture, model list.

If this is the driver shipped on XP, verify the spool directory for only
this printer has not been set. If this value is set it, will override the
default spool location.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Print\Printers\<PRINTERNAME>\Spo
olDirectory


The default spool location is \windows\system32\spool\printers

Since the laser works fine for users, this indicates that the disk security
is configured properly and points more at the driver than the system.

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/default.aspx?scid=fh;[ln];kbhowto

This posting is provided "AS IS" with no warranties, and confers no rights.

"Len" <anonymous@discussions.microsoft.com> wrote in message
news:233601c48dde$fa3af340$a501280a@phx.gbl...
> I'm using Win XP Pro, with a Pentium 4 processor and 1 GB
> RAM.
>
> I have 2 printers connected to my computer, HP LaserJet
> 2100 connected to LPT1 and a HP DeskJet 1220C connected
> to a USB port.
>
> I have an 80 GB hard drive partioned into
> C: drive at 31.45 GB, with 19.78 GB free,
> D: drive at 48.57 GB, with 42.11 GB free
>
> There are 4 user accounts on my computer. I am the
> Administrator and have no problem printing to either
> printer.
>
> The other three user accounts are 'limited accounts'.
> They can print to the LaserJet printer without any
> problem, however, whenever they change the default
> printer to the DeskJet printer, they get the print
> preview screen, but when they select 'print' a window
> pops up titled "Spool Directory Selection". The message
> is: "Insufficient disk space in the current directory to
> spool the print file. Please select another directory".
> It shows the current directly as: D:\spf15109.TMP and
> another box listing a lot of folder names enclosed in
> brackets. The Options are 'Click OK to continue, Skip to
> ignore'. No matter what I do, the document doesn't
> print. If I try to print another subsequent document,
> absolutely nothing happens. I don't understand why it
> shows the currently directory as "D:\"? I would think it
> would be "C:\". Any advice or help would be appreciated.
>
> Thanks,
>
!