Sign in with
Sign up | Sign in
Your question

Saints Row The Third very laggy on HD 5570??

Last response: in Video Games
Share
June 28, 2012 9:40:35 PM

Hey guys..i just recently bought an ATI XFX Radeon HD 5570 1gb ddr5...and it lags on saint row 3 even at the lowest settings..??...btw iam able to maxout crysis 2 and games like assassin's creed revelation..etc..any ideas??..this is my first time using an AMD card..:D ..anyone know any fix??..driver issues or watsoever??...my previous card nvidia 9400gt was able to play saint row 3 on low settings with 1024x768 res without any problem..
my specs:
4 gb ram ddr2
V card as mentioned above
Intel® Core™2 Duo Processor E4500

More about : saints row laggy 5570

June 29, 2012 2:15:55 AM

So that should not be happening because you meet the system specs. What steps have you done so I don't get I already tried that. When you play crysis 2 is it with the new card? Let us know what you have done and we will go from here.

Minimum
OS: Windows XP
Processor: 2GHz Dual Core Processor (Intel Core 2 Duo or AMD Athlon X2) or higher
Memory: 2GB System RAM or more
Graphics: 320MB Video RAM GPU w/ Shader Model 3.0 support. NVIDIA GeForce 8800 series or better. ATI Radeon HD3800 series or better
DirectX: 9.0c
Hard Drive: 10GB
Sound: 100% DirectX 9.0C compliant sound card or equivalent onboard sound
Co-Op Play:NVIDIA GeForce 8800 cards require 640MB of Video RAM. ATI Radeon HD3800 cards require 1GB of Video RAM

Recommended
OS: Microsoft Windows® 7
Processor: Any Quad Core Processor (Intel Core i5 or AMD Phenom II X4) or 3.0+ Dual Core CPU
Memory: 4GB System RAM or more
Graphics: 1GB Video RAM GPU w/ Shader Model 4.0 support. NVIDIA GeForce GTX 400 series or better. ATI Radeon HD5000 series or better
DirectX: DirectX 11
Hard Drive: 10 GB
Sound: 100% DirectX 9.0C compliant sound card or equivalent onboard sound
m
0
l
June 29, 2012 8:05:22 AM

Yeah on my HD 5570..i tried downgrading my drivers to 11.10(no results)..will try 11.9 also....i also heard from steam forum that people are having similar issues..especially with AMD cards...although i doubt my processor might be the culprit...but then again i see videos and posts of people maxing out this game... btw my game is steam version is it causing lag somehow??
m
0
l
Related resources
June 29, 2012 6:33:37 PM

Have you done the Verify integrity of game cache on the game in Steam? If you don't know about it let us know and we will show you how t do it. Since that is the only game that is giving you problems.
m
0
l
June 29, 2012 7:03:09 PM

oh.!!..please do i have no idea about that :D ..Thanks :) 
m
0
l
June 29, 2012 7:46:40 PM

Ok here it is and follow it and I hope this works for you.

When in Steam, left click on Games. Then left click on view Games Library. Right click on the Game. Then left click on properties. Then left click on local files. Then left click on Verify Integrity of Game Cache.

Then let it run it's course. Do it at least 3 times in a row. That way it will fix the files that are probably causing your problem. Good luck.
m
0
l
June 30, 2012 11:22:37 AM

Nope no luck..but thanks anyways...i'll see wether there's some patches...
m
0
l
June 30, 2012 10:17:32 PM

Have you tried all the new drivers out? They start in the 12's or 13's. Have you done a driver sweeper on the other drives? The problem I have with is the lag is only on one of your games.

Maybe the game hates AMD. Anyway next time you do a driver update or go the other way us a driver sweeper. Then when you install the new driver do the custom install

Then you will have another choice, choose the clean install and go from there. Since it is only with that one game did you have any issues with down loading from Steam? You might have to reinstall the game again.

But before you do let me know the answers I have asked for. Then I can tell you what to do step by step.
m
0
l
July 1, 2012 8:59:31 AM

Yeah tried 12.1,12.2,11.11...and yes 12.2 and 11.11 cap2 help improved some fps but the stuttering lag still occurs..like play,stop,play,stop :D  every 1 to 2 seconds...
Yeah i used driver sweeper also and did custom installation....no no issues downloading from steam.. i'll try reinstalling the game..Thnks :) 
m
0
l
July 1, 2012 10:10:53 PM

Have you done Memtest86+ to check your RAM? And have you check your temps? Here is the link to memtest.

http://www.memtest.org/
m
0
l
July 2, 2012 3:48:39 PM

Thanks...will surely try :) 
m
0
l
July 2, 2012 9:43:55 PM

Let me know about your temps and what you are using to check them? If you don't have a program just let us know and I will link you to one.
m
0
l
July 2, 2012 10:18:41 PM

only losers play that *** game.
m
0
l
July 4, 2012 6:58:00 AM

ok my Ram usage shows 60%..
m
0
l
July 4, 2012 9:38:10 PM

I still need to know about the temps. Have you turned off the AA and/or Vsync? Is your bios updated? Is your Soud drivers updated? Have you tried running the game as administrator?
m
0
l
July 5, 2012 5:49:09 PM

My Ram temps at 43-50 Celsius...and yes i've turned off Vsync and AA(lowest settings as possible)...n also tried running under administrator...no dice still..
Sound Drivers are updated..i've checked from device manager..
My motherboard is MS-7525 with current bios version 5.10 06/11/2008..http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01...
i also tried updating bios to 5.22....but error occurs saying minimum requirements not reached even though my system pass
http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadInde...
System requirements:
You must be logged on as an administrator to install this update.(passed)
You must have a Microsoft Windows Vista operating system.(passed)
You must have an MS-7525 motherboard.(passed)


I have never updated my Bios before(how to update??):D .....maybe i'm missing something....can you help me out......and as always Thanks mate!! :) 
m
0
l
July 5, 2012 9:11:15 PM

I am going to link you to some stuff it might help or not but it is good info all the way around. The first link is a settings thing the next few links are on how to update or flash your Bios.

Check out everything and try some of it if you feel you can do and if you have any questions just ask. Good luck.

http://www.tweakguides.com/Graphics_1.html

http://www.pcworld.com/article/187437/how_to_update_you...

http://www.pcstats.com/articleview.cfm?articleID=1605

http://www.youtube.com/watch?v=gxpE1N4xB4s

http://video.search.yahoo.com/search/video?p=how+to+fla...

http://www.ehow.com/how_5011164_flash-bios.html

Here is a game booster to try and see if this doesn't help.

http://gboost.en.softonic.com/

http://www.iobit.com/gamebooster.html
m
0
l
July 6, 2012 8:20:29 PM


Thanks for the info's on the Bios..btw i got it to work :) ......removing the amd display driver really help boost saint row 3 performance(donno how:D  but it did)..it seems to be amd drivers bug after all....anyways i'll give the latest 12.7 a try..
m
0
l
July 6, 2012 11:41:24 PM

That is good news I will keep my fingers crossed but just remember the drive you have now incase the 12.7 doesn't work. Good luck.
m
0
l
July 16, 2012 9:20:14 PM

defy_Y said:
Thanks for the info's on the Bios..btw i got it to work :) ......removing the amd display driver really help boost saint row 3 performance(donno how:D  but it did)..it seems to be amd drivers bug after all....anyways i'll give the latest 12.7 a try..

Could you explain how you did this? I am having a similar problem and it is about to drive me crazy.
m
0
l
July 17, 2012 9:37:35 PM

Try Removing your Catalyst Control Centre(CCC)....u can do this by selecting the custom uninstallation...check only the CCC n uninstall it...also reboot...if tht does not work...try switch back to the driver(the one tht you got with ur vcard in the CD)...also try removing it's CCC.....it made my game playable..hope i helped...also give the 11.11 with cap 2 a try...
m
0
l
July 23, 2013 7:48:22 PM

defy_Y said:
Try Removing your Catalyst Control Centre(CCC)....u can do this by selecting the custom uninstallation...check only the CCC n uninstall it...also reboot...if tht does not work...try switch back to the driver(the one tht you got with ur vcard in the CD)...also try removing it's CCC.....it made my game playable..hope i helped...also give the 11.11 with cap 2 a try...


I am trying to do this now. A year later...will check if this works...have same problem.
m
0
l
!