Sign in with
Sign up | Sign in
Your question

Just Cause 2

Last response: in Video Games
Share
June 29, 2012 12:44:12 PM

I've seen this problem all over the place but haven't been able to find a fix. When I try to play Just Cause 2 I get a white screen and then a message saying the program has stopped working, that's it. I'm running it on an i5-3570k processor and an AMD 6850 with the latest drivers all with Windows 7. I've tried updating Direct X and reinstalling Just Cause to no effect. I've run it in windowed mode and verified its game cache on steam. Any ideas would be great.

More about : question

June 29, 2012 5:34:10 PM

Darthjebus211 said:
I've seen this problem all over the place but haven't been able to find a fix. When I try to play Just Cause 2 I get a white screen and then a message saying the program has stopped working, that's it. I'm running it on an i5-3570k processor and an AMD 6850 with the latest drivers all with Windows 7. I've tried updating Direct X and reinstalling Just Cause to no effect. I've run it in windowed mode and verified its game cache on steam. Any ideas would be great.


Have you tried running it as an administrator?
June 30, 2012 2:49:58 AM

Next time you uninstall the game use a uninstaller other than the remove/change programs. Some times you don't get all the old files out and when you reinstall the problem still there.

Same thing with the drivers. You need to use a driver sweeper to get all of the drivers left behind. Try the run as administrator first and if no go then try this way and when you de reinstall the drivers.

Do a custom install and then choose a clean install. I will link you to what I have stated above. I do wish you good luck on this.

http://download.cnet.com/Revo-Uninstaller/3000-2096_4-1...

driver sweeper
http://phyxion.net/item/driver-sweeper.html
July 1, 2012 10:07:45 AM

I'm running it through steam so I've tried running steam as an administrator and that didn't help. With the custom install again I don't think that's an option when installing through steam. Thanks for all the help though. I shall try using the driver sweeper and report back.


!