Sign in with
Sign up | Sign in
Your question
Solved

Why do I experience lag under 50 FPS.

Tags:
  • PC gaming
  • Lag
  • FPS
  • Computers
  • Video Games
Last response: in Video Games
Share
July 4, 2012 12:26:51 AM

Hello, I've had this computer for a while, and I'm really tired of always experiencing lag under 50fps, it pisses me off. Everything is smooth as butter but the second it takes more than 20ms for every frame (under 50fps) I experience lag, which feels like I'm playing at 20 fps or something. It only happens on this computer, I've tried running games on my older laptop and 30 fps looks amazing compared to 45 fps on this computer. Stuttering, mouse lag (sometimes), choppiness, it all happens the second I hit 49fps. I just can't explain it. I have switched screens, which didn't work, played with some settings in Nvidia control panel, etc... Before I used to have a HD 5970 which ran like crap already from terrible drivers, and this issue forced me to get a new card (now a GTX 580), it is much better than before, don't get me wrong, but I still have that unbearable lag. Any help appreciated.

Specs :
Core i7 860 @ 3.33GHZ
8GB of DDR3 ram
GTX 580 (Asus Matrix 1.5GB)
Gigabyte P55-UD6 Motherboard
Screen resolution : 1680 x 1050

More about : experience lag fps

July 6, 2012 4:42:16 PM

Check your temps for your card, I dislike Nvidia cards because they take a horseload of power and heat up really quickly. I have a generic crappy Widetech Case and my HD 7850 never surpasses 55 degrees celsius when Oced at 1050 core, 1300 mem, and playing BF3 with everything turned up to maximum.
m
0
l
July 7, 2012 2:50:48 AM

I can assure you it's not my graphics card getting too hot. With all the fans it's got on it that would be impossible. Thanks though!
m
0
l
Related resources
July 8, 2012 6:01:16 PM

Do you have VSync on? If you do, there's you issue. Try using adaptive VSYNC (force it in the nvidia control panel for all applications).
m
0
l
July 8, 2012 9:57:19 PM

Nope, I normally have it forced off in almost every game. And turning it on or off doesn't solve the issue. D:
m
0
l
July 19, 2012 10:30:21 PM

Bump.
m
0
l
Anonymous
July 23, 2012 5:26:51 PM

I have EXACTLY the same problem. Pretty much the same rig as yours, GPU is probably a bit weaker at hd7850.

Please tell me if you find a fix.
m
0
l
July 23, 2012 7:21:53 PM

Games begin to stutter and get less smooth under 50 fps? Yep.

Turn off Vsync and Triple Buffering if you're in a game that can utilize TB, but don't expect a greatly improved performance. Disabling those two features doesn't so much make 49 fps look smoother, as it does reduce your chance to get say 45 fps when you could potentially get 55 without (this gets complicated but because of how Vsync works, if it applies to frames under your refresh rate it can drive your fps lower than it naturally would be). But, 49 fps looking kinda shitty is normal. That's why no one wants lower than 60 fps.
m
0
l
July 24, 2012 9:54:00 PM

Vsync and Triple buffering forced off at all times, except on some games where screen tearing is a big issue. Trust me, if Vsync and TB were the problem, I wouldn't be on these forums asking this question. This computer has an issue with slower framerates and I can see it VERY easily. But on other computers running at 30FPS looks smooth as butter compared to 45FPS which looks like 20 on this machine. Thanks for talking your time to answer!
m
0
l
July 24, 2012 10:09:41 PM

30 FPS never looks smooth as butter. It may have framesmoothing enabled if you're in unreal engine, but the game also handles like an oldsmobile at that speed. Anyway, the reason you're stuttering and your game looks bad is because your fps is jumping around which exacerbates an issue that you already have with something like 45 fps where a game is not going to look or feel "smooth as butter" because 45 fps is underperforming. Particularly in an fps. The reason that your 5970 had this problem, and your 580 has it now, is because every graphics card has this problem. If you're running at low fps (which you are), your game is not going to look or feel smooth (which it doesn't, appropriately).
m
0
l
July 24, 2012 10:29:03 PM

Thing is, my HD 5970 also had REALLY bad micro-stuttering which is a common issue with Dual GPU setups, and the GTX 580 helped GREATLY on that front, but never actually fixed the issue. I understand where you're coming from, yes 30 FPS is pretty bad but when your friends' rigs run 30FPS and it feels better than your 50 and under FPS you start asking yourself questions. I mean, I get all sorts of crap under 50 FPS. From stuttering to mouse lag etc etc etc. When I sit down in front of another computer and play the same thing I get absolutely no issues at the same framerate.
m
0
l
July 24, 2012 10:47:45 PM

It depends on what he is running at 30 fps. If it's an unreal engine game with framesmoothing set to 30 fps capped (which many are), then the game will look relatively smooth for as low as the fps are, but it will handle really sloppy as well. All I can tell you, is that having a choppyish experience at 45 fps in a first-person shooter game is normal. It's the reason we buy fancy stuff and the reason we don't turn on 8x MSAA.
m
0
l
July 25, 2012 2:06:58 AM

try using a bf3 configurator or some other bf3 config file maker.
select 60 fps a the max and this will help lift your minimum. it may only be by 1 or 3 fps but that may be the difference between jerky and smooth. reason being its it wont be producing 90 fps then sudenly dropping to 50 which you will notice but if your running at 60 and drop to 55 the game will feel smother. because your not seeing huge fps droop.
m
0
l
July 25, 2012 2:10:47 AM

or make a txt file called user.cfg with notepad
put the bleow in it and save it. the put it in c: program files (x86)/origin games/battlefield 3 (or where ever you have bf3 installed)
now when your boot the game you will have 60fps limited and everything else needed for an optimized game. you can if you want remove some of the stuff with a ; in the beginnin of a line or if you want to turn something off or on then replace a 0 with a 1.
notice i have the fps set to 60 but no vsync on. if you put it on you will likely get more stutter so make sure you disable it when using this cfg file... if you dont like the effect it has on your game just delete it from the install folder.


GameTime.MaxVariableFps 60.000000
render.drawfps 1
Render.DrawScreenInfo 0
render.perfoverlayvisible 0
RenderDevice.Dx11Enable 0
RenderDevice.TripleBufferingEnable 1
Screenshot.Format jpg
WorldRender.DxDeferredCsPathEnable 0
WorldRender.SpotLightShadowmapResolution 1024
Render.DrawFps 1
RenderDevice.TrippleBufferingEnable 1
m
0
l
July 25, 2012 4:09:19 PM

Is there anyway to lower the FPS jumps in games in general? So that instead of having let's say a jump from 40 to 65 have it much smaller at let's say 40 to 50 so that you average at 45 and have much less stutter instead of massive FPS spikes that result in much more stutter?
m
0
l
July 26, 2012 3:37:25 AM

yes limit the max fps... the first line in the above GameTime.MaxVariableFps 60.000000 will limit the fps to 60 but you can use any number from 30 to 120.
also turn down shadows (turning them down to low will give an fps boost. turn of ssao or hbao for the same.
i use the above to get a solid 60 fps on every map running mostly medium to low settings... game still looks good at 1080p but is way smoother without the fps droop.
m
0
l
July 29, 2012 2:07:44 PM

Bump.
m
0
l
July 29, 2012 2:32:29 PM

What more reason is there to bump? You've gotten your question answered very specifically and some background on the subject. There's nothing else to contribute really. lol
m
0
l
July 29, 2012 3:40:29 PM

Because no "fix" was given to my question, I don't care about anything that could "help" gameplay in BF3, that's just ONE game and also a terrible one to make example of because it looks basically the same from very low to very high... I don't know what you guys took from my question but it's extremely far from what I expected. Even after I said nothing helped you kept pushing me into believing that it's one hundred percent normal, and it's NOT. 30 FPS should not look as crappy as it is for me unless you have extremely sensible eyes. I told you that putting my computer side to side with anything else, even a crappy laptop resulted in the laptop looking thousands of times better than my computer at 30FPS. One looks like a regular normal 30 FPS and my computer looks like 10 FPS for absolutely no reason. Hell even consoles don't have the visual stuttering and jumping my computer has. There IS something wrong and it's NOT just Vsync or some other setting, I tried everything and completely reinstalled windows to try and fix it. Even my friends think my computer is lagging when my FPS is as high as 45. If I check how their computer looks at 30 it STILL looks like 50FPS on my machine. I'm not saying you didn't help. Sure you gave me some good settings that do help but I think you're missing the point. It's not a single game or an FPS. It's EVERY game that looks like crap at 30FPS.
m
0
l
July 29, 2012 3:42:52 PM

MadClover said:
Because no "fix" was given to my question, I don't care about anything that could "help" gameplay in BF3, that's just ONE game and also a terrible one to make example of because it looks basically the same from very low to very high... I don't know what you guys took from my question but it's extremely far from what I expected. Even after I said nothing helped you kept pushing me into believing that it's one hundred percent normal, and it's NOT. 30 FPS should not look as crappy as it is for me unless you have extremely sensible eyes. I told you that putting my computer side to side with anything else, even a crappy laptop resulted in the laptop looking thousands of times better than my computer at 30FPS. One looks like a regular normal 30 FPS and my computer looks like 10 FPS for absolutely no reason. Hell even consoles don't have the visual stuttering and jumping my computer has. There IS something wrong and it's NOT just Vsync or some other setting, I tried everything and almost completely reinstalled windows to fix it. Even my friends think my computer is lagging when my FPS is as high as 45. If I check how their computer looks at 30 it STILL looks like 50FPS on my machine. I'm not saying you didn't help. Sure you gave me some good settings that do help but I think you're missing the point. It's not a single game or an FPS. It's EVERY game that looks like crap at 30FPS.


You want smooth gaming experiences at unregulated FPS levels below your refresh rate. There was no fix given because you might as well ask how to turn lead into gold. Several posts with realistic options were made for you on Hexit's part.
m
0
l
July 29, 2012 3:46:31 PM

Does getting a higher refresh rate monitor help by any chance then? Or like I asked earlier is there any setting that could help in the fluctuation of framerate?
m
0
l

Best solution

July 29, 2012 4:30:55 PM

MadClover said:
Does getting a higher refresh rate monitor help by any chance then? Or like I asked earlier is there any setting that could help in the fluctuation of framerate?


Higher refresh rate monitor won't fix the issue of your fps being unregulated and shifting up and down. Like Hexit was telling you, if you wanted to sacrifice peak fps for steady fps, you could limit your max fps using a framerate limiter, and cap it somewhere below your lowest dip (30 fps for instance). You'd be gaming steadily at the same framerate and could get used to looking at it and playing with it, and you wouldn't feel the "jerkiness" in the game so to speak. It still won't look as nice as 60 fps though.

Also, using console as a comparison to your PC gaming experience is a bad habit. A lot of console games are built around running at 25 and 30 fps (depending if you're PAL or NTSC) and they use a lot of blurring and partial image overlay techniques to hide that fact and make the game look smoother. The tradeoff is that the actual image fidelity in these cases, sucks. You'll notice stuttering and texture popping and all of those nasty phenomenon more on a 1080 monitor with games designed to run at 60 fps because A. you're sitting closer to it than you would be to a television that you'd play an xbox on for instance, and B. because the image fidelity is better so you can actually see the flaws better.
Share
July 30, 2012 12:12:16 AM

Well, I used Nvidia inspector to lock my fps to 30 and 40 and jesus does it look better now. I played skyrim with ENB and it looks amazing and runs pretty well, clearly not 60 fps but nowhere near as bad as before. I also tried Witcher 2 at 30 fps and that one felt AMAZING at that speed, metro 2033 was a tad worse because it's a shooter but still very playable. I could even crank the settings to max on Witcher 2 including Ubersampling because it's never in hell going to go lower than 30 fps anyway so it looks even better than before! I think I'm sticking to this from now on. Thanks alot!
m
0
l
August 9, 2012 2:58:12 AM

Best answer selected by MadClover.
m
0
l
August 9, 2012 11:05:08 AM

thing is you have an 870 and a gtx 580 you should be killing bf3 at near max settings 60fps minimum . pretty much every other game you should be able to max with 60fps minimum... theres no way you should be at 45fps with a 580. you have tried a different screen? what screens have you tried? have they both had a refresh rate lower than 8ms?
have you tried overclocking the 870 although i cant see how it would help as 3.3 is more than fast enough...
maybe your stuck on x4 pci-e in bios or something... to be honest im a bit baffled...
maybe you can make a small fraps move to show your problem and help explain it better.
say 1-2 mins of bf3 maxed out then at high settings. to see if theres a difference in smoothness. then try another game... if you can be bothered give a commentary...
you say your 6970 ran like crap also? so that leads me to belive it is a system problem like the pci-e set wrong...
if you have more than 1 slot i recommend you move the card to a different 1 and set the slot appropriately in bios.
1 last thing. what size is your psu and what brand...
m
0
l
August 10, 2012 2:53:58 AM

Okay, this is going to take awhile and I currently don't have the time to try all of that out. But yes, I knew something was wrong because in every game I have bellow average FPS for my computer's specs. My PSU is a Corsair AX850 (850w). I used to have a smaller one but since I switched to the GTX 580 I needed more power because it's really power hungry. Also my old card is a HD 5970 and not a 6970. My CPU was overclocked TO 3.33GHZ but it came in the box at 2.8GHZ, so it is already overclocked. About the screen, I don't know if it is under 8ms but it is an LG Flatron W2254TQ (doubt you can actually find that online) and it is 60hz refresh rate. I did try another monitor but it's the exact same results. If you could help me further with Bios etc I would appreciate it because I'm terrible in that field TBH. My motherboard only has one PCIE 8 slot and my Asus GTX 580 Matrix is much to big to move onto another slot because it already takes the place of two slots (it's a MASSIVE graphics card). Anyways I would just need help about settings for the PCI E slot in the bios, but I haven't touched anything in the bios thus far so I don't know why it would be set wrong.
m
0
l
August 10, 2012 8:29:56 AM

i pcie 8 slot? what motherboard is it? coz i doubt that is correct...
if it is at x8 then thats likely the problem.
make and model please... i will check out the bios via its pdf and let you know what to change.
m
0
l
August 10, 2012 9:41:43 AM

No it is not a problem. No card in the world will get bottlenecked much by PCIe 2.0 x8 slot.

m
0
l
August 10, 2012 12:20:53 PM

that actually depends. all then benches show a 15-5% bottleneck it may not be much but its enough. especially if your system has a weaker cpu than the system the benches were taken from... due to the 870 being about 20% weaker it may turn a 15% bottlneck into a 20-25% 1 and a 5% 1 into a 10%-15% bottleneck.
the saving grace is that the 580 is about 30% weaker then the 680 which should reduce the bottlenecks if there is 1.
what im getting at is if the pci-e is set wrong it may be set wrong in other ways like running at the wrong hz or it may be getting overclocked and becoming out of sync.
if you look back through the guys posts he had 2 cards on the system and both produced the same or similar results. that tells me it may not be the card but the system it plugs into the pci-e being the first point of contact which is why im asking these questions.
nothing he has tried so far has worked so now we go deeper eventually i hope to fix the problem but because i cant go visit him and get hands on, he is stuck having to go step by step...
m
0
l
August 10, 2012 1:59:45 PM

Okay, sorry about the delay, I was sleeping :p  So, my motherboard is a Gigabyte P55-UD6.



EDIT : Also I'm sorry I didn't mean to say PCI E x8, I meant to say x16...
m
0
l
August 10, 2012 3:12:43 PM

ah rite i had a look and i guess you meant the next available pci-e slot is x8 there are 3 x16 then x8 then x4
peg_1 =x16 slot
peg_2 =x8 slot
peg_3 =x4 slot.
so in bios make sure your set to peg_1 its likely set to pci or peg_1 anyway but peg_1 is the preferred.
also remove the pci-e clock rate off auto and set it at 100 this is the default but if its on auto it can cause the motherboard to increase or decrease it if it wants to depending on what the system is doing and what power savings are enabled.. setting it manually forces it to stay constant.
also make sure you have c1 halt and any of the other power profile perfomance switches disabled. things like c2,c3, and so on. doing so will make sure you overclock doesnt step down and reduce system performance when it should be going full tilt. as your overclocking make sure you have everything you need to set manually instead of auto... see pic (dont use my settings yours will be different)
i took a picture of my bios so you can see what i mean about switching from auto to manual settings. everything on the left is the default and you notice the bottom 2 are still on auto they were later changed over to what was on the left... they were the same values as they would have been in auto but they cant be (auto) changed by the system if the system decides to reduce the clock speed of other components.
m
0
l
August 10, 2012 5:37:36 PM

Okay, I've done the changes you've suggested in the Bios. I've changed every voltage setting to the same as the normal settings (they were all set to auto). I also made sure my PCI E slots were set to PEG but on my bios the list says : PCI, PEG, PEG 2 and PEG 3, so I assumed PEG was PEG 1 from your post and set it to that. I also set the PCI E clock rate to 100 but I couldn't find any options for c1 halt, c2 or c3. And I also do not have an option to disable load line calibration, but I can put it to standard mode which is Intel's default.
m
0
l
August 10, 2012 7:39:17 PM

I just finished playing some Metro 2033 and I can say the results are much better than before. Now, anything over 40 FPS looks much better ; no mouse lag, no stuttering. Before the bios changes, 50 fps was basically the lowest possible before starting to have those symptoms. I can also say the performance was much better in terms of FPS, and was pretty much always over 35 FPS with all settings maxed + 4xAA unless it was an extremely intense scene. Sadly under 40 FPS I still see some mouse lag and a bit of stutter. If there's any way to explain it, it feels like my mouse sensitivity was turned way down compared to higher framerates and there is still stuttering happening aswell.



EDIT : I also realized that after changing the bios settings my cpu usage seems to be higher but my RAM usage went down like 6-8%... Possible?
m
0
l
August 10, 2012 10:07:03 PM

its possible... maybe something failed to start or is on delayed start that takes up that extra ram...
c1 halt state should be in your cpu overlocking MIT section. same for c3.
c2 is normally in the pci-e section where you change peg mode. is its advanced powersaving for the pci slots.
as for the mouse lag. make sure you have advanced mouse smoothing off in windows mouse control and the speed slider set in the middle.
m
0
l
August 10, 2012 10:44:41 PM

Okay, the mouse slider was already in the middle and mouse smoothing was off (I'm guessing it's the enhanced precision setting?). About the ram I don't know why it is at a lower usage % than before but I have as much processes so maybe one of the settings were making it slower or less powerful. About C1 halt I'll contact you again after I find and change these options.
m
0
l
August 10, 2012 11:06:07 PM

Alright. So I went into the bios and disabled C.I.A.2 (CPU intelligent Accelerator 2) which I'm guessing is C2 because I couldn't find anything else, not sure if that's it though. Then I disabled C1 and C3/C6/C7. I couldn't disable C3 alone because all three were in the same option. Tell me what you think about that C.I.A.2 option because I doubt that's the right option as it really has nothing to do with PCI E slots.
m
0
l
August 12, 2012 2:04:24 AM

cia 2 is the correct 1... i recomend you turn it off because it ties in with all the other settings you want to turn off. it does have an effect on the pci-e in that when the system uses it the pci-e is also reduced in power and speed. it does have a small impact on the systems perfomance as well as the pci-e slots even if it is indirectly.
m
0
l
August 12, 2012 2:23:55 AM

Okay, so what would be the next step in increasing performance and reducing negative effects? Turning these settings off made me able to play at over 40FPS instead of 50FPS, I wonder how much better it could get... It's obvious that part of the problem lied in the bios setting, now where else should I check? thanks.
m
0
l
August 12, 2012 6:17:34 AM

i would suggest you try optimizing your system. first go into the gfx pannel and set it to default settings... if you have any active game profiles dissable them as they may be whats hampering the games perfomance.(you can enable them later if you wish)
then with apps like windows 7 manager. start optimizing properly.
http://www.yamicsoft.com/windows7manager/index.html i think this has a 30 day trial fully working. if not then there are other apps like it but free.

first off it has lots of options so dont go mad just stick to the basics of cleaning and optimizing... leave all the configuring windows with things like removing shortcut pointers and so on for another day...(also remember apps like these can be potentially dangerous as they can disable essential stuff so be careful)
use the optimization wizard (safest way)and just go through it 1 at a time answering the questions it gives. its pretty straight forward...

cleaning out your startup making sure you only have your antivirus, gfx panel, keyboard/mouse a typical optimized gaming system will have less than 5 startup entries.

if your not on a netwrork then you can disable all that stuff and things like printers and scanners can have there associated services disabled...
if you have a mobile suite or apple quicktime make sure you remove them from startup and set there services to manual so they wont start even on delayed until you click the application... you would be surprised at how many unneeded services start up just because you installed an associated program that you only ever use 1s in a while... like i say you can often set these services to manual and they wont take up precious system resources. 1s done you should have around 55-60 running services on a well optomized gaming system. less is better...

1s done and you have used something like ccleaner to clean the registry.
you can reboot and see if theres any difference in how your games respond.
if there still a bit sluggish then consider partitioning your hdd if you only have 1 partition on your boot drive...
if you have more than 1 drive and there identical consider setting up a raid 0 config... if you do this partition the raid into 2 primary and storage, the primary being 1/4 the whole disk.
if you dont but your drive is big then 2 partitions will be your best setup,. creating more will slow the drive down by 10% each time you make a new 1 so 2 is the optimum for speed and usability . first primary partition that you will install to should be between 1/4 and 1/3 the entire drive and the rest can be used as storage.
if you decide to do this you will get the best performance from the drive as you wont be fragmenting and moving files constantly.
btw you havent listed your drives. if its a 5400 rpm blue or green then it may the root of slow gaming, as they are really just storage drives and are generally to slow to run games off. a slow drive alone can cripple game performance by introducing texture pop when the drive cant load them fast enough. if you are using 1 then i suggest you replace it with 1 or 2 7200rpm drives... i can recommend the samsung spinpoint f3 for this as they are the fastest 7200rpm drives currently available at 1 tb. i use them myself and have 3 in my system...

as for the system iteself go to the gigabyte site and get all the latest drivers you can for the system. thingls like nfo installer, ethernet and so on...
if you dont have a raid and your not creating a raid then dont bother installing any of the drivers they can make a system unstable if they dont find the required hardware.
lastly update your gfx, direct x and run a windows update to make sure you have everything you need. things like .netfix and vcredist should all be checked and make sure there up to date with all versions installed. check the microsoft downloads site if you think your missing something.
1s done run ccleaner 1 more time reboot and hopefully your games will play silky smooth at max or very near max settings with 60fps...

anyways thems the basics... remember when your playing keep an eye on your temps with apps like gpu-z hwmonitor for a few days to make sure your system is stable and withing safe ranges. and hopefully thats enough.
m
0
l
August 13, 2012 12:03:18 AM

Okay, I cleaned everything up and saved almost 7GB in my SSD thanks to you. My processes are now down to about 50-55.

My hard drive is http://www.tigerdirect.ca/applications/SearchTools/item...

This hard drive is where I put all my games and programs, but I also have an SSD for windows 7 and drivers.

Here is my SSD : http://www.intel.com/content/www/us/en/solid-state-driv...

I'll test a few games and report to see if the problem is fixed. Tell me what you think about these for gaming purposes.
m
0
l
August 13, 2012 1:17:22 AM

to me 120 gig is a little small but its enough. if you have the larger 1 then its near perfect.(i would love 2x250gigs for a raid 0 setup) as for the hdd drive... its perfectly adequate for storage. segate are a decent enough brand. lots of elitists dont rate em but the reality is no company would survive in the hdd market if they didnt make reliable drives. it may not have the over blown rep of western digital (personally i dont rate them any more or less than samsung drives) but they do work and they do last... so other than it being a little noisy for my taste. its a good solid drive.
if your using it for both a storage and a program drive then that may be an issue as drives tend to get fragmented very quickly that way... best you make another partition on it and use 1 for programs the other part for storage...

if the ssd is 120 gigs then you will have about 90 gigs after windows is fully installed so theres plenty of space for a half dozzen games or so. i would put the bigger 1s on it. games that have lots of textures and are slow loading... games like bf3 like ssd's it wont completely eliminate the long load time of bf3 but it will reduce it to roughly half what it is on a hdd.
other games like crysis 2 will benefit a little less. some game that really will love it, are gta 4 and rage... they both have serious textures pop issues due to the way the textures are programmed ( rage uses a technique called mega textures, while gta 4 is badly written) on a slow drive it can drive you nuts watching the textures slowly appear. so yeah you may gett a little more perfoamnce if you move your best games on to the ssd... even if its just a trial run...

m
0
l
August 13, 2012 2:02:03 AM

Moving only SOME games to my SSD wouldn't work because I use Steam and Steam is located on my Seagate hard drive, except for minecraft lol. Yeah I know a partition would help so I could put games on one and programs on the other but then wouldn't I lose everything on my hard drive by partitioning?
m
0
l
August 13, 2012 2:13:03 AM

Hmm, I have tested Witcher 2 and still I get some mouse lag when I hit around 39FPS, still I get some stutter too... Not sure what to do now.
m
0
l
August 13, 2012 4:56:48 AM

yep you would loose everything. but its worth considering when you get a new hdd.
as for having grief with the mouse lag. how big is your swap file? (virtual mem/page file) if its more or less than than 1.5x the actual physical ram it can cause all sorts of different issues...
but really you have done everything i asked and your still having issues so to be blunt im lost as to what could be causing it.. you have turned things like enhanced mouse precision, mouse smoothing and acceleration off. your usb's are not being overloaded as you dont have enough plugged in to cause a usb bandwidth issue.

is your mouse polling at the correct speed? have you checked the mouse manufacturers site to see if theres an issue with your mouses firmware...
http://www.ngohq.com/news/15043-how-to-increase-usb-sam... try the apps here to see what your mouses poll rate is and if its working as it should.
also if everything is fine go into the nvidia panel and make sure the render ahead limit is no higher than 3 and preferably set to 2 (if its set to high it will cause mouse lag) the menu should be in the 3d gaming/render settings... other than that i dunno what else i can advise you to do.
m
0
l
August 13, 2012 2:21:52 PM

My mouse polling rate is set to 1000 I'll make sure I check my mouse settings etc. and Nvidia too, as I set Nvidia control panel settings to default yesterday for windows7 manager.
m
0
l
August 14, 2012 1:07:20 AM

About the page file it was set to exactly 8GB which is exactly as much as my RAM so I set it to 12288MB (1.5x 8GB) I'll see what that changes.
m
0
l
August 14, 2012 1:42:17 AM

try putting the mouse in a differnt usb socket.. make sure you dont use its twin but use a separate usb hub. this way you will know if the usb is slow/damaged.
also go into device manager and see if the usb hub has any issues and its not set to power saving.
m
0
l
August 14, 2012 4:20:12 PM

Okay, all the hubs were set to (allow computer to turn this device off to save power). I disabled these options to ensure they are working all the time.
m
0
l
August 16, 2012 11:16:31 PM

Seems I still get the annoying lag and I don't know why... Any more help appreciated, and thank you very much HEXiT.
m
0
l
!