Sign in with
Sign up | Sign in
Your question

The Witcher 2 slows down in some areas on high end setup

Tags:
  • PC gaming
  • Video Games
Last response: in Video Games
Share
July 7, 2012 7:48:23 PM

Hi, so i just finished my first play through of the Witcher 2 last night. It was great, but I am a little stumped on some things. During big battles like Vergen Besieged and the fight with the dragon my fps would drop from 60 (i have v-snyc enabled) to 50 fps (which is noticeable and annoying). My setup includes 2 GTX 570s in SLI (1.2gb) an I5 2500k at 4.2 GHZ, 8 gigs of ram, etc. as you can see my PC (which i built) is very high end and im not sure if its me or is the game extremely demanding. Also on a side note when it drops my gpu usage for both cards is like 60-70% which I am pretty sure is OK because some processes cant utilize 100% of the gpu and i know i dont have a bottleneck. I have all the settings on ultra except ubersampling and am running at 1080p. Please, an explanation would be useful thank you (I just need to ease my mind and make sure it is not my setup, because i have had other problems in another game mainly Shogun 2, which i know is the games poor optimization and use of 1 core).

More about : witcher slows areas high end setup

July 9, 2012 10:55:12 PM

with a double post its polite to ask a mod to remove it... as for your perfomance 50fps minimum is pretty good. if you have vsnc on then your gonna see some microstutter when the fps drops below 60 and theres not a lot you can do about it unless you drop a setting or 2. as your playing @1080p take the a.a down to x2 or use a fxaa injector and remove it all together. this will put you back to 60 fps minimum and hopefully stop your issues.
m
0
l
July 10, 2012 5:31:56 AM

HEXiT said:
with a double post its polite to ask a mod to remove it... as for your perfomance 50fps minimum is pretty good. if you have vsnc on then your gonna see some microstutter when the fps drops below 60 and theres not a lot you can do about it unless you drop a setting or 2. as your playing @1080p take the a.a down to x2 or use a fxaa injector and remove it all together. this will put you back to 60 fps minimum and hopefully stop your issues.


+1. Additionally, make sure you check the advanced settings and make sure ubersampling is turned off. If you do have uber enabled, which I doubt you do, make sure you turn AA off completely. With all of that being said, I play Skyrim (with the nvidia tweak guide), BF3, Arma 2, and DCS: A10C. I think for the type of gaming that you get from Witcher 2, it's the most taxing game on my system. 55 fps average is very good for that game. I still don't know how they made it so ridiculously awesome on DX9, it probably would have ran better in DX10 however.
m
0
l
Related resources
!