Sign in with
Sign up | Sign in
Your question

Low FPS in Darksiders

Last response: in Video Games
Share
July 13, 2012 12:55:29 AM

After spotting a good price on Darksiders in the Steam summer sale I grabbed it.

However, a little to my disappointment, it runs like crap on my system. Dropping to as low as 14 fps in some cases making it look super choppy.

My native resolution that I use is 1920x1080p.
I use it for everything since any lower looks like crap on such a large 32" monitor (TV)

When water is encountered in the game the framerate really seems to tank hard and ups again when the water is no longer on screen.
Also when there are long draw distances to render the fps drops alot.

I have no slouch of a system, but its not amazing either.

i5 760
GTX 460 OC
Win7 64bit
8GB RAM

Any ideas why it could be running so badly?
I should be getting a rock solid 60FPS with v synch on with this PC surely?

More about : low fps darksiders

July 13, 2012 1:47:23 AM

Darksiders wasn't a great port, not well optimized, and virtually no graphical options. That said, you should not be getting poor performance. I have a similarly powered system to yours, with a video card that is only slightly better, and the game runs okay.

I would say this is probably a video driver problem. It could be that Darksiders doesn't play nice with the current nvidia drivers. Try rolling back to an earlier revision and see if that helps performance in Darksiders.
July 13, 2012 4:15:15 AM

^+1
Also you can try the Verify Integrity Of Game Cache. Alot of times it helps because Steam games for some reason they don't down load a lot of the files that is neede in the games. It is just another thing to try and help. Good luck to you.

TOOL: When in Steam, left click on Games. Then left click on view Games Library. Right click on the Game. Then left click on properties. Then left click on local files. Then left click on Verify Integrity of Game Cache.
Related resources
July 15, 2012 12:27:29 PM

I'm running Darksiders on a 540M with the current drivers and aren't having any problems with the frame rate or any bugs/glitches. Though I do agree that it isn't very well optimized and the lack of video options is quite strange.
July 15, 2012 1:08:05 PM

There was some really simple fix for Darksiders. I can't remember if it was to run it in windowless mode, or disable vsync/triple buffering but I remember fiddling around with the game for about 5 minutes and turning on/off one of the usual suspects that would cause a glitch in fps rate on a console port, and the game ran perfectly fine after doing so (as in, from 15 fps let's say, to 120).

On a side note, 1920x1200 is pushing it on a gtx 460 VRAM-wise.
!