Sign in with
Sign up | Sign in
Your question

Crashing games, could it be my onboard sound?

Tags:
  • PC gaming
  • Games
  • Skyrim
  • Video Games
Last response: in Video Games
Share
July 14, 2012 10:51:08 PM

Hi, i recently built my PC to play games like Skyrim and BF2: Bad Company, among many others. But with those 2 titles i tend to get hard crashes where the game will actually lock up and i have to hit the reset button to get out of it.

While researching the issue with BF2 i came across a solution that many had agree'd worked for them - get a sound card.

With Skyrim I tend to freeze up with strong sounds like using flame spells or a dragon roaring at me at close range. The point though is i always freeze during a loud sound.

My specs are:

Pentium G620 2.6 Ghz : 4GB 1066 Memory : AMD Radeon 6850 OC 950/1100

More about : crashing games onboard sound

July 15, 2012 12:41:19 AM

I believe it is your drivers and a little bottlenecking. Your CPU can't keep up with your GPU plus your GPU is OC'd. Try updating your drivers and turn everything off like yoiur AA, Vsync, etc, and run on low settings.

It is worth a try. Also try lower resolution. Try turning off all the back ground programs that takes up your CPU. Good luck to you.
m
0
l
July 15, 2012 1:43:18 AM

AA is set to 2 how do i turn it off? My drivers are up to date also. I turn everything in background off and also run GameBooster to insure everything in background is off.

I kinda figured my cpu was bottlenecked and was upgrading... maybe i'll take my money i planned on a sound card and put it towards a i3 2120 or i5 2400
m
0
l
Related resources
July 16, 2012 2:38:12 AM

Yeah get the i5 if you can upgrade it to the current MOBO. If not you will have to buy a new MOBO that will support the i3 or i5, i7. But when you got your current MOBO it said it supports i3, i5, and the i7 CPU's.

AA can be shut off in your CCC where in there I have no idea. I have never owned a AMD GPU. A lot of times in the games you can shut the AA off in game settings.

If you think it is a lack of a sound card, have you tried to update your sound drivers that are integrated into your MOBO? Also is any of the games a Steam game? If so have you tried the Verify Integrity of Game Cache?

Here is how you do if you don't know how. Good luck hope to hear back from you.

NOTE: When in Steam, left click on Games. Then left click on view Games Library. Right click on the Game. Then left click on properties. Then left click on local files. Then left click on Verify Integrity of Game Cache.
m
0
l
July 16, 2012 4:02:01 PM

yeah my mobo is 1155 socket so it can run the i3 / i5. my mobo sound drivers are also up to date. And skyrim is a Steam game, but BF2 BC is not. I have recently varified my game cache on skyrim though so i know thats not the cause.

So i suppose i do need to get a sound card.
m
0
l
July 16, 2012 8:29:09 PM

is your sound set to surround or something similar with realtek built-in audio?
m
0
l
July 17, 2012 12:38:11 AM

Yeah I agree with you and if it turns out not to be the sound card you can always return it. But AntiZig is very good when it comes to these problems so get the answer back to him.

If you can and after you talk with AntiZig try OC'ing your CPU and un OC your GPU and only do that if all else fails. Don't give up there is a fix. I know how frustrating it can be. Good luck.
m
0
l
July 17, 2012 5:16:29 AM

AntiZig said:
is your sound set to surround or something similar with realtek built-in audio?


No i have it set to stereo and the sound quality is set to 24bit 48000 Hz



m
0
l
July 17, 2012 2:02:07 PM

try lowering it to 44100hz
m
0
l
July 19, 2012 3:46:20 AM

ha, that seemed to fix it, though sometimes when casting fire i get a small freeze for a split second. I think i might upgrade my memory instead of getting a sound card. I use a lot of mods on it so i think i would benifit more from memory atm.
m
0
l
!