Sign in with
Sign up | Sign in
Your question

Strange lag issues with high fps - MW3

Last response: in Video Games
Share
July 24, 2012 8:25:31 PM

I'm playing on 1600x1200 with everything set to high. Fraps is showing 50-60 fps. I'm experiencing choppy gameplay when trying to shoot at an enemy, look at smoke or run into random high textured gfx. I shouldn't have this problem. my specs are as followed:

i5 2500k
p8z68
6950 2gb
windows 7

any ideas?
July 24, 2012 8:34:48 PM

Are you checking your fps DURING these smoke sequences? Try disabling vsync and make sure there is no triple-buffering availability for the game, if there is make sure that is disabled.
m
0
l
July 24, 2012 8:36:55 PM

you should be getting way more than 50-60 fps, you should be able to max it out...
make sure you have textures on native in the options and turn shader warming off if its on.(ati cards dont use it) also max fsaa is x4 and lock vsync on and tripple buffer is enabled in ati panel (only when vsync is on). max everything else and you should get a rock solid 60 fps on every map. reason being you should be getting about 100 minimum with that card on that game at that screen size.
i know this because i do with my 5870.
it may well be fraps thats causing the ingame lag. try using a different program like bandicam or camstudio.
m
0
l
Related resources
July 24, 2012 8:45:31 PM

HEXiT said:
you should be getting way more than 50-60 fps, you should be able to max it out...
make sure you have textures on native in the options and turn shader warming off if its on.(ati cards dont use it) also max fsaa is x4 and lock vsync on and tripple buffer is enabled in ati panel (only when vsync is on). max everything else and you should get a rock solid 60 fps on every map. reason being you should be getting about 100 minimum with that card on that game at that screen size.
i know this because i do with my 5870.
it may well be fraps thats causing the ingame lag. try using a different program like bandicam or camstudio.


no I only ran fraps once to see if my fps was really low, it's not. what do you mean by this "also max fsaa is x4 and lock vsync on and tripple buffer is enabled in ati panel (only when vsync is on)". I don't understand. turn vsync on? off? what other options should I change?
m
0
l
July 24, 2012 8:46:26 PM

Quote:
I get a solid game capped 91fps, and this does not change at all during play at the maximum cranked settings, with 1920x1080 res.

That 6950 should make MW3 look like child's play.


there are hundreds of threads on steam forums talking about this issue. even people with 570s and 580s are experiencing this. Single player is flawless, it's only in multiplayer...
m
0
l
July 24, 2012 9:09:33 PM

can anyone else decipher what hexit was saying to me in my post?

"also max fsaa is x4 and lock vsync on and tripple buffer is enabled in ati panel (only when vsync is on)"
m
0
l
July 24, 2012 10:12:49 PM

He was telling you to make sure you don't go beyond 4x FSAA, and don't have Triple Buffering enabled unless you have Vsync enabled, and only certain directx programs can actually use triple buffering anyway (it requires a work-around that some games come from the ground up with). You can force those features on/off in ati control panel (catalyst control panel, ati-tray tools, whichever you use).
m
0
l
July 25, 2012 2:22:38 AM

thanx for that. i was half asleep when i posted it sorry...
sometimes you can force vsync on outside the game and even though its off in the games own settings. this makes the gfx card use its own vsync routine instead of the games. it can be more efficient because it uses direct draw not direct x which allows you to enable tripple buffering. it can have the opposite effect and cause perfomance to droop but its always worth trying just in case.
you can also try ati tray tools to forc these options. tripple buffer forced with ati tray tools forces it on in direct x even though its not officially supported...(from what i gather)
these are just tips and trick that help get smooth gameplay and can be applied to most any game on ati hardware.

m
0
l
!