Closed

Age of Empires II DirectDraw Error

I have installed Age of Empires II: Age of Kings on my fairly new Dell, but after installing I get an error stating "Could not initialize graphics system. Make sure that your video card and driver are compatible with DirectDraw." I have already tried running the program in compatibility mode, disabling desktop composition, running in 256 colors, and I have updated my video card drivers as well as DirectX. I have also installed DirectX End-User Runtime, and have manually downloaded and installed DirectX 9.0c, but to no avail.

Specs:

Windows 7 Home Premium
Inspiron 570 64-bit
AMD Athlon II X2 245 Processor, 2900 Mhz, 2 Cores, 2 Logical Processors
4 GB of RAM
ATI Radeon HD 4200 updated to Catalyst 12.6


It may also be worth mentioning that my cousin just bought a brand new laptop that has an AMD Radeon 6520g card, and is able to play the game right out of the box.

Is there anything else I can try?

Sincerely,

David
22 answers Last reply
More about empires directdraw error
  1. I have the Exact same issue.
    What is more interesting is it is working on my Other computer with Windows 8 Consumer Preview version, But not with Windows 7 64-Bit. I Wonder if 64-bit has anything to do with it or my PC's Video Card.
  2. This suggestion below worked (Though not the best solution).

    totticrack replied on July 20, 2011
    I've solved it. Went to Device Manager and disabled my graphic card, then restarted Windows. Then, played perfectly well. When I finish playing, I go back to device manager and enable my graphic card.
    The problem is due to newer graphic cards being unable to display in 640x480 resolution.
    PS: Don't trust this Microsoft "Experts"... They ask things like "Are you sure you meet the minimum requirements?" OF COURSE YOU IDIOT, I'M RUNNING A 1999 GAME ON A 2009 COMPUTER!!! They bring the worst out of me

    http://answers.microsoft.com/en-us/windows/forum/windows_other-gaming/could-not-initialize-graphics-system-make-sure/f81ab88a-5873-4617-b801-fef211abf12b?page=1
  3. I have a simpler workaround that involves creating a simple txt file that you then use to execute the game. It works perfectly on Win 7 x64, no restarts required.

    I will dig it up when I get home, provided I remember. :-)
  4. Herr_Koos said:
    I have a simpler workaround that involves creating a simple txt file that you then use to execute the game. It works perfectly on Win 7 x64, no restarts required.

    I will dig it up when I get home, provided I remember. :-)


    So.. Did you dig it up?
  5. Nope, no-one reminded me. Since OP never came back I assume he solved the problem himself.
  6. Hello David

    I have the same problem. disabling the video card doesn't work on my system. I'm running a windows 8 system with a radeon 7570 card.

    Did you ever get your system working?
  7. Herr_Koos said:
    Nope, no-one reminded me. Since OP never came back I assume he solved the problem himself.


    Can you share it with us, please? I have the same problem
  8. I may have been mistaken; the workaround I was referring to fixes the colour problem in Windows 7, not the DirectDraw error. You could try it though; it basically consists of killing explorer.exe, running the game, and the restarting explorer afterwards.
  9. Herr_Koos said:
    I may have been mistaken; the workaround I was referring to fixes the colour problem in Windows 7, not the DirectDraw error. You could try it though; it basically consists of killing explorer.exe, running the game, and the restarting explorer afterwards.


    Oh, the Diablo hack. Theres other ways around that other then killing explorer (I forget them offhand though).

    The root issue here is that 16-bit code CAN NOT EXECUTE on 64-bit; MSFT intentionally did not include the 16-bit emulation layer on these versions of Windows. This ended up breaking DirectDraw (which has LONG been depreciated).
  10. Weil I bought the AoE Gold pack (boxed edition with AOE 1 and 2 plus expansions) and it runs just fine in Win 7 x64. Could they maybe have switched to a 32bit installer with that?
  11. I'm having a problem with it starting to start and then erroring out with "Could not initialize graphics system. Make sure that your video card and driver are compatible with DirectDraw."

    I'm running Win 7 Home Premium SP1 64-bit.

    Any suggestions?
  12. Here http://www.forosuse.org/forosuse/archive/index.php/t-12172.html , the user drews_blunted give this solution:

    Simply run "wine /path_to_AOE2_executable/empires2.exe -- -opengl"

    Whitout the quotes, and thats all. Some text blink in the game, but thats not big deal...

    NOTE: I installed the game whitout DirectPlay, decause i going to play against the AI. My version of wine is 1.0.1, and im using Debian Squeeze.

    Bye.
  13. and... you can now buy AoK on steam, and it will have steamworkshop and steam multiplayer support! (only 20 USD) it also fixes the color problems and directdraw errors.
  14. Carlitos2000 said:
    Here http://www.forosuse.org/forosuse/archive/index.php/t-12172.html , the user drews_blunted give this solution:

    Simply run "wine /path_to_AOE2_executable/empires2.exe -- -opengl"

    Whitout the quotes, and thats all. Some text blink in the game, but thats not big deal...

    NOTE: I installed the game whitout DirectPlay, decause i going to play against the AI. My version of wine is 1.0.1, and im using Debian Squeeze.

    Bye.


    This is a Linux-based solution though, all the other posters (including me) seem to be running Windows...
  15. CarolKarine said:
    and... you can now buy AoK on steam, and it will have steamworkshop and steam multiplayer support! (only 20 USD) it also fixes the color problems and directdraw errors.


    Quire excited about this, means I can finally multiplayer AoE2 again!
  16. I bought the HD version today from steam and get the same directdraw error message. I tried disabling my graphics card and restarting as suggested above but now it says "Unable to initialize graphics system. Device may not meet munimum specs. Subcode=1" I am running a pretty old win xp sp2 on a macbook bootcamp. I play Left 4 Dead on the same laptop on steam without any issue. It sounds like the problem is due to most of us having way advanced graphics card compared to the game, which is why I thought disabling it might work for me. But then again this is the HD version so wouldn't it use a more modern graphics card? Anyway I am no expert, just someone who wants to play AOE and feel nostalgic. If anyone else has any suggestions it would be greatly appreciated
  17. After browsing a lil, I found the support site for AOE HD version. And there are already tons of threads. gonna see if I can dig up any solution to this particular problem. heres the link
    http://steamcommunity.com/app/221380/discussions/2/
  18. Cool, let us know if you find anything.
  19. Herr_Koos said:
    I may have been mistaken; the workaround I was referring to fixes the colour problem in Windows 7, not the DirectDraw error. You could try it though; it basically consists of killing explorer.exe, running the game, and the restarting explorer afterwards.


    how do i restart explorer.exe afterwards?? ending it using the task manager worked & now I can play AOE II, but now i don't know how to start explorer.exe again.
  20. annabelle766 said:
    Herr_Koos said:
    I may have been mistaken; the workaround I was referring to fixes the colour problem in Windows 7, not the DirectDraw error. You could try it though; it basically consists of killing explorer.exe, running the game, and the restarting explorer afterwards.


    how do i restart explorer.exe afterwards?? ending it using the task manager worked & now I can play AOE II, but now i don't know how to start explorer.exe again.



    You can use Task Manger for this as well; select New ?open Task (something like that) and just type explorer.exe
  21. the DirectDraw got fixed when i disabled my graphics card. but then when i started a random map game i could not play becauce of the resolution. any way to fix this.
  22. I found a very simple way to fix this problem on windows XP 32bit. simply find your .exe file to launch the game, (mine being empires.exe)
    right click it, goto properties, then Compatabality tab and make it run on 640x480 screen resolution, then apply and run the .exe :D
    plays perfect for me!
Ask a new question

Read More

PC gaming Video Games