Cursor keeps moving down

I have a problem with my mouse cursor. In some games it keeps moving down. It suddenly began doing it. It wasn't a problem when I installed windows 7. It is primarily a problem in the games that come with Windows 7, so I've been ignoring it, but I can't play Fallout New Vegas because the cursor problem occurs in that game as well. I have a Logitech MX 620 mouse. I have tried to pull out the batteries to see if that helped, but it didn't. I tried to unplug the mouse to see if that helped, but it didn't. I tried installing Setpoint, but it didn't change anything. Does anyone know what I can do to get rid of this really annoying problem?
Reply to billward
20 answers Last reply
More about cursor moving down
  1. go to control panel and double click mouse. Go to POINTER OPTIONS and un-check ENHANCED POINTER PRECISION. That should help...

    I hope this helps!

    Brett M,
    Windows Outreach Team
    Reply to bmathews
  2. I've tried that, but it doesn't help.
    Reply to billward
  3. I have two mice connected to my system because I sometimes switch hands depending on what I'm doing & one of my mice is right-handed only. Every once in a while one of the mice goes a little funky and starts moving the cursor on its own. When this occurs and I'm using the other mouse, it's really hard to figure out what the heck's going on - but a little bump of the other mouse solves the problem.
    Reply to sminlal
  4. But I only have one mouse connected.
    Reply to billward
  5. I tried connecting another mouse instead of my Logitech mouse, but that didn't help. When I disconnected it and connected my old mouse the cursor went all the way to the top left corner of the screen. I had to restart my computer to solve that.
    I have tried to scan the computer with ad-aware, Spybot and my anti-virus program Kaspersky and none of them found any malicious software on my computer.
    Reply to billward
  6. I managed to fix it by removing the mouse and deleting the driver in device manager or whatever it's called in the English version of Windows. I then plugged in another mouse and had Windows install that and then I unplugged it and plugged in my Logitech mouse. Now the problem has gone away.
    Reply to billward
  7. Strange to think that the driver would do something like that...

    Thanks for posting the solution you found!
    Reply to sminlal
  8. I tried removing the mouse in device manager. forgot to delete the driver though, and it kept doing it. But i did go into mouse settings and I ENABLED my mouse pointer precision and it went away. no more problem ;-p
    Reply to DaRAGingLunatic
  9. billward said:
    I have a problem with my mouse cursor. In some games it keeps moving down. It suddenly began doing it. It wasn't a problem when I installed windows 7. It is primarily a problem in the games that come with Windows 7, so I've been ignoring it, but I can't play Fallout New Vegas because the cursor problem occurs in that game as well. I have a Logitech MX 620 mouse. I have tried to pull out the batteries to see if that helped, but it didn't. I tried to unplug the mouse to see if that helped, but it didn't. I tried installing Setpoint, but it didn't change anything. Does anyone know what I can do to get rid of this really annoying problem?
    Reply to stefin n
  10. Go to computer properties right click select mange then device manger click it mouse pointer and other devices then disable extra mouse point device rather than you are using if you are facing problem with that please contact me through mail [removed]

    Do not post your personal e-mail address. If you want to contact the OP privately use the PM function for that. - G
    Reply to stefin n
  11. SOLUTION !!! SOLUTION !!!! SOLUTION!!!!!


    hey buddy..i had the same problem..n i was fedup ....i couldn't find the solution .....until i did what was

    necessary to do .......u could go ahead with all the other solutions found online and if that hasn't worked out this is the final step u need to take ......to get rid of it


    what i did:


    1) u need to disable the page up and page down key from the keyboard.....(in my case the scroll would go down always so i only disabled the page down button)


    2) mind u once u have disabled the particular key ;the key wount work , also u can turn the key back on manually later.....so changes not permanent


    3) now u can see the tutorial from this site


    link: http://www.youtube.com/watch?v=uId_uyirZU4


    4) or follow this steps

    1.downlad sharpkeys software (its free and direct download) version 2.1.1

    2.install it .....open it (i'm assuming u know u least know that )

    3.click on 'add' botton

    4.a window 'll pop up, click on 'type keys'

    5.press the page up or page down button or both

    6.press ok

    7.now click on write to registry and voila

    its done....

    8.just restart the damn pc and the problem should be gone .....


    note :this process will disable ur page up/down button bt will also the solve ur problem....so do it at ur own risk (its the hard way bt it works)


    ciao!!!
    Reply to sas12345
  12. I encountered the same issue today with my Logitech m525 wireless mouse, fortunately I resolved what was the issue. The batteries has slightly leaked onto the circuit board into the mouse. I resolved the problem by cleaning up all the interior of the mouse with rubbing alcohol and q-tip. Now it works perfectly.

    Hope that help someone else that encounter the same issue.
    Reply to marssien
  13. bmathews said:
    go to control panel and double click mouse. Go to POINTER OPTIONS and un-check ENHANCED POINTER PRECISION. That should help...

    I hope this helps!

    Brett M,
    Windows Outreach Team
    Reply to venkatesh venky
  14. un check "enhanced pointer precision" doesn't work for the problem
    if there are any other alternatives for the problem, post it here
    Reply to venkatesh venky
  15. I use a wireless mouse and an optical wired mouse. I spent a lot of time scanning for malware and reading a long list of 'fixes' , many of which I tried before giving up my optical wired mouse for dead, and seeking out my wireless mouse to see if it might serve as a permanent alternative. It was then that I realized I had last left my wireless mouse on an uneven surface. I put it back on an even surface, and my problem with my optical wired mouse disappeared. Obviously, not the solution for most, but I liked it.
    Reply to gwmc7e
  16. Remove all mouse drivers and start over
    Reply to navybuff
  17. I tried everything (scanned for a virus? replaced bad driver? upgraded old driver? incompatible OS? incompatible laptop?)... and found this mouse to be extremely fragile. Same thing happened when I bought an MX Anywhere mouse. After a few months ... same thing started happening. I got it replaced ... and after a few months again... same mouse drift.

    Anyhow - long story short... flipped the mouse over to re-seat the battery and shake the mouse back to its senses. I looked a little closer at the mouse lens and saw a small (gray) chip around the refracting surface just below the optical sensor. I recalled this used to be completely black.

    My .25 cents solution: Pulled out the trusted black Sharpie and colored over the gray chipped area. Its been 6 weeks now and surprisingly no recurring issues.

    Another quick note: DON'T DROP YOUR MOUSE.

    Hope this helps someone.
    Reply to Nappzter
  18. bmathews said:
    go to control panel and double click mouse. Go to POINTER OPTIONS and un-check ENHANCED POINTER PRECISION. That should help...

    I hope this helps!

    Brett M,
    Windows Outreach Team


    billward said:
    I've tried that, but it doesn't help.


    So I have been having this problem too. I have a gaming laptop and i like to play with the computer screen. but I also like to play with my monitor. When I play Minecraft on the computer screen, it messes up. I move my players head around, stop, and it keep dragging very slowly on its on. This also happens in the program Cinema 4D. Whenever i plug into my monitor, everything is fine. I usually like to use my laptop screen more though. So I followed Bmatthews' tip and went to turn on Enhance pointer precision, and I found that it was already on. And when i turned it off, I could play Minecraft and Cinema 4D without the drag! Maybe this will work for you too... Goodluck!

    ~Michael
    Reply to Michaelp3712
  19. So I have been having this problem too. I have a gaming laptop and i like to play with the computer screen. but I also like to play with my monitor. When I play Minecraft on the computer screen, it messes up. I move my players head around, stop, and it keep dragging very slowly on its on. This also happens in the program Cinema 4D. Whenever i plug into my monitor, everything is fine. I usually like to use my laptop screen more though. So I followed Bmatthews' tip and went to turn on Enhance pointer precision, and I found that it was already on. And when i turned it off, I could play Minecraft and Cinema 4D without the drag! Maybe this will work for you too... Goodluck!

    ~Michael
    Reply to Michaelp3712
  20. Some laptops have the dual mouse option built in and this is nothing to do with your external mouse. The touch pad and Accupoint (i.e the small pointing stick in the middle of your keyboard) may have issues running concurrently.

    Go to mouse controls/ advanced/ advanced features settings/ device select/ then deselect Accupoint. This seemed to work for me. I never used the pointing stick control and have always felt it was a little redundant.
    Reply to FordGT
Ask a new question Answer

Read More

Cursor Windows 7 Games