Sign in with
Sign up | Sign in
Your question

Fallout 3 Crashes

Last response: in Video Games
Share
July 31, 2012 8:11:48 AM

Hi guys

I am having a problem where Fallout 3 crashes my computer so the screen looks like this http://s18.postimage.org/dnr75gtg9/2012_07_31_19_51_32....

It happens when I go into VATS and it has suddenly started happening very close to when I start the game, before it would take a few hours.

Everything keeps running in the background like I can still talk on skype, but the screen is locked up and I have to force restart the computer to fix it.
I know it's not overheating or anything like that because if I check temps while I am playing they are fine, around normal for my graphics card. I also don't think it is a hardware problem because this hasn't happened in any other games. I have done the tweaks so that it will run alright on Windows 7 but they haven't fixed it. I also have rolled back drivers and tried 12.6 and 12.7. Neither helped

Specs:

Win 7 Home Premium 64bit
i5 3570k
Asus Radeon 7970 Direct Cu ii Top
8gb 1600mhz RAM
64gb Crucial M4
2tb Seagate Barracuda 7200rpm
Asus P8Z77-V LK
OCZ ZX850W Gold PSU


I think I remembered everything I needed to tell you but if I missed anything let me know.


Thanks for any help.

More about : fallout crashes

Anonymous
July 31, 2012 8:27:54 AM

There's a problem with quad core cpus.. easy fix. Can't remember what it is but if you google it..
July 31, 2012 8:42:45 AM

Quote:
There's a problem with quad core cpus.. easy fix. Can't remember what it is but if you google it..

Yeah I've tried that, it didn't fix it.
Related resources
July 31, 2012 8:47:39 AM

^^ go to Documents/My Games/Fallout3 and edit Fallout.ini with notepad or whatever you like. Under general put:
iNumHWThreads=4
4 would be 4 threads (4 cores or two cores 2 w/ hyper threading)

I'm not exactly sure why that would fix the problem but I have heard that people with quad core CPUs sometimes set that to 2 to limit it to only two cores and it fixed many crash problems.

EDIT: sorry didn't see your post before I wrote mine! Is that what you tried? ^
July 31, 2012 9:21:01 AM

iyzik said:
^^ go to Documents/My Games/Fallout3 and edit Fallout.ini with notepad or whatever you like. Under general put:
iNumHWThreads=4
4 would be 4 threads (4 cores or two cores 2 w/ hyper threading)

I'm not exactly sure why that would fix the problem but I have heard that people with quad core CPUs sometimes set that to 2 to limit it to only two cores and it fixed many crash problems.

EDIT: sorry didn't see your post before I wrote mine! Is that what you tried? ^

Yeah that's the one I have tried. I'm not sure it is the same problem because from what I people have said about that crash it doesn't crash the computer, just the game.
July 31, 2012 4:20:33 PM

Ok, I used to have this problem I think telling the game to use threaded AI and a mixture of that and limit it to 2 cores is what fixed it.
Fallout.ini add the
iNumHWThreads=2
as well as change or add:
bUseThreadedAI=1

Not sure why I couldn't remember that one earlier. I did not have the same CTD semi freeze problem but mine would freeze up after a few minutes and this tweak definitely fixed it for me.
July 31, 2012 9:34:09 PM

iyzik said:
Ok, I used to have this problem I think telling the game to use threaded AI and a mixture of that and limit it to 2 cores is what fixed it.
Fallout.ini add the
iNumHWThreads=2
as well as change or add:
bUseThreadedAI=1

Not sure why I couldn't remember that one earlier. I did not have the same CTD semi freeze problem but mine would freeze up after a few minutes and this tweak definitely fixed it for me.

Tried that one too, it didn't work. Thanks for the suggestions though.
August 2, 2012 12:47:39 PM

I tried everyting that I could find on the internet: Ini file .Net Frameworks, K-lite pack, compatibility mode, turning of visual themes and desktop composition, dll file, turning off autosaving, not using quicksaving, forcing V-sync off, patching away Windows Live Gaming or something, turning off my mods, cleaning my registry, clear cache memory with ~PBC, the thing with ffdshow, updated my graphic drivers, updated my sound drivers, and some other stuff I must have forgotten. Worked on it for 4 days now.

And now: after installing: Large Adress Aware Enabler for FO3 and Error Corrections Reduce CTD at Fallout Nexus: no more crashes. I think the trick was that the game was heavy for my memory, game uses my 4 GB memory now.
August 2, 2012 4:15:32 PM

passenger1978 said:
I tried everyting that I could find on the internet: Ini file .Net Frameworks, K-lite pack, compatibility mode, turning of visual themes and desktop composition, dll file, turning off autosaving, not using quicksaving, forcing V-sync off, patching away Windows Live Gaming or something, turning off my mods, cleaning my registry, clear cache memory with ~PBC, the thing with ffdshow, updated my graphic drivers, updated my sound drivers, and some other stuff I must have forgotten. Worked on it for 4 days now.

And now: after installing: Large Adress Aware Enabler for FO3 and Error Corrections Reduce CTD at Fallout Nexus: no more crashes. I think the trick was that the game was heavy for my memory, game uses my 4 GB memory now.


Wow you sure tried a lot of different things, those Large Address Aware mods for Beth games from Nexus are always helpful :) 
Good to know you figured it out by yourself! Congrats!
August 2, 2012 9:30:23 PM

passenger1978 said:
I tried everyting that I could find on the internet: Ini file .Net Frameworks, K-lite pack, compatibility mode, turning of visual themes and desktop composition, dll file, turning off autosaving, not using quicksaving, forcing V-sync off, patching away Windows Live Gaming or something, turning off my mods, cleaning my registry, clear cache memory with ~PBC, the thing with ffdshow, updated my graphic drivers, updated my sound drivers, and some other stuff I must have forgotten. Worked on it for 4 days now.

And now: after installing: Large Adress Aware Enabler for FO3 and Error Corrections Reduce CTD at Fallout Nexus: no more crashes. I think the trick was that the game was heavy for my memory, game uses my 4 GB memory now.

I'll try that out on mine when I get home, hopefully it works!
August 4, 2012 3:13:33 AM

Sadly those fixes didn't work for me. I also noticed that the color the screen goes when it crashes changes depending on the lighting in the part of the game I am in.
!