Sign in with
Sign up | Sign in
Your question

Running TF2 with Swiftshader closes the game

Tags:
  • PC gaming
  • Games
  • Video Games
Last response: in Video Games
Share
August 4, 2012 4:57:41 AM

To get this out of the way, here are my specs:
Dell Inspiron 530
Windows Vista Home Basic Service Pack 2, 32-bit
Intel Celeron CPU 450 @ 2.20 GHz
2.00 GB RAM
Intel G33/G31 Express Chipset Family

It's crappy and not meant for games, I know.

Now, I've been looking around for a few ways to improve my FPS in Team Fortress 2. I actually managed to get it to around 25-ish FPS, dropping to 5-15 FPS at completely random times.
One thing I have not tried, however, is using Swiftshader. So I downloaded Swiftshader 3.0 and put my d3d9.dll file in my C:\Program Files\Steam\steamapps\username\team fortress 2\bin folder.

The Valve and Source logos are shown, and then... the game closes. No error is shown, I'm just back at my desktop.

Did I do it right? Should I edit a setting in my Swiftshader.ini file? I am using -dxlevel81. Would that affect anything?

More about : running tf2 swiftshader closes game

September 4, 2012 2:09:36 PM

Try to run TF2 in windowed mode by typing in command line -window -noborder
It helped for me and i hope will help you too =)
m
0
l
September 5, 2012 11:58:21 AM

Turn off windows aero desktop theme, and use the windows classic theme instead. Aero seems to use gpu/cpu some, so that might improve your fps too.
m
0
l
!