SC2 Framerate Drop

I know this question has been asked a hundred times, and I've gone as far as I can looking around in other threads. I need help specifically for my PC. Basically the game works fine (all graphics on lowest possible settings) until more than, idk, maybe 6 hundred units are on the visible map. Basically if I'm playing 3v3, by the time I've amassed half an army and all players clash, fps drops to 1.

I have an Asus Laptop
Model: ASUS Notebook K53SJ, K53SV, K53SC Series
Processor: Intel(R) Core(TM) i5-2410 CPU @ 2.30GHz
RAM: 6GB
System Type: 64-bit
Graphics: NVIDIA GeForce GT 540M

A few things I've tried already:
Under "Select PhysX processor" I set it to GeForce GT 540M
Under "Manage 3D Settings" I set "Multi-display/mixed-GPU acceleration" to "Compatibility performance" (helped a little)
I added: "frameratecap=60 frameratecapGlue=30" to the variables.txt file in Documents>>Starcraft II

I don't think overheating is the problem because I play with a fan next to me blowing on the comp (maybe I'm ignorant and that doesn't actually help but it doesn't Feel too hot haha). In the process of trying to download EVGA Precision but the site isn't responding
11 answers Last reply
More about framerate drop
  1. Bump!
  2. Download HWMonitor and check temperatures with it when FPS drops. I think it will be more accurate than your feelings :).
  3. KK, took 2 while playing when the framerate dropped, didn't use my fan since I'd like to be able to play without it haha.
  4. could you check CPU usage through task manager and GPU usage through msi afterburner when the fps drops?

    MSI afterburner link: http://event.msi.com/vga/afterburner/overview.htm
  5. this is nothing out of the ordinary, SC2 is known to bring down even desktop processors to the knees when you have bajillion units on the screen. Your options are either to play smaller games (2v2) or upgrade to a desktop.

    see here for reference:
    http://www.tomshardware.com/reviews/best-gaming-cpu-core-i3-2100-phenom-ii-x6-1075t,2859-8.html
    (sadly I cannot find the article that described the SC2 test in detail, but it was something like they slapped 300 units on the same screen resulting in a gian cluster-F, which they then run for like 10-30 secs)

    also, this is a review on mobile chipsets:
    http://www.tomshardware.com/reviews/a8-3500m-llano-apu,2959-10.html

    You can try lowering your resolution, if you can tolerate it, it might help a little.
  6. AntiZig said:
    this is nothing out of the ordinary, SC2 is known to bring down even desktop processors to the knees when you have bajillion units on the screen. Your options are either to play smaller games (2v2) or upgrade to a desktop.

    see here for reference:
    http://www.tomshardware.com/reviews/best-gaming-cpu-core-i3-2100-phenom-ii-x6-1075t,2859-8.html
    (sadly I cannot find the article that described the SC2 test in detail, but it was something like they slapped 300 units on the same screen resulting in a gian cluster-F, which they then run for like 10-30 secs)

    also, this is a review on mobile chipsets:
    http://www.tomshardware.com/reviews/a8-3500m-llano-apu,2959-10.html

    You can try lowering your resolution, if you can tolerate it, it might help a little.


    Already on lowest resolution and graphics settings :/. Idk, I hear a lot of people get this problem fixed so i feel like there's some way to help it besides getting an entirely new computer just to play 1 game....

    Sunius said:
    could you check CPU usage through task manager and GPU usage through msi afterburner when the fps drops?

    MSI afterburner link: http://event.msi.com/vga/afterburner/overview.htm


    Downloaded, will post pic later today
  7. It looks like your graphics card is going to power saving mode! Notice how Core clock drops to half. Go to Nvidia control panel and in 3D settings select "Prefer maximum performance".
  8. Sunius said:
    It looks like your graphics card is going to power saving mode! Notice how Core clock drops to half. Go to Nvidia control panel and in 3D settings select "Prefer maximum performance".


    Could you please be more specific where to find that? 3D Settings>>??>>??
  9. Sunius said:


    Thank you! Will try it out and post results later!
Ask a new question

Read More

PC gaming Video Games