Sign in with
Sign up | Sign in
Your question

MSconfig changes in Window 7

Last response: in Windows 7
Share
October 20, 2009 5:29:12 AM

Hi
i have window 7 test version installed
however When i tried to install Act of war: Direct action, it didn't work
and since i have herd how the game does not like more than 3 GB of rams i change the MSconfig settings and set a limit on the memory from the Advance options

after i restarted my computer
it crashed...
and i am unable to undo the msconfig changes, because i am unable to access msconfig

i have tried to boot into safemode and load msconfig, however it says i do not have the privileged to access msconfig...
i have tried the automatic repair in window 7... and it didn't work

anyother ways to undo it?

i have a lot of accessments in the C: drive which i have not backed up

any help would be appreciated
thanks
ron

More about : msconfig window

October 20, 2009 5:54:36 AM

System restore ?
October 20, 2009 6:25:00 AM

Tried it, dosen't work
seems it only restore changes that was made by programs

and i didn't do a system image back up...

mistake in my previous post:

Safe Mode crashes, seem i was loading in to the recovery mode(from the recovery CD)

so i only have access to recovery mode command prompt which does not have privilege access to MSconfig

any ways to change the values directly? i mean msconfig only changes .ini files
if i know the correct .ini file to look for, i might be able to change the value directly

or can i do a replacement on the msconfig?

really not having a good day...
Related resources
October 20, 2009 7:27:45 AM

You should have several restore points in System Restore. Have you tried restoring to an even earlier restore point, one which was saved before you made the changes via msconfig.
October 20, 2009 10:11:44 AM

yes, i have tried to restore to older restore points, same problem occurs

i don't think that value get backed up... and can be restored
i guess the only way is to reinstall the OS...
October 20, 2009 1:21:35 PM

Don't know if this will work, but try to run DOS cmd as administrator (right click on DOS cmd in accessories and choose "Run as administrator"). Then launch msconfig from the new DOS cmd that appeared and you should have the administrator rights. If it doesn't then you can't do anything or maybe you did something wrong in the process.
October 20, 2009 1:25:14 PM

The game install probably works but you have to do it different for Win7 applications that are older (and some that are not even that old, i found out). I had this problem with several games, and finally figured it out.

when installing, dont use auto run that boots from the installation disk. close auto run, open the installation disk in folder and find the 'setup' application.

Win7 has a compatability mode. You have to install the game with the compatability mode method.

Right click on the 'setup' application, then use the compatability mode to install.
October 20, 2009 1:54:43 PM

I don't think you need to go that as far as running compatibility mode on the setup of the game as OneHumongousLoser suggest.

You should be able to install all games normally then you use the compatibility mode on the game's exe when you run it.
October 20, 2009 1:59:28 PM

you will know quick if you can install or not. you cant install them to begin with, you get an error message and game wont install at all. So you have to use the compatability mode to install them. After that, never an issue.
October 20, 2009 5:27:26 PM

OneHumongousLoser said:
you will know quick if you can install or not. you cant install them to begin with, you get an error message and game wont install at all. So you have to use the compatability mode to install them. After that, never an issue.


That rings a bell, you might be right for that one. Just don't forget to adjust compatibility for the game's exe after the install, the setup compatibility option won't do much for you when you'll be running the game.
October 20, 2009 6:37:43 PM

I had the problem with several games, and just installed per above and dont have problems (not yet anyway haha), and they supposedly run forever in that 'mode'. How do you adjust for compatability with games exe after install?
October 20, 2009 7:11:14 PM

OneHumongousLoser said:
I had the problem with several games, and just installed per above and dont have problems (not yet anyway haha), and they supposedly run forever in that 'mode'. How do you adjust for compatability with games exe after install?


Same as with setup, just go to Program Files and right click on the game's exe. Select "Properties" and there should be a tab "compatibility".

You might be right for the setup, maybe the game's exe retain the setup compatibility mode, I never tried it, so I couldn't vouch it doesn't work. But just to be on the safe side, I would verify it after installing a game that way.
October 20, 2009 8:47:24 PM

Quote:
Don't know if this will work, but try to run DOS cmd as administrator (right click on DOS cmd in accessories and choose "Run as administrator" ). Then launch msconfig from the new DOS cmd that appeared and you should have the administrator rights. If it doesn't then you can't do anything or maybe you did something wrong in the process.


i do not have anything to right click to, the command prompt is loaded from the recovery CD, hence it is running in external mode, hence no admin rights

all the recovery stuff is done on x: drive(emulated by the recovery CD)
My OS would not boot correctly, blue screen of death after the window logo sign
that includes Safe Mode

Quote:
The game install probably works but you have to do it different for Win7 applications that are older (and some that are not even that old, i found out). I had this problem with several games, and finally figured it out.

when installing, dont use auto run that boots from the installation disk. close auto run, open the installation disk in folder and find the 'setup' application.

Win7 has a compatability mode. You have to install the game with the compatability mode method.

Right click on the 'setup' application, then use the compatability mode to install.


I had tried to run it in compatibility mode, and it didn't work, i am using x64bit OS and 12 GB of ram
October 20, 2009 9:21:55 PM

You mentionned you booted in safemode in your first post. It shouldn't log you into a DOS cmd, it should give you access to your desktop.

From there, you should be able to go in the menu and right click on DOS cmd to choose "Run as administrator".

Might be totaly mistaken about the whole safemode, but if my memories serves me right...
October 20, 2009 9:33:19 PM

My guess is that the changes are in one of three locations: System.ini, Win.ini,Boot.ini

You can try and see if you see the change and switch it back to the default setting.

This article discusses troubleshooting for XP, I figure it is probably similar.
http://support.microsoft.com/kb/310560
October 21, 2009 3:07:38 AM

Vista and Windows 7 does not use Boot.ini file anymore but it uses BCD. So to modify it you need to use the bcdedit program. If you need to disable the 3gb user mode RAM then take a look at this http://www.cadforum.cz/cadforum_en/qaID.asp?tip=5551 . I hope the command works in recovery console, if not I don't know :D  as I haven't screwed my computer up enough for that and I'm actually a unix admin.
October 21, 2009 10:20:25 AM

Thanks everyone for their effort

By booting into the repair disc's recovery mode
i was able to load bcdedit.exe

however i was not able to delete the IncreaseUserVa value just as stated in the http://www.cadforum.cz/cadforum_en/qaID.asp?tip=5551 forum

but i have used the bcdedit command /set and set the value to 1024

this value was valid, and i was able to boot into windows

this is taking a while, as 1 GB of ram for window7 is not enough (still loading as i am typing this)

Special thanks @thuan and @kamel5547
the msdn website taught me alot on bcdedit functions and the CAD forum showed the actually way to do it

@thuan: well i guess you can be a win admin too now

Ronald
October 21, 2009 10:23:11 AM

Found out what i did wrong

i have typed 3000000000 in to the MSconfig
since the units is in MBs it should have been 3072

August 8, 2011 12:41:40 PM

hi dears : the problem which I'm facing with my windows 7 that is : i wrote msconfig in run command then i decrease the timeout from 30 second to 3 second and i increased the number of processor from 1 to 4 then i restarted the computer so it does not bring the start up instead it shows this option
Launch start up repair(recommended)
start windows
so any one can help me in this regard i will thankfull...bcz all my prgrms are in c drive and in disktop and my windows is 7 64-bit...
and this is my email address:mustafa.ibrahimy@gmail.com
thanks dears...
!